Fanatec McLaren GT3 rim problems...

Discussion in 'Sim Racing Hardware' started by anton_Chez, May 27, 2018.

  1. Nada

    Nada

    Messages:
    2
    Ratings:
    +0
    It seem they know the problem now cause they give me RMA(repair) after 2 questions (have you last 311 drivers and are the others buttons, screen works?).
    I have miss shifting, miss downshifting and double downshifting after 1 week (mclaren with quick release).
     
  2. anton_Chez

    anton_Chez
    Premium

    Messages:
    1,274
    Ratings:
    +391
    Do you have the latest firmware installed on the rim? I wouldn't worry about anything unless you have upgraded the firmware on the rim to the latest possible version. It makes a difference.
     
  3. jpdribbler

    jpdribbler

    Messages:
    2
    Ratings:
    +2
    Thanks for your info.

    My paddles stopped working yesterday as well (using quick release). Other buttons are working. I have contacted Fanatec and they said they will replace the wheel now. I did a factory reset and flashed the latest firmware but this seems to be a technical/hardware issue. I am curious and afraid if the repaired or new wheel will have the same issue. I'll let you know.
     
  4. Nada

    Nada

    Messages:
    2
    Ratings:
    +0
    Yes i have latest drivers and firmware(311 firm 475 firm wheel 25).
    Before sending the wheel to RMA i make a reinstall of drivers but nothing change (still miss shifting.....).
    But now for about 4 days (4 sessions 1H PC2, AC) the problem is gone.
     
  5. mark scholes

    mark scholes

    Messages:
    3
    Ratings:
    +0
    I know this is an old question but I thought I should answer regardless as there may be other people considering this rim. I am on my 3rd wheel now, all have been used with the quick release and all, including the most recent one have developed the same issue. Miss shifting or double shifting. I am going to get this one collected as well as it is just as bed as the first one. I can't believe they are still selling it
     
    • Beer Beer x 1
    • Agree Agree x 1
  6. mark scholes

    mark scholes

    Messages:
    3
    Ratings:
    +0
    Have you had any further problems?
     
  7. johndough247

    johndough247
    Premium

    Messages:
    461
    Ratings:
    +274
    Nope no more problems. I use the fastening bolt every time, which is a 20 second hassle to install/remove each time, but the shifting hasn't failed since my last report.

    I'm planning on getting the new formula rim with the advanced paddle module when it's released. After I get that I'll send the Mclaren back to be fixed...I really like GT3/GTE/open wheel racing so I don't want to be without that type of wheel for too long.

    Did you ever try using the fastening bolt, or did you try tightening the bolts on the wheel and the wheel base? How long ago did you send wheel #2 back? If it was this month then maybe they haven't found a solution as yet :unsure:
     
  8. mark scholes

    mark scholes

    Messages:
    3
    Ratings:
    +0
    Yeah, I tried both the fastening bolt and tightening the screws and nothing has worked.
    They have just emailed me to say that they now think that it must be my wheel base. They are clutching at straws they've claimed to know what the problem is repeatedly and it's never right.

    There is obviously something seriously wrong with the product but they are still selling it. Worse thing is, there are people on forums from all over the world that are saying they have the same problems but it is not finacial worth it to pay to return it back to fanatec.
     
  9. johndough247

    johndough247
    Premium

    Messages:
    461
    Ratings:
    +274
    Sorry those solutions didn't help...yea, honestly I do think there's something defective in the design that they're not admitting to. Maybe they've corrected it in the latest batches...who knows. At this point maybe you could ask them to exchange it for a different product (and you cover the difference in price)?
     
  10. anton_Chez

    anton_Chez
    Premium

    Messages:
    1,274
    Ratings:
    +391
    It's a spew though because that rim is awesome for the price. But maybe 50 bucks in higher quality parts would have resulted in a much better product.
     
  11. Tardy Tony

    Tardy Tony
    Premium

    Messages:
    192
    Ratings:
    +47
    My GT3 shifters failed too. Hardware. Getting it refunded.
     
    • Like Like x 1
  12. jpdribbler

    jpdribbler

    Messages:
    2
    Ratings:
    +2
    Fanatec repaired my GT3, no issues anymore (yet)
     
    • Like Like x 2
  13. Xero

    Xero

    Messages:
    22
    Ratings:
    +21
    How's it holding up a week later? Just sent mine back today after getting it just before Christmas and the shifting problem appearing, hoping the repair is a permanent fix!
     
    Last edited: Jan 16, 2019
    • Agree Agree x 1
  14. Ray T

    Ray T

    Messages:
    1
    Ratings:
    +1
    My new wheel just started this after a week of usage. It seems strange that this was happening a lot after only a relatively short space of time to many people. After trying various things i started wondering how soft the metal was on the shifters and discovered by careful manipulation that the metal is indeed quite malleable. It is possible that pressure over several hundred/ thousand presses could bend the rocker inwards and shorten the activation gap and cause misreads. I bent both sides very slightly away from the body of the wheel, thereby proving how easily bent it was and my problem disappeared. Fearful that this may happen again in the future, i have started using the shoulder of the rocker instead. I'm lucky in this respect as i have large hands. It's a bit weird but i think i can get used to it, others mightn't be so lucky. Of course this could all be coincidence but it could also be a silly design fault in using a weak metal. If anyone tries this and cocks up, please don't blame me.
     
    • Beer Beer x 2
    • Like Like x 1
  15. Tardy Tony

    Tardy Tony
    Premium

    Messages:
    192
    Ratings:
    +47
    My GT3 lasted a day!
     
    • Beer Beer x 1
  16. GEO147

    GEO147
    Premium

    Messages:
    101
    Ratings:
    +40
    The rubber on mine has started to dry and fray a bit. Is there anything that I should do to slow it down?
     
  17. anton_Chez

    anton_Chez
    Premium

    Messages:
    1,274
    Ratings:
    +391
    Gloves? I always race with gloves on
     
  18. GEO147

    GEO147
    Premium

    Messages:
    101
    Ratings:
    +40
    That's with gloves!
     
  19. anton_Chez

    anton_Chez
    Premium

    Messages:
    1,274
    Ratings:
    +391
    Hmm. I don't use mine exclusively so I am yet to see degradation. I have no idea. Can you wrap it in something? Some people wrap their rims to make them slightly thicker. You could do the same where you grip but for a different purpose.
     
    • Beer Beer x 1
  20. Fil140

    Fil140

    Messages:
    47
    Ratings:
    +11
    hello and happy new year. has there been any news on this issue described by the op? ive stripped and tested my macca and im getting a spike from the left paddle even when i completely remove the connector from the board.....any ideas or advice? warranty is well and truly dead.
    thanks , phil
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.