AC crashes: Car ks_whatever might be missing or its data is heavily damaged

Billy Pilgrim

1000RPM
Premium
Mar 25, 2014
1,269
272
Since last night, AC crashes back to the desktop when I try to load a race and CM gives a message to say: Car ks_porsche/or whatever might be missing data or is heavily damaged.
It doesn't seem to be doing this with all cars - there seems to not be a problem with mod cars, but just with some, not all, Kunos cars.

I'm thinking I may have to do a file integrity check through Steam. What do you think?

Thing is, I recently (for another problem) did a file integrity check and have used the cars that are now causing AC to crash since that integrity check many times with no problem.

Any tips on how to proceed? And what could have caused this problem? When I check if the cars are missing - they are not mising, they're exactly where they should be.
 

Jempy

1000RPM
Premium
Nov 26, 2010
1,709
487
68
The Steam file integrity check is surely the only method to retrieve those original cars working as they were.

If you already did it ... and those cars were perfectly working for a time... there must be something ( surely in a mod ) causing them not to work again after a time.

Discover what and how will be the most difficult problem to solve ... except remember by chance which cars were installed, modified or used just before those crashes happened.

Edit: or discover which mod will not work any longer after this new file integrity check.
 
  • Like
Reactions: Billy Pilgrim

Jempy

1000RPM
Premium
Nov 26, 2010
1,709
487
68
I had another idea .... did you uninstall or unactivate a mod just before those original cars began to crash the game ?

If this mod replaced original files ... of course unactivating or uninstalling it should have deleted some necessary files for the original cars. Always a risk installing a mod replacing original files.
Normally JSGME gives a warning when replacing files and mostly retrieves the previous files in case of uninstall.... but uninstalling manually doesn't allow it.

This might be the 2nd likely possibility for your problem.
 
  • Like
Reactions: Billy Pilgrim

Billy Pilgrim

1000RPM
Premium
Mar 25, 2014
1,269
272
The Steam file integrity check is surely the only method to retrieve those original cars working as they were.

If you already did it ... and those cars were perfectly working for a time... there must be something ( surely in a mod ) causing them not to work again after a time.

Discover what and how will be the most difficult problem to solve ... except remember by chance which cars were installed, modified or used just before those crashes happened.

Edit: or discover which mod will not work any longer after this new file integrity check.
Merci pour les conseils.
I don't remember uninstalling a mod before these crashes started. I'll have a look when i get back to the PC