Windows 1903 and WMR

Andrew_WOT

4000RPM
May 11, 2014
4,150
2,008
Anyone noticed drop in sharpness in SteamVR?
Was scratching my head since yesterday trying to figure out what is causing that. I am on Odyssey+
Situation improved a bit by changing SS from 200% that used to give the sharpest result to 212% which should be closest to internal Odyssey+ resolution accordingly to WMR dev.
It's better but I am still not 100% sure that it is as sharp as before.
 

EsxPaul

500RPM
Premium
Feb 17, 2016
925
678
I was planning to go from 1803 to 1903 this weekend but might put that on hold for a bit after reading that.
 

Andrew_WOT

4000RPM
May 11, 2014
4,150
2,008
Can we please stay on topic.
MS just released Holographic driver update, seems like things get improved.
 

Andrew_WOT

4000RPM
May 11, 2014
4,150
2,008
Yep, fixed. Yay!
Although I think 212% SS for Odyssey+ looks a bit better than 200% now, need to test more.
 

SaXXXon

75RPM
Premium
Mar 17, 2013
85
52
Not likely, was starting just fine for me with 1903.
You start SteamVR first, right?
yup. no difference if i do or not. it's like the game launcher doesn't communicate with SteamVR. everything i launch directly from Steam works. just not AC :( there's no sign of AC launching in SteamVR
 

Fernando Deutsch

500RPM
Premium
Feb 12, 2014
824
421
51
After 1905 update I got considerable better performance on ACC. I could see via fpsVR SS was set to 100% but I see the same graphics quality than before. Have not tried AC yet. Using Lenovo Explorer headset.
 

Andrew_WOT

4000RPM
May 11, 2014
4,150
2,008
yup. no difference if i do or not. it's like the game launcher doesn't communicate with SteamVR. everything i launch directly from Steam works. just not AC :( there's no sign of AC launching in SteamVR
Try to dig through the logs in Users\<yourName>\Documents\Assetto Corsa\logs
Some clues could be there.
Does it work in vanilla launcher? If CM specific issue, try dicsord. https://discord.gg/GBfphV3
 
  • Like
Reactions: SaXXXon

SaXXXon

75RPM
Premium
Mar 17, 2013
85
52
got a little further when i removed shader patch

CRASH in:
OS-Version: 6.2.9200 () 0x100-0x1
d:\dev\dev_pc_master_race\kunossim\stereocameraforwardvive.cpp (251): StereoCameraVive::getRenderMultiplier
d:\dev\dev_pc_master_race\systemapps\formopenvr.cpp (35): FormOpenVR::FormOpenVR
d:\dev\dev_pc_master_race\acs\sim.cpp (455): Sim::Sim
d:\dev\dev_pc_master_race\acs\splashscreen.cpp (319): SplashScreen::postRender
d:\dev\dev_pc_master_race\ksgame\game.cpp (181): Game::onIdle
d:\dev\dev_pc_master_race\ksgame\game.cpp (210): Game::run
d:\dev\dev_pc_master_race\acs\acs.cpp (477): wWinMain
f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c (618): __tmainCRTStartup
ERROR: SymGetLineFromAddr64, GetLastError: 487 (Address: 00007FFBD3F97BD4)
00007FFBD3F97BD4 (KERNEL32): (filename not available): BaseThreadInitThunk
ERROR: SymGetLineFromAddr64, GetLastError: 487 (Address: 00007FFBD5A4CE71)
00007FFBD5A4CE71 (ntdll): (filename not available): RtlUserThreadStart
 

Andrew_WOT

4000RPM
May 11, 2014
4,150
2,008
Sorry, can't help with that. I'd just reinstall AC from scratch.
Can you please start your own thread so we do not clutter the topic of discussion, I believe you have one already in AC section.
For 1903 + WMR problem, I have created feedback issue with MS. Please upvote to speed up resolution.
https://aka.ms/AA56cou
 

Peter Koslowski

TIKAL SPORT
Premium
Apr 20, 2015
130
72
51
With 1903 you will get blurriness on 60 and less on 90Hz, I rolled back! We have to wait for a fix for a few weeks!
 

Dan Costa

World Champ Procrastination n' Hoarding Series
Nov 30, 2015
964
412
I've been away from VR the past 6 months, but now i'm trying again and had to roll back to 1809. On 1903 it was too aliased.

@Andrew_WOT do you still recommend 200% or the 210% + Advanced Supersample Filtering?

anything more we can do to make the image sharper? I already have the render target = 2
 

Bjarne Hansen

500RPM
Jan 7, 2015
808
375
62
With 1903 you will get blurriness on 60 and less on 90Hz, I rolled back! We have to wait for a fix for a few weeks!
Which headset are you using?
I see some reports that the 1440 x 1440 are doing great on 1903 more fps and more fluid with no blurriness. Compared to 1809
 

Andrew_WOT

4000RPM
May 11, 2014
4,150
2,008
I've been away from VR the past 6 months, but now i'm trying again and had to roll back to 1809. On 1903 it was too aliased.

@Andrew_WOT do you still recommend 200% or the 210% + Advanced Supersample Filtering?

anything more we can do to make the image sharper? I already have the render target = 2
Windows 1809, 210% SS, Advanced Supersample Filtering on. RenderTargetScale is 2.0 by default now, you don't need to mess with cfg file. And don't enable motion reprojection, it's crazy bad on performance at the moment.
Don't bother with 1903 for now.
For AC, MIP LOD BIAS = -1. If using CSP try adding CMAA on Ultra with Extra Sharp checked on the top of MSAA.