Stream Deck plugin for Simhub

Chimaera

10RPM
Mar 17, 2019
18
2
47
I know @Wotever wrote an amazing replacement for the Elgato Stream Deck software to turn it into a proper button box, but if you want to use your Stream Deck for multiple purposes I've made a plugin that will allow you to trigger any Simhub event using the SD with stock software. Just install the plugin, give your new button a name and press that button while in the "Controls and Events" section when creating or editing a trigger. That's it, nothing fancy but means you can now have a dedicated Sim profile while also using all of the other Stream Deck functionality.
http://www.baptiewright.com/streamdeck/com.baptiewright.simhub.streamDeckPlugin
 
  • Like
Reactions: herve45

Tofi

1RPM
Feb 10, 2019
1
0
42
@Chimaera Can you add something opposite? Take out telemetry from simhub and display in buttons? i.e. speed and revs, and lap time. Two versions: 1) each value one button, 2) each button single digit that speed takes 3 buttons. And the last feature is splitting the image into parts to display racing flags.
 

Chimaera

10RPM
Mar 17, 2019
18
2
47
@Chimaera Can you add something opposite? Take out telemetry from simhub and display in buttons? i.e. speed and revs, and lap time. Two versions: 1) each value one button, 2) each button single digit that speed takes 3 buttons. And the last feature is splitting the image into parts to display racing flags.
Theoretically, since SimHub can be used as a UDP telemetry source. However, I currently don’t have a way to get a UDP stream in to my plugin because it’s written in pure JavaScript. I will page @Wotever and see if he can provide me with some more functions in the API like a single variable query that just returns the current value. Then I could at least do some of this. I like the flag idea, I haven’t done anything that takes over multiple buttons yet.
 
Nov 26, 2017
1
0
34
Hi guys! Is the plug-in still working?

I am trying to use but simhub doesn't recognized the button pressed even after naming it.

Edit: understood the issue. It doesn't work if it is within a folder.

Thanks!
 
Last edited: