Vive is unusable outside of this game, after installing the beta.

Discussion in 'rFactor 2' started by Zenhye, Aug 9, 2017.

  1. Zenhye


    Hi everyone,

    When I tried out the rFactor2 beta with my vive, everything worked fine in game. The second I closed the game and SteamVR opened automatically, it will lag like CRAZY. Right eye flickers, computer will completely bog down to 1 fps including audio stuttering until I closed SteamVR. Tracking hardly works etc.

    If I turn on my pc, open steam for the first time for the day, and launch SteamVR by the controlers, I get the same thing.

    I've tried

    • Uninstalling both, then reinstalling SteamVR only

    • ReInstalling rFactor 2 with no beta, and reinstalling SteamVR.

    • Reinstalling rFactor 2 with no beta, and trying the current SteamVR then went into rFactor 2 again to see if there wasn't any lag in game, and there is NOT.

    • Reinstalled video drivers with a fresh install since rFactor 2 beta is a big direct x 11 update. I am now on 384.94.
    rFactor 2 works fine even after all of this testing, but regular VR use within steam totally laggy and unusable.

    Does anyone have any ideas for me to try? It sounds like rFactor 2 took over some files or settings or something.

    Is there another way to completely uninstall the Vive besides uninstalling SteamVR?

    Thank you!


    Windows 8.1
    i7 6700k Skylake
    16GB of RAM
    GTX 970
    Asus E3 PRO GAMING V5
  2. JoelGL


    What type of 'laggy' performance do you get? What settings have you set in rF2 and Supersampling in SteamVR (if any)?
  3. Zenhye


    I will have to double check the settings after work, but I have not touched any in SteamVR (Got the Vive 2 weeks ago). The lag I'm receiving is extreme stuttering to my entire computer without raising CPU & memory usage.
    If I look around inside the SteamVR home area (Cabin on the mountains) I will see the picture originally, then as I look around it will not update for a second or two since it forever stutters (Like playing CS with 1fps). But before that one frame loads, I see black. Sometimes if the frame loads, the right lens will not have anything showing or it will flicker.

    1 - Look at wall in VR
    2 - Turn head 90 degrees right. As I do that I still see the same wall as if I'm looking straight
    3 - A frame loads from about 45 degrees mid turn, but my right lens is now black, while the left one shows that 45 degrees view.
    4 - Picture catches up to the new 90 degrees but things are not lined up. A lot of black around the sides with a rainbow of pixels in a curved shape at the edge of the lens.
    5 - Repeat forever while looking around

    I tried to make it easy to understand, I hope that helps.