rFactor Unknown Internal Error

Discussion in 'rFactor' started by Bram Hengeveld, Oct 28, 2008.

Thread Status:
Not open for further replies.
  1. Bram Hengeveld

    Bram Hengeveld
    Founder Staff Premium

    Messages:
    43,618
    Ratings:
    +17,179

    Attached Files:

  2. Paul Godden

    Paul Godden

    Messages:
    222
    Ratings:
    +0
    I found this at Racesim Central - might be worth trying a few of the suggestions?
     
  3. Bram Hengeveld

    Bram Hengeveld
    Founder Staff Premium

    Messages:
    43,618
    Ratings:
    +17,179
    Yeah i ran through those pages as well but without any success. Problem is still there :(
     
  4. Paul Godden

    Paul Godden

    Messages:
    222
    Ratings:
    +0
    I've not ever seen the error message before - I'll do a little more research, to see if I can dig anything up. It almost looks like it's something to do with the activation for the game? I might be way off the mark though..

    In the meantime, have you tried contacting customer services by clicking the link? It might be something they're familiar with, after a reinstall.
     
  5. Bram Hengeveld

    Bram Hengeveld
    Founder Staff Premium

    Messages:
    43,618
    Ratings:
    +17,179
    Nope havent contacted them yet, normally our board is a quicker way to solve things then official customer support :)
    If nobody knows the answer they will be my final resort, otherwise my rF days will be over soon..
     
  6. Simon Trendell

    Simon Trendell

    Messages:
    5,023
    Ratings:
    +7
    Tried using a Nocd Bram?
     
  7. Bram Hengeveld

    Bram Hengeveld
    Founder Staff Premium

    Messages:
    43,618
    Ratings:
    +17,179
    Jup, doesnt work either
     
  8. Tim Ling

    Tim Ling
    It's a million-to-1 chance, but it just might work

    Messages:
    3,000
    Ratings:
    +1,003
    it maybe an issue with Windows rather than rF Bram. I'm assuming you've done all the updates for Windows? DX error maybe? Do other games run ok? :frusty:
     
  9. Paul Godden

    Paul Godden

    Messages:
    222
    Ratings:
    +0
    I've heard that the activation can get screwed up sometimes on a new install:

    Take a backup of your Trymedia folder (found in C:\documents and settings\All Users\Application Data in XP or C:\Users\All Users in Vista) then remove the original - it should ask for reactivation after running rFactor, so have your activation key handy!
     
  10. Bram Hengeveld

    Bram Hengeveld
    Founder Staff Premium

    Messages:
    43,618
    Ratings:
    +17,179
    After new re-install of the pc 2 months ago i've lost my trymedia folder. Really a challenge to solve this isnt :)

    @ Tim: other games run flawless
     
  11. Warren Dawes

    Warren Dawes
    Premium

    Messages:
    12,831
    Ratings:
    +1,829
    Not seen that message either Bram, but I had to reinstall rFactor this week to my new PC, and also had problems with my original saved downloaded installation file. I assume it was because it was the older version.
    So I just downloaded the newer rFactor Lite 1255 version, and everything went fine. When it required activation, I just entered my activation code from before and it activated immediately.

    Have you checked whether you still have that Trymedia folder in Documents and settings, maybe it ended up in a different location. If so, kill it and try again.
     
  12. Bram Hengeveld

    Bram Hengeveld
    Founder Staff Premium

    Messages:
    43,618
    Ratings:
    +17,179
    My old file was gone after reformatting the pc. Ramon and i have tried to install 3 different downloads, different keys, and also rF Lite with no success..

    So the one that comes with the golden answer will make me a really happy man. All ready missed today's Karting event in the Racing Club because of this... Me and rFactor don't get allong to well i think :)
     
  13. Patrick van Driel

    Patrick van Driel

    Messages:
    3,380
    Ratings:
    +1
    I wish i knew what it was Bram, i have never seen this error before??
    Might be good to contact them anyhow even if it takes longer. Did you try to install on another HDD ?
     
  14. Paul Godden

    Paul Godden

    Messages:
    222
    Ratings:
    +0
    One other thing to check - you're running the latest version right? If your DVD wasn't the 1255 version, you can get the update from the rFactor.net site - bare in mind there are two different versions, one for the downloaded copy, and one for the DVD copy.

    Turning into a real challenge this one! It might be a good idea, like Patrick says, to contact support at the same time - it can't do any harm. :)
     
  15. Bram Hengeveld

    Bram Hengeveld
    Founder Staff Premium

    Messages:
    43,618
    Ratings:
    +17,179
    Problem solved. You will not believe this:

    We uninstalled AVG virusscanner and suddenly this come to life!
     
  16. Sander Hogendoorn

    Sander Hogendoorn

    Messages:
    1,285
    Ratings:
    +10
    Lol Bram, yesterday I was about to post something about virusscanners, until I saw that you tried everything that was named in a link earlier this thread, so I thought you already tried it, since there also was something about virusscanners in it :bounce:

    Good to hear it's solved.
     
  17. Ramon van Rijn

    Ramon van Rijn

    Messages:
    5,399
    Ratings:
    +235
    We did try to disable AND uninstall the virusscanner earlier. Apparently it was not really removed :)

    Glad it worked this time :)
     
  18. Ramon van Rijn

    Ramon van Rijn

    Messages:
    5,399
    Ratings:
    +235
    Solution for AVG Free users to run rFactor is to make an exception for the rFactor folder.


    • Right click AVG Anti-Virus Free (system tray)
    • Open AVG User Interface
    • Double click Resident Shield Component
    • Click on "Manage Exceptions"
    • Add path to directory where you have rFactor installed (in example: C:\GAMES\rFactor\)
    • Apply
    • Save Changes
    Game will run fine now :)
     
  19. Paul Godden

    Paul Godden

    Messages:
    222
    Ratings:
    +0
    Cool - good news. I'm glad it's all sorted for you.
     
  20. Ross Balfour

    Ross Balfour
    #99 | Roaring Pipes Maniacs

    Messages:
    10,560
    Ratings:
    +199
    Oh my goodness the same thing is happening to me! But I cant get rid of AVG my dad will kill me!
     
Thread Status:
Not open for further replies.