Need Help Sparco r383 Thrustmaster Wheel Add-Onn buttons are not working (some)

FlickIT

1RPM
May 12, 2018
1
0
49
Hi i Just got a Sparco r383 from Thrustmaster and i connected it to my ts pc wheel base and basicly all buttons worked except the left paddle and the yellow button at the right side of the wheel i hope you guys can help me with this issue.
 

Thiago Willemann

25RPM
Premium
Jan 8, 2018
28
11
34
Hi i Just got a Sparco r383 from Thrustmaster and i connected it to my ts pc wheel base and basicly all buttons worked except the left paddle and the yellow button at the right side of the wheel i hope you guys can help me with this issue.
Did you solve the problem i have the exact same brand new wheel not working in the exact same manner
 
May 8, 2018
3
1
Hi i Just got a Sparco r383 from Thrustmaster and i connected it to my ts pc wheel base and basicly all buttons worked except the left paddle and the yellow button at the right side of the wheel i hope you guys can help me with this issue.
I'm having the same issue here. Installed the latest firmware and everything, but it still has the wrong mapping. Any solutions to this?
 
May 8, 2018
3
1
@FlickIT I just found out the solution. Go to the control panel and see what's the firmware you have installed in the base. If it's not firmware 9, then go to your start menu in Windows, look for the Thrustmaster FFB Racing Wheel folder, and then click "Firmware update". Click on the wheel base and then "Update". Should run perfectly once it finished updating.
 
  • Like
Reactions: DrRob