AC dont work anymore pls help

Nov 16, 2017
4
0
22
AC doesn´t start races



hi there,

so I m playing AC for PC since a Year and yesterday I tryed to start a race after a break since 2 month.

i used the Content manager as always and a say "go" and he imidediately say "race cancelled". i thought the content manager was broke and tryed the normal game but same problem. (orginal car and track, no mod) (all other mods = off)

i reinstalled the game to a diffrent HDD, deleted the AC folder in my Documents and updated my graficcard. pls help i dont know what to do anymore, first time AC dont work.

this is the logfile:

Installing CrashGuard Fault Handler

CRASH in:

OS-Version: 6.2.9200 () 0x100-0x1

ERROR: SymGetLineFromAddr64, GetLastError: 487 (Address: 00007FFF6A51A388)

00007FFF6A51A388 (KERNELBASE): (filename not available): RaiseException

f:\dd\vctools\delayimp\delayhlp.cpp (315): __delayLoadHelper2

f:\dd\vctools\delayimp\delayhlp.cpp (437): __HrLoadAllImportsForDll

d:\dev\dev_pc_master_race\acs\acs.cpp (348): wWinMain

f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c (618): __tmainCRTStartup

ERROR: SymGetLineFromAddr64, GetLastError: 487 (Address: 00007FFF6BFF3DC4)

00007FFF6BFF3DC4 (KERNEL32): (filename not available): BaseThreadInitThunk

ERROR: SymGetLineFromAddr64, GetLastError: 487 (Address: 00007FFF6DCA3691)

00007FFF6DCA3691 (ntdll): (filename not available): RtlUserThreadStart
 

Alan Jones

10RPM
Premium
Feb 25, 2017
19
6
66
I'm no expert on these things but have you tried doing an integrity check on Steam? That will look at your game and download any missing files. Any mods should remain intact but you can do a backup beforehand if you so wish.
Right click on Assetto Corsa in Steam, click on 'Properties', then in the menu pop up, select 'Local Files' tab and click on 'Verify Integrity of Game Files'.
 

Dobermann92

250RPM
May 16, 2018
284
254
28
I had this problem on Content Manager before, but I never got problem with the base game. The integrity check will maybe help, but you may have more serious problems in the background.
 

Denis Betty

The older I get, the better I was.
Staff
Premium
Jun 18, 2013
7,597
3,644
I don't know much about this either, but it sounds like something is corrupted. One thing that sometimes works in other games, is to create a new profile with a different name and see if you can race. If it does, you can just delete the corrupted profile and make a new one.

Did you try to remove the assetto corsa folder from "My Documents"?
Back it up somewhere safe and remove it. A new one will be made when you start the game (I think). It's worth a try and you can always just put the original back if it doesn't work.
Also, the errors keep referring to address 64. You are not trying to run in force 32 bit or something?

Just throwing some stuff out there. Try everything you can think of. If you did a fresh install of AC, then the corrupted file(s) must be somewhere else... the folder in My Documents or possibly your registry or something.
 

Dave Stephenson

RaceDepartment Technical Administrator
Staff
Premium
Sep 4, 2007
10,006
1,612
My gut feeling on that would be missing exe. Check your antivirus software hasn't decided to quarantine the one of the exes and if it has restore it and add an exception.
 
Nov 16, 2017
4
0
22
I had this problem on Content Manager before, but I never got problem with the base game. The integrity check will maybe help, but you may have more serious problems in the background.
integrity check is fine anytime.


I don't know much about this either, but it sounds like something is corrupted. One thing that sometimes works in other games, is to create a new profile with a different name and see if you can race. If it does, you can just delete the corrupted profile and make a new one.

Did you try to remove the assetto corsa folder from "My Documents"?
Back it up somewhere safe and remove it. A new one will be made when you start the game (I think). It's worth a try and you can always just put the original back if it doesn't work.
Also, the errors keep referring to address 64. You are not trying to run in force 32 bit or something?

Just throwing some stuff out there. Try everything you can think of. If you did a fresh install of AC, then the corrupted file(s) must be somewhere else... the folder in My Documents or possibly your registry or something.
all deleted, no 32bit force, fres installed, - no changes..


My gut feeling on that would be missing exe. Check your antivirus software hasn't decided to quarantine the one of the exes and if it has restore it and add an exception.
nope, its there. i can start AC without content Manager. i coose Track and car, push "Start", getting the loading screen and after a few seconds i´m back in the menu to choose track and car..

aaand i dont use any antivirus software.. ^^

still not working
 

Jempy

1000RPM
Premium
Nov 26, 2010
1,897
573
69
And no firewall used ? .... I think that's also a rather old symptom of a acs.exe or acs_x86.exe not approved in the firewall
Are they still approved in your firewall if you have one ?
 

Jempy

1000RPM
Premium
Nov 26, 2010
1,897
573
69
Or should it be the same problem some encounter ?
This is what I just read in Sol's mod thread:

If you got permanent "race cancelled" errors:

You have to delete the "gameplay.ini" in \Documents\Assetto Corsa\cfg always before launching AC!

Its a windows update caused bug!
 

Peter Boese

1000RPM
Premium
Apr 7, 2014
1,648
2,591
70
Yes it comes with a windows update. Maybe there are some problems with protected files now. Also deactivating UAC will make no difference. We search for a solution via CM.
 

Jempy

1000RPM
Premium
Nov 26, 2010
1,897
573
69
Yes it comes with a windows update. Maybe there are some problems with protected files now.
Surely something related to the 1809 update .... as I don't encounter this problem yet.
Using the hardest option in Win10 Pro ( semi-annuel ...in french )
... seems to still avoid this 1809 update until now... as I'm still with 1803 version.
 

Rogerbee

500RPM
May 2, 2018
567
71
50
Ever since Windows 10 1709 royally screwed my system, I have stuck religiously to 1703. You can download the .iso for 1703 still. Install it and then get a program called WUMGR, it overrides Windows Update and lets you hide feature updates so they never bother you again. As far as I'm concerned 1703 was the last new(ish) build of Windows 10 that was fully stable.
 
Nov 16, 2017
4
0
22
And no firewall used ? .... I think that's also a rather old symptom of a acs.exe or acs_x86.exe not approved in the firewall
Are they still approved in your firewall if you have one ?
Or should it be the same problem some encounter ?
This is what I just read in Sol's mod thread:
both dont work.. so i guess i have to go back to an old win10 version..
 

Rogerbee

500RPM
May 2, 2018
567
71
50
Certainly worth a try. I mainly use 1703 as I use a lot of older programs and they didn't work properly in 1709 when Windows Update forced it on me. Once you get 1703 up and going, get a program called WUMGR. It overrides Windows Update and you can choose to hide any feature updates that it finds. I've been running 1703 for years and have barely had any issues except for those I've caused myself when trying to be clever.
 

Peter Boese

1000RPM
Premium
Apr 7, 2014
1,648
2,591
70
both dont work.. so i guess i have to go back to an old win10 version..
Just try 1 thing:
Rename "AssettoCorsa.exe" to "__AssettoCorsa.exe" (which is just the launcher) and rename "ContentManager.exe" to "AssettoCorsa.exe". Then CM will act as AC's offical Launcher. You will see that "Replacement" is selected as Starter in CM: Settings->ContentManager->Drive