VR issues now in RF2

bbgroovin

10RPM
Premium
Wondering if anyone else is having issues with RF2 and SteamVR these days .... RF2 used to work fine in VR ... now it doesn't .... acts like it is just a screen in front of you vs. being immersed in a VR experience .... assume this is due to some sort of update recently ? Haven't played the game for a while but wanted to get back into it as I have more time for sim racing in the winter. Used to love RF2 in VR !!! Now after starting the game, I don't get it listed as a choice under the video settings like i used to - in fact when I hit the Video Settings button, I nothing happens. When I put on my VR goggles, the game just looks like a single screen in front of you. Hope they fix it soon if it was due to an update !!! Anybody else have any insight ?
 

Maltus

10RPM
Same here with Oculus Rift. Searched a solution in 397 forums but i cant find it (maybe my bad english), im very frustrated....any solution to launch in VR?
 

JoelGL

1000RPM
Not sure what you guys are experiencing but I can run it fine on my Rift, though I use opencomposite (not SteamVR). I even switch between triples and VR, just tick multiview for triples, or select HMD for VR.

Just annoying that it doesn't save my graphics card and resolution, always starts with Auto and blank reso.
 

Maltus

10RPM
Not sure what you guys are experiencing but I can run it fine on my Rift, though I use opencomposite (not SteamVR). I even switch between triples and VR, just tick multiview for triples, or select HMD for VR.

Just annoying that it doesn't save my graphics card and resolution, always starts with Auto and blank reso.
Thanks, JoelGL for your help. Installed opencomposite, changed the files, and no result (flikering rFactor 2 screen and pc blocked), but you give the idea to investigate alternate launching modes....and launch from oculus library (need to make some steps because rFactor didnt appear to me) and voilaaa, it works.

Thanks again.
 

Terry Rock

2000RPM
Framerate-wise, mine still runs great but I now have what appears to be a locked position in the cockpit relative to the car.
If I lean forward in the VR space, the cockpit will also move forward. If I lean backward...same.
Not sure when that happened, since I don't run RF2 as often as other sims.
The other thing I've noticed is the HUD is displayed across the lower section of the screen at all times...whether I deselect it or not.
It kind of blends in in the background.
I'm on a Lenovo Explorer WMR headset.
 

bbgroovin

10RPM
Premium
Hopefully someone can help me --- I use SteamVR with my Vive Pro.
VR used to work a few months ago (I didn't use it much during the summer months) and have now started sim racing again and have updated all the apps/programs to the latest editions. Every time I try to start RF2 it comes up with a message saying that RF2 does not support VR ??? It used to .... now it doesn't ???

I used to be able to start the game and then go into VIDEO SETTINGS and then choose between regular, Oculus, and OpenVR (or SteamVR) .... now when you hit that button nothing happens. I have tried Beta v1117 (latest Beta version) and it still does the same thing. When you start the game with SteamVR running and my VIVE Pro on ... after you start the game a pop messages says RF2 does not support VR.
Is this a SteamVR issue ?
I used to love this game in VR when I was playing it last spring.

Hope someone can help,
Thanks in advance,
Bruce
 

Maltus

10RPM
Every time I try to start RF2 it comes up with a message saying that RF2 does not support VR ??? It used to .... now it doesn't ???
bbgroovin, I have the same problem. I read somewhere that the game is missing from the SteamVR application settings menu due to an improperly set publishing property of the game, and will need to be updated by the developer.

You need to launch it with an external app. There are people who use "opencomposite", you can read post by JoelGL. It didnt work for me, but i use now "OculusDebugTool" and it work again launching it without opening steam before. Try "opencomposite", and if dont work there must be another app you could use with Valve Pro.

Good luck.
 
Framerate-wise, mine still runs great but I now have what appears to be a locked position in the cockpit relative to the car.
If I lean forward in the VR space, the cockpit will also move forward. If I lean backward...same.
Not sure when that happened, since I don't run RF2 as often as other sims.
The other thing I've noticed is the HUD is displayed across the lower section of the screen at all times...whether I deselect it or not.
It kind of blends in in the background.
I'm on a Lenovo Explorer WMR headset.
My Lenovo does the same thing occasionally in both RF2 and in IL-2. The solution is to exit the game and go into the WMR portal, select Settings and redo the seated position. After restarting, you should be once again able to lean outside of the cockpit, etc.
 

Beef36

100RPM
Framerate-wise, mine still runs great but I now have what appears to be a locked position in the cockpit relative to the car.
If I lean forward in the VR space, the cockpit will also move forward. If I lean backward...same.
Not sure when that happened, since I don't run RF2 as often as other sims.
The other thing I've noticed is the HUD is displayed across the lower section of the screen at all times...whether I deselect it or not.
It kind of blends in in the background.
I'm on a Lenovo Explorer WMR headset.
My Lenovo does the same thing occasionally in both RF2 and in IL-2. The solution is to exit the game and go into the WMR portal, select Settings and redo the seated position. After restarting, you should be once again able to lean outside of the cockpit, etc.
I get the same locked position effect in rF2, but on the Oculus Rift. Does anyone know of an equivalent workaround for the Rift?
 

xoSx.Racing

250RPM
Premium
Framerate-wise, mine still runs great but I now have what appears to be a locked position in the cockpit relative to the car.
If I lean forward in the VR space, the cockpit will also move forward. If I lean backward...same.
Not sure when that happened, since I don't run RF2 as often as other sims.
The other thing I've noticed is the HUD is displayed across the lower section of the screen at all times...whether I deselect it or not.
It kind of blends in in the background.
I'm on a Lenovo Explorer WMR headset.
That's just a simple matter of restoring your Windows MR HMD boundaries.
When these are switched off, or in case of low light situation, the headset switches to the rotational movement only.
 
Top Bottom