RD Series on Simracing.GP

Daily WTCR races on Simracing.GP Weekly GT3 Endurance races on Simracing.GP Weekly GT3 Sprint Races on Simracing.GP Weekly GT4 Sprint Races on Simracing.GP

t300 installation issue

ok i followed all the steps on the website 1st off all...now when i go to this part When done, select Start/All Programs/Thrustmaster/FFB Racing Wheel/Control Panel.

The racing wheel appears onscreen with the status indication OK

5- In the Control Panel, click Properties to configure your racing wheel:...my status just says controller... nothing about a wheel in here the only option i have is advanced and cant get into properties like it suggests...its like my computer has not even seen the wheel.
 

Msportdan

@Simberia
oh crap oi just bought this..

Did you install firmware in boot mode on wheel. (hold down 2 right buttons on base) while inserting usb let go when done, then update firmware
 
oh crap oi just bought this..

Did you install firmware in boot mode on wheel. (hold down 2 right buttons on base) while inserting usb let go when done, then update firmware
no i didnt see that option...are we talking L3 R3 BUTTON
 

Msportdan

@Simberia
yes.

uninstall it all..

then

install from website TTRs driver. (dont plug in wheel) when prompted plug in wheel usb in boot mode, then do firmware update... (should see wheel in [BOOT] mode.)


This fixed my TX issue, howver with my wheel it didnt syat connected when unplugged USB or cpu turned off.


I hope this isnt another brilliant TM issue.,

Whats wrong with these wheels.!!!
 
I'm not sure if this helps but to access my t500 control panel I go to Control panel ->Hardware and sounds -> Devices and printers, right click on t500 and select Game Controller Settings. On the new small window right click again on t500 and click properties.
 
yes.

uninstall it all..

then

install from website TTRs driver. (dont plug in wheel) when prompted plug in wheel usb in boot mode, then do firmware update... (should see wheel in [BOOT] mode.)


This fixed my TX issue, howver with my wheel it didnt syat connected when unplugged USB or cpu turned off.


I hope this isnt another brilliant TM issue.,

Whats wrong with these wheels.!!!
it says please connect all of the ffb controllers you want to install...is this when i plug in usb and hold r3 l3?
 

Msportdan

@Simberia
yep

then go to firmware update,

EDIT**
and this is why i took the day of,.

to install the bloody thing!!!
 
yep

then go to firmware update,

EDIT**
and this is why i took the day of,.

to install the bloody thing!!!
ok im getting somewhere but this time it says t300 was not installed correctly because usb was unplugged hahah wtf its clearly in my pc weird
 

Msportdan

@Simberia
try another USB, (even ones from mobo)

ill remeber all this tomorrow probs be back asking your for help lol!!!
 
well this might be a problem not sure but in calibration the wheel is not centred and the wheel on screen is not the same degrees as what im actually looking at
 
didnt have that with the TX.. hhhmmmm

has it done the ferocious calibration thingy yet?
yea and when it stop its at 90degrees but on the profile its straight...it also wont let me select ferrari 458 and it thinks this is t300 rs although im not sure that will matter
 
so not good so far :( not sure about that mate.
right sorted it i needed a restart to get it to highlight ferrari instead of t300...and as for axis i needed to put the wheel back on and screw that cap around the rim a bit more now its all in line...my only issue that i have found with this wheel is if you want to change rim that means unscrewing the little screw which goes into the plastic..then if you wanted to go back to that rim you will have to find the exact same spot the screw went into otherwise your gonna have lots of holes in the plastic sleeve thing if you change rim alot.
 
well this might be a problem not sure but in calibration the wheel is not centred and the wheel on screen is not the same degrees as what im actually looking at

1. Drivers have been loaded properly and firmware updated?

2. What firmware is showing in the TM control panel?

3. When you say not centered, when its done calibrating, do you just mean the wheel is slightly left or right of center? If so, is it showing center at 0 degrees in the TM control panel when you straighten the wheel?
 
right sorted it i needed a restart to get it to highlight ferrari instead of t300...and as for axis i needed to put the wheel back on and screw that cap around the rim a bit more now its all in line...my only issue that i have found with this wheel is if you want to change rim that means unscrewing the little screw which goes into the plastic..then if you wanted to go back to that rim you will have to find the exact same spot the screw went into otherwise your gonna have lots of holes in the plastic sleeve thing if you change rim alot.

You haven't read your manual. It clearly states NOT to remove that screw, you only loosen it when you change rims and you only tighten slightly to where you just feel some resistance. That screw doesn't go all the way through the quick release. If you look at how its designed, it only goes in far enough to keep the inside portion from turning by creating a stop.
 
phew.. glad its okay....
lol yea i screwed through the sleeve of plastic only by a little bit though untill it pinched...ive just done a few laps on rre and i must say im very impressed it is night and day compared to g25 im feeling things i never did before and much easier catching spin outs.
 
Top