SimDeck

Apps SimDeck 0.9.5

No permission to download

Wotever

2000RPM
Wotever submitted a new resource:

SimDeck - Convert your elgato StreamDeck into a button box

Have you ever seen the StreamDeck ? Could be a nice nice button box ? However Elgato totally missed this potential use. It's where SimDeck fills the gap.

View attachment 269861

Key features :
  • VJoy support : your stream deck will act like a real button box
  • Smart Profiles switch : Switch back and forth to game or app specific profiles
  • Orientation setting : Support all 4 orientation to match any mounting requirements on...
Read more about this resource...
 

axelpaq

1RPM
bonjour,
merci d'avoir mis à disposition cet outil
je l'ai installé (et bien désactivé le Stream Deck au démarrage de Windows) - par contre je rencontre qqs soucis :
* j'utilise SLImax pour mon SLI-F1 (64 bits) - lorsque je paramètre le .exe dans le SimDeck j'ai un message d'erreur et le logiciel SLImax refuse de s'ouvrir (pas de soucis avec le Stream Deck)
* lorsque je créé des profils, au redémarrage de Windows les profils disparaissent et le SimDeck revient au profil "Default profile"

sinon le soft a l'air très bien et le côté button box est parfait - le coup de l'heure en live c'est top - je me suis bien fait au système de pages

avez-vous une idée pour résoudre ces soucis ?

merci bien,
Alex
 

Wotever

2000RPM
bonjour,
merci d'avoir mis à disposition cet outil
je l'ai installé (et bien désactivé le Stream Deck au démarrage de Windows) - par contre je rencontre qqs soucis :
* j'utilise SLImax pour mon SLI-F1 (64 bits) - lorsque je paramètre le .exe dans le SimDeck j'ai un message d'erreur et le logiciel SLImax refuse de s'ouvrir (pas de soucis avec le Stream Deck)
* lorsque je créé des profils, au redémarrage de Windows les profils disparaissent et le SimDeck revient au profil "Default profile"

sinon le soft a l'air très bien et le côté button box est parfait - le coup de l'heure en live c'est top - je me suis bien fait au système de pages

avez-vous une idée pour résoudre ces soucis ?

merci bien,
Alex
Effectivement dans les dernières versions j'ai remarqué qu'il était un peu dur de la feuille pour sauver les paramètres, mais vu le peu d'interet manifesté pour le moment je ne me suis pas précipité pour le corriger :D, je vais regarder çà ;) pour SLImax, c'est étrange, je vais regarder.
Dans tous les cas ca ne devrait pas ètre long à corriger ;)
 

Wotever

2000RPM
Wotever updated SimDeck with a new update entry:

Hotfix

Hi !
Little update with a few fixes :
- Settings were not saved when restarting computer.
- Open file command and open website changes were only applied at text box focus loss so when cliking on "execute now" the old value was used.
- Open application command was not setting a working directory making some applications unhappy :D
Read the rest of this update entry...
 

axelpaq

1RPM
merci beaucoup pour l'update - j'essaye ce soir mais logiquement ça devrait être bon
merci encore de vous êtes penché dessus et surtout pour avoir créé ce logiciel qui est très très pratique
 

BeR1

1RPM
Alors je n'ai pas encore un gros retour d'expérience à vous faire, je viens d'installer et me faire un équivalent de ma configuration d'origine, mais je ne peux m’empêcher de vous dire un grand bravo avant toute chose : Merci, mieux que l'editeur et les scripts autokey en natif c'est génial.

Votre logiciel devrait avoir une meilleure visibilité sur Raceroom (pas seulement dans Assetto).

Pour les fonctionnalités que j'aimerais :
- plusieurs scripts affectés à une même touche qui s'executent l'un après l'autre à chaque appui , puis boucle sur premier. (Par exemple successivement permettre sur des appuis successif d'avoir la touche 1 puis 2 puis 3 ...)
- action permettant de changer un icone d'un bouton, permettant par exemple d'avoir la visualisation de l'etat d'un dispositif physique (train atterissage sorti, mode radar, ...)

Pour l'instant, pas de plantage.
Encore bravo et merci.
 
Last edited:

Roger01

1RPM
Salut! Impossible d'accès à un lecteur réseau (NAS) pour ajouter une image, même avec un raccourci. Merci pour le logiciel en tout cas! C'est super hormis ça :p
 

Wotever

2000RPM
Salut! Impossible d'accès à un lecteur réseau (NAS) pour ajouter une image, même avec un raccourci. Merci pour le logiciel en tout cas! C'est super hormis ça :p
J'imagine que ca dépend de l'authentification, pour le coup ce sont les interfaces de windows qui s'affichent et je n'ai pas la main dessus. D'expérience windows peut ètre un chouilla ronchon avec les accès réseau.
 

Roger01

1RPM
J'imagine que ca dépend de l'authentification, pour le coup ce sont les interfaces de windows qui s'affichent et je n'ai pas la main dessus. D'expérience windows peut ètre un chouilla ronchon avec les accès réseau.
Hmm en fait c'est surtout qu'il est carrément absent. Mais ça doit être un problème de droit ou autre effectivement...SIMDECK.png

[Edit]Après c'est pas grave, il suffit de mettre les images sur un disque local.
 

Wotever

2000RPM
Hmm en fait c'est surtout qu'il est carrément absent. Mais ça doit être un problème de droit ou autre effectivement...View attachment 279697
Ah je crois que j'ai la réponse : https://social.technet.microsoft.com/Forums/en-US/0a9e014d-6172-4d93-af0d-347388f2879f/cant-see-network-drives-in-the-open-dialog-box?forum=w8itprogeneral

C'est parce que SimDeck tourne en tant qu'admin (pour pouvoir envoyer les commandes à n'importe quelle appli même admin, pour pouvoir contourner çà il faudrait couper l'appli en deux un editeur et un service (qui s'occuperait de faire tourner le deck) pour le coup ça me semble un petit peu overkill :D
 

Roger01

1RPM
Il est possible d'avoir la possibilité de mettre des raccourcis (genre A; Ralt+Q; Rctrl+Lalt+Y etc..) sans passer par des commandes autohotkey? Sur DCS par exemple, je suis obligé de taper ça pour que ça fonctionne : (Lshift+à)

sendinput {Lshift Down}
sendinput {à Down}
sleep,75
sendinput {à Up}
sendinput {Lshift Up}

Sauf qu'il faut un temps de sleep sinon le jeu ne prend pas en compte la demande (trop rapide), la commande se lance quand on lache la touche et, de ce fait, on ne peut pas balancer en continue une commande (ex : laisser appuyer la touche pour fermer la verrière).
Si ça existe quand même avec autohotkey, je n'ai pas trouvé la commande sur leur wiki.

Sinon hâte de voir l'intégration dynamique des touches, et voir si DCS Bios fonctionne sur Sim Deck, comme cela fonctionne avec Stream Deck.
 

BeR1

1RPM
Super, le "cycling actions", à peine j'en parlais il y a quelques jours et hop c'est fait aujourd'hui.
Aller, pour chipoter : une option pour que ce ne soit pas seulement cyclique mais les faire toutes l'une après l'autre (cela permettrait par exemple d'exécuter un raccourci et d'aller dans la foulée à une autre page)
Merci.
 

Wotever

2000RPM
Super, le "cycling actions", à peine j'en parlais il y a quelques jours et hop c'est fait aujourd'hui.
Aller, pour chipoter : une option pour que ce ne soit pas seulement cyclique mais les faire toutes l'une après l'autre (cela permettrait par exemple d'exécuter un raccourci et d'aller dans la foulée à une autre page)
Merci.
Ah ah :D , oui c'était pas dur, j'avoue que pour le moment sur SimDeck je suis en mode écoute, j'attends les idées, pour mon propre besoin je suis content, mais je reste ouvert, je vais regarder pour faire çà ;)
 

BeR1

1RPM
Bonjour, je crois comprendre d’après une copie d'écran que votre logiciel est développé en c#. Aillant une petite expérience de dev avec Visual Studio C#, il y aurait-il la possibilité d'avoir votre code source ?
Ceci est uniquement dans le but de l'adapter à un jeu bien précis (DCS) et pas du tout de concurrencer votre application "passe-partout" qui rempli très bien son rôle.
Merci pour votre réponse.
 

barclay

10RPM
Hi there, have been using this very successfully for a couple of months, but now have a problem where if I open the app it minimizes to taskbar. When I then double or single click on the icon the app disappears, and I have a bunch of kernelbase.dll errors showing up in Event Viewer.
any ideas what might be going on?
(I have uninstalled the Elgato software, made sure I had the correct .NET version, deleted all my .NET versions, re-updated, all with no luck.)
 
Top Bottom