• Welcome to the largest (sim) racing website in the world!
    Blurring the line between real and virtual motorsports.

Question about AA & AF settings - Nvidia Inspector

Discussion in 'GTR 2' started by jbfan1263, Jul 8, 2019.

  1. jbfan1263

    jbfan1263
    jbfan Premium

    Messages:
    19
    Ratings:
    +3
    Hey guys,
    I know this topic has been discussed a thousand times and Yes, I did do a search of the forums for answers before posting. My questions is a little different, are any of you guys running a GeForce GTX 1050ti GPU on a single monitor at 1920x1080 for GTR2? The reason I ask is because I cannot seem to get rid of the shimmers and tearing/jaggies on screen and also, when I set the AA level to 32x (32xCSAA(8color+24 cv samples) it crashes and restarts my PC when I try to launch GTR2.
    Having said that my specs are:
    AMD X4 860 Quad Core 3.70
    Windows 10 - 64 bit
    8 Gigs RAM
    GPU: Nvidia GeForce GTX 1050 Ti

    (Running all GTR2 exe's as Admin and Windows XP Service Pack 3 compatibility)
    4gb Patch

    Nvidia Inspector, I am currently using:
    All GTR2 exe's properly assigned
    AA compatibility = Diablo III
    AA setting = 4x multisample
    AA transparency supersample = 8x Sparse Grid
    Anisotropic filtering mode = Userdefined/Off
    Anisotropic filtering setting = 16x
    Texture filtering anisotropic filter optimization = Off
    Texture filtering anisotropic sample optimization = Off
    Texture Filtering Negative LOD Bias = clamp
    Texture Filtering Quality = High Quality
    Texture Filtering Trilinear Optimization = Off

    Also, I have tried these settings with both AA & DX9 enabled and disabled in GTR2 Config. exe.

    Any ideas?
    Thank You
     
  2. RasmusP

    RasmusP
    Premium

    Messages:
    5,456
    Ratings:
    +1,991
    I never played gtr2 but I know some things about the inspector.
    1. Csaa stopped being a thing with the gtx 6xx series or something. It crashes the driver, never use it.
    2. I can't see which "mode" your anti aliasing is set to? Is it still at "application controlled"? It should be set to overwrite or enhance to make it work :)
    Also 8x sparse grid with only giving it 4 samples from the msaa kills performance while bit giving any better image. Rather use 8x msaa and 4x sgssaa if 4/4 isn't enough.
     
  3. Stephen O'Sullivan

    Stephen O'Sullivan
    Premium

    Messages:
    416
    Ratings:
    +301
    When using MSAA and Sparse Grid SuperSampling, it's usually a good idea to match values: 2x + 2x; 4x + 4x, etc..
     
  4. jbfan1263

    jbfan1263
    jbfan Premium

    Messages:
    19
    Ratings:
    +3
    Good information. Thank You!
    Also, my AA mode is set to : "Override application"
     
  5. RasmusP

    RasmusP
    Premium

    Messages:
    5,456
    Ratings:
    +1,991
    Then it's not working for whatever reason. 4x msaa with either 4x sgssaa or 8x sgssaa should be very very smooth!
    Where did you find the diablo bit being the correct one?
     
  6. jbfan1263

    jbfan1263
    jbfan Premium

    Messages:
    19
    Ratings:
    +3
    I'm not sure that the Diablo bit is the correct one. I just read it in a similar post, so I think I'm going to try the "Walker" setting (If I remember correctly)
     
  7. jbfan1263

    jbfan1263
    jbfan Premium

    Messages:
    19
    Ratings:
    +3
    Should AA be disabled in the GTR2 Config. settings?
     
  8. RasmusP

    RasmusP
    Premium

    Messages:
    5,456
    Ratings:
    +1,991
    Normally keeping it on will work better since the engine already enables the base of it (msaa here).
    You might wanna try "enhancing" and putting msaa to "application controlled).
    Then set it to 4x in the game and enable 4x sgssaa in the inspector.
     
  9. jbfan1263

    jbfan1263
    jbfan Premium

    Messages:
    19
    Ratings:
    +3
    I will try that. Thanks so much.
     
  10. RasmusP

    RasmusP
    Premium

    Messages:
    5,456
    Ratings:
    +1,991
    I had a quick read. Seems like you wouldn't need any bits at all according to some German forum.
    I also found this:
    https://www.racedepartment.com/threads/gtr-2-m3-nuerburgring-nordkurve.162844/#post-2883818
    You probably found that too?
    Do you have reshade or sweetFX in your GTR2 folders? If so, delete it, especially the reshade dx9 dll as mentioned in the linked post.

    Here is a Screenshot of what I would set in the inspector:
    Two configs, one might work :)

    GTR2_Inspector_1.JPG GTR2_Inspector_2.JPG
     
  11. jbfan1263

    jbfan1263
    jbfan Premium

    Messages:
    19
    Ratings:
    +3
    Wow! Thanks for taking the time to research and post that! I will definitely try those settings tonight.
    I will read through that post as well. Thank You!
     
    • Like Like x 1
  12. jbfan1263

    jbfan1263
    jbfan Premium

    Messages:
    19
    Ratings:
    +3
    Let me ask a newbie question....I installed the 10th Anniversary patch, so I assume it would have the reshade and/or sweetfx with it? I will look for them in the core folder.
     
  13. RasmusP

    RasmusP
    Premium

    Messages:
    5,456
    Ratings:
    +1,991
    Yeah that might be. As I said I never played gtr2...
    Lookout for any dll files that have reshade, sweetfx or enb in their name. Soft-delete them by moving them out of the gtr2 folder or delete them into the bin. I wouldn't hard-delete them.
    These DLLs will be in the same folder as the exe file. Maybe you'll need to dig a bit around :)
     
  14. jbfan1263

    jbfan1263
    jbfan Premium

    Messages:
    19
    Ratings:
    +3
    RasmusP,
    I followed your instructions and it worked beautifully!! Thank You so much!!
    You've been very helpful!! Much appreciated.
     
    • Like Like x 1
    • Love Love x 1
  15. RasmusP

    RasmusP
    Premium

    Messages:
    5,456
    Ratings:
    +1,991
    Glad to hear :)
     
    • Beer Beer x 1
  16. GTR233

    GTR233

    Messages:
    395
    Ratings:
    +264
    Glad to hear that all works for you now ;)
    Just a word to say that, as it was mentioned, GTR2 10th Anniversary Patch does NOT include graphic plugin such as ENBseries, SweetFX or ReShade. So I let users choose the plugin they want :)
    Moreover, the readme describes exactly what is included : if not in readme then not included, I mean no easter eggs :D
     
    • Like Like x 1
  17. jbfan1263

    jbfan1263
    jbfan Premium

    Messages:
    19
    Ratings:
    +3
    Got'cha! As strange as it may seem, I actually read the readme files as I can imagine there are some who don't. A lot of useful information in there! I did find a d39.dll that I removed (per instructions) and the sim still runs fine, so I assume it was from a previous mod or something. I read that if there is a d39.dll that the AA settings in Nvidia Inspector won't work. I may put it back tonight just to see what happens.
    Thank You
     
  18. jbfan1263

    jbfan1263
    jbfan Premium

    Messages:
    19
    Ratings:
    +3
    Also, if you are the person that created the 10th Anniversary Patch....THANK YOU!!
     
    • Like Like x 1
  19. NEChris

    NEChris

    Messages:
    3
    Ratings:
    +2
    For the best AA effect you should set AA compatibility to Diablo III
     
  20. jbfan1263

    jbfan1263
    jbfan Premium

    Messages:
    19
    Ratings:
    +3
    I did. Thank You!
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.