Upcoming Events

Rookie friendly WTCR sereis Weekly BMW races on Simracing.GP Weekly BMW races on Simracing.GP Other regular AC events on Simracing.GP Weekly GT3 Sprint Races on Simracing.GP Weekly GT4 Sprint Races on Simracing.GP

Logitech G920 brake pedal fix for ACC

Messages
41
Points
0
G920 users may have noticed that it is very difficult to get decent braking in ACC. This is because the Advanced Brake settings only allow for a maximum upper deadzone of 50% (Maximum Limit 100 on the adjustment scale) whereas I usually need about 70% upper deadzone to counteract the effect of the physical rubber bung in the G920 brake pedal. This can be set in AC but not ACC for some reason.

So how can you get good braking? First of all edit the controls.json file then change the ingame Advanced Brake Pedal setting. Here's how.

Go to your Documents\Assetto Corsa Competizione\Config folder and open the controls.json file with Notepad or your favourite text editor then scroll down to this section:

"raceCommandAxisList": [
{
"axisIndex": 0,
"axisCode": "Steer",
"minRange": 1,
"maxRange": -1,
"isCombined": false
},
{
"axisIndex": 1,
"axisCode": "Gas",
"minRange": 1,
"maxRange": -1,
"isCombined": false
},
{
"axisIndex": 5,
"axisCode": "Brake",
"minRange": 1,
"maxRange": 0.6,
"isCombined": false
},
{
"axisIndex": 6,
"axisCode": "Clutch",
"minRange": 1,
"maxRange": -1,
"isCombined": false

In the section for Brake find the "maxRange" line and edit the value from -1 (default) to 0.6. You can try other settings between 0.0 and 1 but personally I like the feel of the brakes at 0.6 which gives good braking without pushing the pedal through the floor. Remember to save the controls.json file.

Next load the game and go to Options/Controls/Brake/Advanced and set Maximum Limit to 100. Take a car out on track and you've now got brakes.

I hope you find this tip useful, maybe Kunos will change the configuration in game one day, but until then this works a treat.
 
Last edited:
Messages
546
Points
0
I hope you find this tip useful,
Thx for the info. Currently I'm using the clutch pedal of my G29 pedal set, but should I ever have/want to switch I think your approach would be the first thing I'd try.

We had a discussion about this topic (stiff, non-linear brake pedal) in another thread some time ago. Also there some interesting suggestions where made and it was also obvious, that preferences are different between people.
 

Hoksu

Premium
Messages
960
Solutions
1
Points
1,097
This is because the Advanced Brake settings only allow for a maximum upper deadzone of 50% (Maximum Limit 100 on the adjustment scale)
Why Kunos don't just fix that is beyond me. AC did not have that problem but for some reason ACC went backwards in that regard
 
Messages
2
Points
1
Exo info mate, worked for me, I was pushing past my capabilities just to get a little braking. WTF, that is important stuff, hard to do anything without brakes. Thank you so much
 
Top