Upcoming Events

Weekly BMW races on Simracing.GP Other regular AC events on Simracing.GP Weekly GT3 Sprint Races on Simracing.GP Weekly GT4 Sprint Races on Simracing.GP Daily WTCR races on Simracing.GP

Finally fixed my stuttering in ACC!

After never having ACC run without stuttering, and returning after buying the GT4 pack I was determined to try and resolve the issue. I was running at 80 to 120 fps in 4k but was still plagued with the dreaded microstutters.

Most of you may already know this, but for those who it may help.

To resolve the issue (for me anyway) if you locate the file ac2-win64-shipping.exe (which in located in your ACC game folder SteamLibrary\steamapps\common\Assetto Corsa Competizione\AC2\Binaries\Win64) - right click on it, select properties, select the compatibility tab and click on Disable Full Screen Optimisations. In game set the frame limiter to your screen refresh rate and turn on V-Sync. Windows Game Bar Mode also needs to be disabled for this to work.

I also used the same same option on the acc.exe file (which in located in your ACC game folder SteamLibrary\steamapps\common\Assetto Corsa Competizione\AC2) just in case.

It's cured my microstutters and I've been able to put most settings back to epic on 4k and retain solid 60fps with no stutters :thumbsup:

Kudos and my eternal thanks to PhilS13 at the AC Forums who posted this solution over a year ago, just wish I'd found it sooner.
 
Thanks for this tut.
Sadly, for me, it didn't work.

Could it be the game itself is "weird/faulty"?
I mean; it's weird that the VGA card is using 7(!) Gb of vram, the CPU is working at 96% all the time and the VGA itself is only running at 43% load.......(no fps lock or v-sync)
(i5 3570, 8Gb ram 1600Mhz, GTX 1070 8Gb OC)

It does the exact same thing as when I was running my GTX 680 with 2 Gb.
Now; I see dips in fps on several points on the track, the exact same spots all the time. Hungary is the worst.

I saw someone here writing that there must be a stutter when framerate changes. I see how that is logical.
But; F1 2020 for instance, changes a lot: 70/98 fps during the track, and I don't see that one stuttering really.

Now, with v-sync and framerate lock on, I get stutter on those spots on the track I mentioned before.
Lock at 60, it drops to 54.
So I lock it at 50; drops to 43. Lock at 40, drops to 27.......
How can that be?
When not locked, it doesn't go that low. When locked at 60, it "only" goes down to 54.......

Seems it HAS to drop down the fps for some reason, no matter what your VGA can do, how low the eye candy is and so on.
In my opinion, the game is just crappy made.
 
Fixed it!!

Been busy with this for too long now.......then I remembered; version 1.3.1 ran "okay" for me, so I reverted to that one ;)

It does look a bit less......ehm, nice? It seems it has a bit less eye candy, but I can't put my finger on it.
Anyway; the problem is not gone; it still does the same, but now it shows as "not fluid" instead of freezing for 0,4 seconds, making you end up in the grass.

Now; I only have v-sync on, no fps lock. All set to epic with the preset bar; thats it.
I'll keep it like this :)

May not be your choice if you want to play online ;)
 
Fixed it also here ! I came back to look how to solve those stuttering that were worse and worse, and even worse with the last 1.6 version, and got a huge improvement, and came back to some "epic" settings I had to quit before... Thank you so much !
 
Glad you've sorted the issue!
You list what amounts to 4 separate changes here: disabling optimisations, setting frame limiter, turning on vsync, and disabling game bar. Do you know for sure that all 4 are required?
Interesting. However, any time you are not holding the exact same fps as the desktop refresh rate you will micro stutter. No matter the fps. Bouncing from 80 to 120 fps will cause stuttering. ACC has no way to set the refresh rate independently in game it seems. Im going to try the compatibility thing just to see if it improves overall performance somehow. However, Im not sure that had anything to do with your original issue.
Oh my god this fix the issue I was on 100% all the time now I'm 65% on the gpu. Nice!
I was having alot of stuttering in VR, I came across this info and has seemed to solve my issues.


There are a few things you could try:


Close other programs (especially CPU and RAM heavy programs like web browsers).
Give Assetto Corsa Competizione High priority via task manager.

1) Run Assetto Corsa Competizione.

2) Open Task Manager [CTRL+SHIFT+ESC]

3) Switch it to the More details view if required using the “More details” link in the bottom right corner.

4) Switch to the “Details” tab.

5) Right click “Assetto Corsa Competizione.exe” on the list -> “Set priority” -> “High”


OPTIMIZE NVIDIA SETTINGS

If you have an NVIDIA graphics card, you can do some things to tweak your settings even more. These tweaks require that you go into your NVIDIA 3D settings, from the NVIDIA Control Panel.



Tip: Remember to keep your graphics card driver updated! Especially never graphics card will get a lot of performance boosts from just updating the drivers.



  • Open the NVIDIA Control Panel (right-click on your desktop and choose it from the menu).
Click Manage 3D settings.

You can either change the settings for all programs and games, or you can do it for select programs. Select Global Settings or Program Settings and find Assetto Corsa Competizione on the list. If you choose Global Settings, the changes will affect all programs and games.

  • Set Maximum pre-rendered frames to 1.
  • Set Preferred refresh rate to “Highest available”.
  • Set Power Management Mode to “Prefer maximum performance”.
  • Set Threaded optimization to ON.
  • Set Vertical sync to OFF.
  • Click apply and you can now close the control panel again.



Getting rid of junk files

A. Clearing PC from temporary files.

Those files don’t do anything, but they can take up a considerable amount of space and can slow down your PC even if you still have a lot of space on your storage device(s).

It’s especially helpful for those who have installed Windows for a few months and never really cleared junk from PC properly. You can alternatively use some utility programs such as CCleaner, but you still need to double-check whether all of those junk files are removed from your PC. How to do that:

• Press Win + R to open the run box -> type “prefetch” -> remove all junk (some files may not be deleted but it’s OK)

• Press Win + R -> type “%temp%” -> remove all junk (some files may not be deleted but it’s OK)

B. Run disk cleanup

Yet again there might be some programs that can do that for you, but if you don’t have one or you are not sure it actually removes the junk files – do the following

• Go to windows search and type “disk cleanup”

• Open the program

• Checkmark every file category that’s available and press OK


Maximization of power usage

• If you for some reason don’t want to use BHP, go to Power Option in Windows Control Panel and set it to High Performance. This will allow your CPU to use as much as power as possible.

I have ultimate Performance enabled


I did not do the following steps but worth a try if you are still having issues.

• Turn off C-states in BIOS*
  • This one is highly optional and I don’t recommend anyone doing that unless you know what you are doing! For example, for some motherboards not all C-states need to be turned off. C-states are the mechanisms that your motherboard uses to save energy. When C-states are turned off, CPU cannot be bottlenecked by the lack of power input from your motherboard. Disabling of C-states works very well with the High Performance power mode described above.
Game Shortcut

If you have the game shortcut on your desktop.

1. Right click on it and press properties and the Compatibility tab.

2. Tick override high DPI scaling Behavior. and choose Scaling performed by (Application) in drop down menu.

3. Tick Disable fullscreen optimizations.

4. And tick Run this program as an administrator.
Combind with this make a big difference. good job!
 
I would like to thank you, it worked for me! I've been playing for 2 years with stuttering. I already gave up on ACC. Now it is fixed!

(Dell G5 5587: i7-8750H CPU @ 2.20GHz 2.21 GHz, 16 GB RAM, Nvidia GeForce GTX 1060 (6GB) with MaxQ Design) >> I'm running almost everything on high, 1920 * 1080
 
Last edited:

RasmusP

Premium
Hurray.. People found out about v-sync making things smooth.
Glad it was helpful for some, but it's really not a guide worthy solution...

Did one of you also notice the massive input lag at 60 hz/fps + vsync?

I've just read through this thread and there are the following points to summarize:

- vsync makes things smooth

- limiter to 60 fps helps to keep the frame times steady even before vsync happens, which often smoothes things further

- with a 9 year old cpu, acc won't run great. It has too much stuff going on (that you often don't really see) and that needs some beefy cpu. Settings won't really change much.
If your graphics card is at the limit, you can easily lower settings though.

- Xbox game bar can interfere due to the overlay and recording possibility. Probably screws with non-perfect gpu drivers and takes a few percent cpu load.

- full screen optimizations enable a semi-exclusive-fullscreen mode where for example the volume changing animation of windows 10 will be visible as an overlay although being in full screen mode. This can screw with vsync, cpu load and gpu load if you're on the edge of your system or if you're using gsync in full screen-only mode, like me.


If you want smoothness and low input lag:
- either use the scanline sync from riva tuner (rtss)
- or google vsync tester, go on that page, let it run for a minute and note down your exact monitor refresh rate (Hz).
Then install riva tuner and limit your fps a tiny bit below that monitor Hz value.
60 Hz = limit at 59.97 fps.

This somehow magically keeps the frame buffers "empty" and lowers the input lag dramatically.
It gives you one frame hiccup every second to every few seconds but you won't really notice. It's still really really smooth.

I used that for years before getting a gsync monitor.
 
It doesn't fix anything for me :'( .
I can't play ACC anymore since a few days, no idea why i have all this massive stuttering, i'm with an Intel i7-9700k, RTX 3080, running arround 100 to 140 fps (1% low 95fps) in game on a Samsung Oddyssey G9, but it's really unplayable, i think i've tried everything, drivers, setting, screen setting ... i'm gonna do a complete system reinstall this week-end, and if it's still not working, well ... ACC is over for me :'(
 

Tarmac Terrorist

Paul McCaffrey
After never having ACC run without stuttering, and returning after buying the GT4 pack I was determined to try and resolve the issue. I was running at 80 to 120 fps in 4k but was still plagued with the dreaded microstutters.

Most of you may already know this, but for those who it may help.

To resolve the issue (for me anyway) if you locate the file ac2-win64-shipping.exe (which in located in your ACC game folder SteamLibrary\steamapps\common\Assetto Corsa Competizione\AC2\Binaries\Win64) - right click on it, select properties, select the compatibility tab and click on Disable Full Screen Optimisations. In game set the frame limiter to your screen refresh rate and turn on V-Sync. Windows Game Bar Mode also needs to be disabled for this to work.

I also used the same same option on the acc.exe file (which in located in your ACC game folder SteamLibrary\steamapps\common\Assetto Corsa Competizione\AC2) just in case.

It's cured my microstutters and I've been able to put most settings back to epic on 4k and retain solid 60fps with no stutters :thumbsup:

Kudos and my eternal thanks to PhilS13 at the AC Forums who posted this solution over a year ago, just wish I'd found it sooner.
Wow! Nice one MapoUK you little beauty! Whilst i don't get bad stutters the od little micro stutter is very offputting, especially at a crucial moment. Your tip has just cured that, and at a time when I am enjoying ACC more than ever before due to some steering settings I changed, this is the icing on the cake for me! Bravo!

I did'nt have to change everything though, I tried turning gamebar off and disabling full screen opps. I did'nt turn on vsync as i try not to use it if i can, and hey presto it worked! However with FS opps disabled I could not the use the windows button or alt tab out (theres a particular reason i like to be able to do this), so I tried re enabling FS Opps, as i thought maybe if im lucky, just turning off game bar has done the trick, and guess what! It has! Brilliant!

Here are my other settings
No vsync (in game or Nvidia control pannel)
Running epic graphics preset.
3440 x 1440 res
Getting about 50 FPS on start grid at Spa with 30 cars, drops top lows of about 45 during rolling start, then equals out to between 55 & 65 or higher during race (smooth throughout even with varying FPS)

Nvida control panel:
Low Latency mode: Ultra
Max Frame rate: 93 (my screen is 100hz, 93 seems to allow high frames with no tearing)
Power management: Maximum
Trilinear Optimisation: On
Texture filtering: Perfomance

My system is running a:
i7 9700F (have a feeling this proccessor may be hold the system back just a little)
RTX 2070 super
16GB DDR4 266mhz ram

Windows power management: System mechanic Ultra Performance

Thanks again mate, nice one!
 
Last edited:

Andrew_WOT

Premium
It doesn't fix anything for me :'( .
I can't play ACC anymore since a few days, no idea why i have all this massive stuttering, i'm with an Intel i7-9700k, RTX 3080, running arround 100 to 140 fps (1% low 95fps) in game on a Samsung Oddyssey G9, but it's really unplayable, i think i've tried everything, drivers, setting, screen setting ... i'm gonna do a complete system reinstall this week-end, and if it's still not working, well ... ACC is over for me :'(
For G9 stuttering read G9 thread starting from this post.
There are certain combinations of settings that work better with DSC on or off.
 
Last edited:

RasmusP

Premium

Tearing_3.jpg
 
Aren't you seeing the tearing?
58 fps at 60 hz without syncing has massive tearing for me...
I'll post a video of it later
No tearing for me at all thankfully. It stays at a constant 58. I have Radeon chill on, with a minimum of 58, which it stays at because it doesn't recognize the wheel as an input. I'm not sure if that affects it or not. Is your framerate able to stay a constant 58?
 

RasmusP

Premium
No tearing for me at all thankfully. It stays at a constant 58. I have Radeon chill on, with a minimum of 58, which it stays at because it doesn't recognize the wheel as an input. I'm not sure if that affects it or not. Is your framerate able to stay a constant 58?
If vsync isn't active and you're not using freesync, then you 100% sure have tearing. Maybe you don't notice it?
Or maybe you somehow have vsync enabled due to playing in borderless and Windows 10 desktop forcing vsync?

My fps were 100% stable. My settings are set up for 80+ fps.
In my video you can see the 60 Hz of my monitor on the left and the 58 gsync Hz on the right.
It's showing the Hz in almost real time, without gsync, it's locked at 60 Hz, ofc. With gsync, it changes with the fps.
As you can see, the 58 fluctuates a little to 57 and 59. That's normal and as stable as it gets. Frametimes in Afterburner/RTSS were a flat line, no variations.
 
If vsync isn't active and you're not using freesync, then you 100% sure have tearing. Maybe you don't notice it?
Or maybe you somehow have vsync enabled due to playing in borderless and Windows 10 desktop forcing vsync?

My fps were 100% stable. My settings are set up for 80+ fps.
In my video you can see the 60 Hz of my monitor on the left and the 58 gsync Hz on the right.
It's showing the Hz in almost real time, without gsync, it's locked at 60 Hz, ofc. With gsync, it changes with the fps.
As you can see, the 58 fluctuates a little to 57 and 59. That's normal and as stable as it gets. Frametimes in Afterburner/RTSS were a flat line, no variations.
I'm playing on a 60hz screen with no freesync. There is definitely no tearing whatsoever. I'm someone who cannot stand any tearing, it drives me nuts. I did have to lower some graphic settings to keep my framerate steady and avoid the tearing from fluctuations. My Radeon R9 390 is getting long in the tooth lol.

It is my understanding that keeping the framerate steady, with no jumps, and not exceeding the refresh rate of the monitor, would prevent tearing. That's why i chose 58, to account for fluctuations up and down.

If I get a chance, I'll jump on tonight to check the in-game and Radeon settings.

I do believe I'm in Exclusive Fullscreen, but I'm not 100% sure on that. If I'm in borderless then that would definitely explain it though. I'll confirm that this evening.
 
Also, just to add...definitely have not noticed anything like the sign tearing that you show in your video. My display is a Hisense 55" LED set in game mode, which is supposed to disable all post-processing stuff, but I suppose it is possible it is doing something on its end.

At the beginning, I did have quite a bit of tearing until i tinkered with the frame limiters, lowered some details, and whatnot.

Regardless of tearing, with vsync on or off (i hate vsync typically, makes games feel like doodoo), I experienced the stuttering while turning 100% of the time with the HLOD feature turned on.
 
Top