Brake Pedal is Only Showing 50% in Controller Properties View

cnuk

50RPM
Original poster
Jan 30, 2018
60
20
59
As the title says, my brake pedal (Thomas Super Wheel EVO) is only registering at approximately 50% in-game. This is evidenced by the Sliders display in the Controller Menu.
This is very evident when driving as I've got no brakes!
My Windows Controller Properties register correctly, and I don't see this problem in any other Sim that I've been running lately (Assetto Corsa, ACC, iRacing, RRRE, Project Cars 2).
I can't figure this one out. Help or advice would be greatly appreciated.
GTR2 Controller.jpg
TSWEvo Controllers.jpg
 

cnuk

50RPM
Original poster
Jan 30, 2018
60
20
59
I've experimented with different settings, both in-game, and in the .PLR file.
I increased the brake Sensitivity to 100%, which at least makes the cars drive-able /stop-able.
This change surprisingly shows up in the slider, increasing the range to approximately 90%. I would have thought the change would only show up as an increase in the speed at which the slider moves.
Note too, I hadn't changed any settings since the last time I used the simulator. What caused it is a mystery. I've never before set my brake Sensitivity to 100%. It was set at 20% before this happened. And it happened in all of my GTR2 installations (7 total).
 

Jempy

1000RPM
Premium
Nov 26, 2010
1,961
605
69
I'll check one of my installs in order to see if it acts the same way with my CSP V2.
Strange indeed as a sensivity and a brake gauge are something different !

If it's not the case with mine ... we'll have to search for the reason of your problem.
Do you start GTR2 with admin rights ? ... I don't see why it should have an incidence but ???
As even the GTR2config needs to be done with admin rights to be effective ... who knows it might be a reason in your case ?
 

cnuk

50RPM
Original poster
Jan 30, 2018
60
20
59
Well, interestingly, I have always just ran everything as Administrator (and I have GTR2 set to run as Administrator). A colleague warned me about the potential risk of being on-line as an Administrator. He created a new Admin account then changed my old Admin to a User account.

Everything seems to work as before except for MSI Afterburner, and Borderless Windows, and of course GTR2 (7 different installations). Can't imagine why that would make a difference with the controller (I did re-calibrated the controller in Windows 10 to see if that was causing a problem).

I did try to run GTR2 from the Admin account, but saw the same problem with the controller. Borderless Windows didn't work either (I tried reinstalling). I'll try creating a new player later today and see if that produces different results.

I did a google search for the problem, and found this at RaceDepartment:
https://www.racedepartment.com/threads/pedal-sensitivity-question.5265/

I found that in the .PLR file, my brake is shown as "Controller 1 RX"
If I change the Center value I see the following results:
Center=1.0000 (the brake pedal bar does not show or move)
Center=0.0000 (the brake pedal bar shows from 0-50% - now 0-80% after Sensitivity change)
Center=0.5000 (the brake pedal bar shows from 0-10%)

Frustrating ... sure miss NoGripRacing for issues like this.
 

Jempy

1000RPM
Premium
Nov 26, 2010
1,961
605
69
Right !!! NG was a gold mine for such informations ... but maybe a more older GTR2 user might help you in this case.

But anyway, even as User I still run those GTR2 exe with Admin rights ... and no problem.
I'm on Win10 too....
That's nearly written everywhere in all newer GTR2 infos.

I can tell you: running Bill2's Process Manager or GTR2config.exe without admin rights doesn't work at all on my PC.

EDIT: where are your GTR2 user files .... not in Documents/GTR2 I presume ?
 

Denis Betty

The older I get, the better I was.
Staff
Premium
Jun 18, 2013
8,146
4,109
Did you try creating a new user profile?
No difference?
 

cnuk

50RPM
Original poster
Jan 30, 2018
60
20
59
I'm just back from creating a new user profile.
In choosing the controller for brakes, again the slider only goes to about 60% of the bar.
And the car reacts as you would expect ... about 60% of the braking potential.
Anti-Lock Brakes and Traction-Control are Off.

Brake Controller in the .PLR file looks like this:
Axis [00, 03] Dead Zone="0.00000" // Controller 1 RX
Axis [00, 03] Sensitivity="0.50000"
Axis [00, 03] Center="0.00000"

I am running all versions of GTR2 as Administrator as checked in
Properties/Compatibility/Run this program as administrator

My User files are all in their respective folders:
D:\RacingSims\GTR2\UserData\My Name
D:\RacingSims\GTR2_PG3\UserData\My Name

I found that a GTR2 folder was created today in My Documents at the time I created a new Player Profile ... that was not expected.
But the folder for the new Player is located in the GTR2 folder:
D:\RacingSims\GTR2\UserData\Calibration Test
 

cnuk

50RPM
Original poster
Jan 30, 2018
60
20
59
Okay ... I made a fresh installation under my Administrator account using the instructions found on this forum. When I choose my controller options, again, the Brake Slider only goes to 50%. And as before, when I increase the Brake Sensitivity to 100%, the Brake Slider goes to approximately 80%. But more significantly, I can now lock my brakes!
As an experiment, I ran the Administrator Installation from my User account. All good ... I am able to lock my brakes.
Next, I copied all of the [controller] information from my Admin account (cnuk_admin.PLR) to my User account (cnuk.PLR). But that did not solve the problem.
Then I copied the entire UserData/cnuk_admin folder over to my GTR2 folder. That didn't solve the problem either ... I just can't lock up my brakes.
It's like the anti-lock brakes are on ... and believe me, I've checked this many times.
I'm beginning to think there is a controller or settings file outside of the UserData folder that I'm overlooking.
Help is appreciated!
 

Zipdrive

25RPM
Aug 1, 2011
29
10
Have you been to the Thomas Superwheel site and read their guides on setting up their wheels for GTR, GTL and rFactor ? There's also a PDF manual too that has some setup tips.

When you are depressing the brake pedal during the GTR2 controller setup process does it go all the way or only to the 50% mark ?

Wonder if your digital version of the wheel, over the analog version, has anything to do with it. Do you have another PC with say Windows 7 or 8 on it that you can install GTR2 and plug in your wheel. This would help to rule out Windows 10 as a possible cause.
 

cnuk

50RPM
Original poster
Jan 30, 2018
60
20
59
1. I've had this wheel for years and have used it for GTL/GTL/GTR2/GTREvo/RaceOn (and too many others to list) without issues
2. When I do a Windows calibration, the wheel and pedals move to their full extents (I just re-calibrated today)
3. When I depress the gas pedal in the GTR2 controller setup, it moves to the full extent
4. When I depress the brake pedal in the GTR2 controller setup, it only moves to approx. 50% (which is causing the car to feel like it has almost no brakes ... refer to screenshots in my first post)
5. When I depress the brake pedal in the GTR2 controller setup after I change the Sensitivity to 100%, the bar fills to approx. 80% (which is causing the car to feel like it has anti-lock breaks)
6. When I depress the brake pedal in the GTR2 (fresh install - Admin Account) I get the same results. However, I get the full affect of the brakes in-game ... therefore I can lock the brakes
7. Prior to all of this, I always had my brake sensitivity set to 20%, so the idea that changing the sensitivity would affect the brake travel in the setup is baffling to me

To be honest, I hadn't played these sims in awhile. It was only after creating a User Account that I went back to make sure everything was working properly ... and found this problem. All of my SimBin installs are acting the same way (GTL / Race On / and 7 GTR2 installs including my Power & Glory install).
No other sim is behaving this way (GPL, Nascar 2003/GTP, Race Room, rFactor2, AC, ACC, iRacing, Dirt Rally).

May I ask:
What does your brake calibration screen look like?
What affect does the sensitivity setting have on your configuration setup screen?
Does your brake fill the bar to 100%?
If it does, then that's where my problem lies.
Thanks!
 
Last edited:

Zipdrive

25RPM
Aug 1, 2011
29
10
May I ask:
What does your brake calibration screen look like?
What affect does the sensitivity setting have on your configuration setup screen?
Does your brake fill the bar to 100%?
If it does, then that's where my problem lies.
Thanks!
Just so you know cnuk, I don't have a Thomas Superwheel so comparing screens and sensitivities are like apples and oranges, which is why I just wanted to know if the brake bar moved to 100% during setup, thinking it may have something to do with the brake pedals travel. I have multiple rigs and various wheels connected to them but mostly my GTR2/GTL sensitivity settings are at 50% for Steering, Throttle and Brake. For deadzone, my Steering is at 0 and the Throttle and Brake are anywhere between 2 - 5 % depending on the pedal set. Also the Speed Sensitive Steering is at 0 for all wheels.

What version of windows were you using back when everything worked. With your Thomas wheel not needing any drivers it's really no different then a Plug and Play USB controller. I have an old Microsoft Sidewinder USB Wheel (non FFB) on one older system with both WinXP and Win7 in dual boot and all the SimBin titles configure the pedals just fine under Win 7.

I also still run Win7 64 bit on my main racing rig as well and until I need to upgrade to Win 10 for DX12 support I'll keep using it as all my sims and hardware add-ons work as they should. Also I've never had to run any of the SimBin EXE files as an Admin like others have. But then again I have UAC turned off and that rig is only connected to the internet when required.

One thing I noticed in one of your past posts was where you have GTR2 installed. You have it installed as a subfolder of your RacingSims folder on your D drive. Try coping the GTR2 folder to the root of your D drive and see if that makes any difference when setting up your wheel.
 

cnuk

50RPM
Original poster
Jan 30, 2018
60
20
59
Q: I don't have a Thomas Superwheel so comparing screens and sensitivities are like apples and oranges
A: I understand that ... I'm just curious to know if your brake pedal fills the controller bar. I don't remember if mine ever did.

Q: I just wanted to know if the brake bar moved to 100% during setup?
A: No, the brake bar does not move to 100% during GTR2 controller setup. It does move to 100% in windows controller setup (see screenshots in original post).

Q: What version of windows were you using back when everything worked?
A: Everything worked in Windows 10 when I ran as Administrator. As near as I can tell, the problem began after I created a User account.

Q: Try copying the GTR2 folder to the root of your D drive and see if that makes any difference when setting up your wheel
A: No difference. I've always had them in a top-level directory (that isn't Program Files).

Thanks for your attention ... I'll continue to mess around with it. At this point, It's my opinion that there is another file that deals with the controller setup (besides the xxxx.PLR file).
 

Zipdrive

25RPM
Aug 1, 2011
29
10
Sorry I haven't posted back cnuk. Had to do a full day prep on Monday for a day surgery procedure that I had yesterday.

All my wheels show 100% brake bar in both Windows Joystick Control and in the SimBin games when depressed. There was only one time that an old Momo didn't and it was due to a dirty potentiometer.

With the SimBin titles all controller settings are contained within the PLR file and in my case all those are in my UserData/Player Name folders in the main GTR2/GTL Folders. The exception being the Race07 series and it's expansion packs. My PLR file is in My Documents/SimBin/Race07/UserData/Player Name and I have a separate file (.RCS) based on any custom controller configuration I've made and that's in a ControlSet sub folder of my Player Name.

The original rFactor also has a separate Controller.ini file in the UserData/Player Name folder.

If you suspect a rouge PLR file you can always do a system search. Backup any and all you find, then delete all of them and start fresh creating just one Player Profile. Then quit the game and do a system search again for any PLR files and see if there is more then the one you just created.
 

cnuk

50RPM
Original poster
Jan 30, 2018
60
20
59
The fact that both of your controller bars fill to 100% is interesting, what I would have guessed, and what I remember.
I like your idea of a "rogue" .PLR file affecting all of the installations, but it's beyond my understanding of how that's possible.
I don't remember exactly, but I believe when I went from Windows XP to Windows 10, I installed on Windows 10, then just copied/replaced the new files with the XP files that I had saved. But I only noticed the issue when I created and ran the games under a User Account. As a User, with a Sensitivity setting of 20%, I literally had no brakes.
At this time, I believe the problem has something to do with permissions and administrator accounts!
I don't think it has anything to do with my wheel, as if functions perfectly in all other applications.
I do have another Windows 10 machine ... given the time, I may try a fresh installation on that and see how my wheel responds under that setting.
Thanks, and hope your recovery goes well.