Brake Pedal is Only Showing 50% in Controller Properties View

Discussion in 'GTR 2' started by cnuk, Dec 4, 2018.

  1. cnuk

    cnuk

    Messages:
    21
    Ratings:
    +3
    As the title says, my brake pedal (Thomas Super Wheel EVO) is only registering at approximately 50% in-game. This is evidenced by the Sliders display in the Controller Menu.
    This is very evident when driving as I've got no brakes!
    My Windows Controller Properties register correctly, and I don't see this problem in any other Sim that I've been running lately (Assetto Corsa, ACC, iRacing, RRRE, Project Cars 2).
    I can't figure this one out. Help or advice would be greatly appreciated.
    GTR2 Controller.jpg TSWEvo Controllers.jpg
     
  2. cnuk

    cnuk

    Messages:
    21
    Ratings:
    +3
    I've experimented with different settings, both in-game, and in the .PLR file.
    I increased the brake Sensitivity to 100%, which at least makes the cars drive-able /stop-able.
    This change surprisingly shows up in the slider, increasing the range to approximately 90%. I would have thought the change would only show up as an increase in the speed at which the slider moves.
    Note too, I hadn't changed any settings since the last time I used the simulator. What caused it is a mystery. I've never before set my brake Sensitivity to 100%. It was set at 20% before this happened. And it happened in all of my GTR2 installations (7 total).
     
  3. Jempy

    Jempy
    Premium

    Messages:
    1,099
    Ratings:
    +314
    I'll check one of my installs in order to see if it acts the same way with my CSP V2.
    Strange indeed as a sensivity and a brake gauge are something different !

    If it's not the case with mine ... we'll have to search for the reason of your problem.
    Do you start GTR2 with admin rights ? ... I don't see why it should have an incidence but ???
    As even the GTR2config needs to be done with admin rights to be effective ... who knows it might be a reason in your case ?
     
  4. cnuk

    cnuk

    Messages:
    21
    Ratings:
    +3
    Well, interestingly, I have always just ran everything as Administrator (and I have GTR2 set to run as Administrator). A colleague warned me about the potential risk of being on-line as an Administrator. He created a new Admin account then changed my old Admin to a User account.

    Everything seems to work as before except for MSI Afterburner, and Borderless Windows, and of course GTR2 (7 different installations). Can't imagine why that would make a difference with the controller (I did re-calibrated the controller in Windows 10 to see if that was causing a problem).

    I did try to run GTR2 from the Admin account, but saw the same problem with the controller. Borderless Windows didn't work either (I tried reinstalling). I'll try creating a new player later today and see if that produces different results.

    I did a google search for the problem, and found this at RaceDepartment:
    https://www.racedepartment.com/threads/pedal-sensitivity-question.5265/

    I found that in the .PLR file, my brake is shown as "Controller 1 RX"
    If I change the Center value I see the following results:
    Center=1.0000 (the brake pedal bar does not show or move)
    Center=0.0000 (the brake pedal bar shows from 0-50% - now 0-80% after Sensitivity change)
    Center=0.5000 (the brake pedal bar shows from 0-10%)

    Frustrating ... sure miss NoGripRacing for issues like this.
     
  5. Jempy

    Jempy
    Premium

    Messages:
    1,099
    Ratings:
    +314
    Right !!! NG was a gold mine for such informations ... but maybe a more older GTR2 user might help you in this case.

    But anyway, even as User I still run those GTR2 exe with Admin rights ... and no problem.
    I'm on Win10 too....
    That's nearly written everywhere in all newer GTR2 infos.

    I can tell you: running Bill2's Process Manager or GTR2config.exe without admin rights doesn't work at all on my PC.

    EDIT: where are your GTR2 user files .... not in Documents/GTR2 I presume ?
     
  6. Denis Betty

    Denis Betty
    Staff Premium

    Messages:
    3,828
    Ratings:
    +1,507
    Did you try creating a new user profile?
    No difference?
     
  7. cnuk

    cnuk

    Messages:
    21
    Ratings:
    +3
    I'm just back from creating a new user profile.
    In choosing the controller for brakes, again the slider only goes to about 60% of the bar.
    And the car reacts as you would expect ... about 60% of the braking potential.
    Anti-Lock Brakes and Traction-Control are Off.

    Brake Controller in the .PLR file looks like this:
    Axis [00, 03] Dead Zone="0.00000" // Controller 1 RX
    Axis [00, 03] Sensitivity="0.50000"
    Axis [00, 03] Center="0.00000"

    I am running all versions of GTR2 as Administrator as checked in
    Properties/Compatibility/Run this program as administrator

    My User files are all in their respective folders:
    D:\RacingSims\GTR2\UserData\My Name
    D:\RacingSims\GTR2_PG3\UserData\My Name

    I found that a GTR2 folder was created today in My Documents at the time I created a new Player Profile ... that was not expected.
    But the folder for the new Player is located in the GTR2 folder:
    D:\RacingSims\GTR2\UserData\Calibration Test
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.