Upcoming Events

Weekly BMW races on Simracing.GP Other regular AC events on Simracing.GP Weekly GT3 Sprint Races on Simracing.GP Weekly GT4 Sprint Races on Simracing.GP Daily WTCR races on Simracing.GP

F1 2019 Zero FFB on Thrustmaster TS-XW. I'm out of options advice is appreciated

F1 2019 The Game (Codemasters)
I've been playing other games with the wheel . But potentially my old G29 hardware drivers are conflicting with F1 2019 / 2018??
theres another steam thread where Project cars 2 was changing things in the Registry Edit, im not exactly sure and maybe i didnt do these steps exactly right. But I did perform the steps that fixed this guys wheel. https://steamcommunity.com/app/515220/discussions/0/1482109512316153067/


EDIT: so this theory got turned upside down, i plugged the wheel in and downloaded the game on my other gaming comp, updated GPU and wheel drivers, SAME PROBLEM!!!!!!!!! no FFB but inputs work!?? that comp does NOT have Project Cars2 nor did it ever have the G29 plugged in, so its not an issue with RegEdit and PC2 changing the data somehow,
SO CONFUSED!


I am running on a PC windows 10, intel i7 9th gen, Nvidia 2070. Thrustmaster TS-XW

I have input to steer/ accelerate and brake All the buttons work on the wheel and base itself, but ZERO FFB. Not even a hint.

Whats also strange is Dirt Rally 2.0 works!? I mean all other sims have worked but is it not the same game engine?

So far this is how these are the things I've tried on the top of my head.

-I’ve updated Nvidia drivers

-updated thrustmaster drivers

-verified integrity of game files

-gone though global steam input settings (forced on, forced off, default) both DX11 and DX12

-tried all profiles in F1 controller settings for the wheel

-Uninstalled old G29 drivers and Logitech Ghub with Geek Uninstaller

- uninstalled Thrustmaster drivers and Control Panel with Geek Uninstaller

-reset, unplugged, and reinstalled Thrustmaster TS-XW with newest drivers

-unchecked all controller boxes in steam controller settings

-separate pedal axis is on by default but I turned it off to try....Terrible experience and still no FFB

-plugged into another gaming comp, still no FFB



Any ideas? Im out of em. I did think it was strange when I uninstalled everything with Geek Uninstaller, which is supposed to wipe the files clean from the ssd right? So then /when I launched F1 again with a fresh install of the wheel, my profiles were saved still...

AND codemasters have gone dark on me. i have a feeling it has to do with PC2 tho
any help is appreciated
 

atorrealba

Premium
Hey man, a bit late but I'm having the same issue,

Anytime I would plug in the wheel to the USB 2.0 port on my motherboard, it would attempt to calibrate with a weird spaz in the beginning and then rotate before my PC makes another sound that it connected and THEN it calibrates/spins. Basically the wheel inputs are detected and working in game,

however there is literally NO FFB, when opening control panel it won't even test the FFB presets that shake the wheel to test the strength. Absolutely nothing, its like a dead fish when trying to race with lol


I have repaired a T500 that was bricked from updating the firmware with a wrong USB 3.0 port in the past however this seems like it is not firmwarwe/software related but rather the motor going bad.

I have opened up the TS-XW and notice an audible whining noise coming from the motor, and then every 5-6 seconds it will sound like a robot/motherboard Electronic noise and then continue the sound like its a electronic noise loop lol but it won't spin or restart.

I think its something related to the motor not receiving a signal and its retesting it, or the PCB for the motor has gone bad because it detects the input from buttons but nothing detail from the wheel
 

atorrealba

Premium
UPDATE: ended up fixing the wheelbase by opening it and re-connecting every cable to assure they are not loose

Also refastened the motor screws to assure it was seated correctly and it returned to center normally and all FFB is restored
 
Top