Upcoming Events

Weekly BMW races on Simracing.GP Other regular AC events on Simracing.GP Weekly GT3 Sprint Races on Simracing.GP Weekly GT4 Sprint Races on Simracing.GP Daily WTCR races on Simracing.GP

VR crashes pc when loading into track

I'm using Oculus Quest 2 and loading the game though Steam VR. When selecting track hitting "start" my headset black screens then my PC goes into what I'm assuming Sleep mode or just plain shuts down. I had it Working like it should for a couple day but now its doing this. Everything is up to date and the cord is fine just not sure what kills it. Game is put in VR screen mode and the Oculus App says its connected and ready to play. Any ideas on what might help it playable again?
 
I’m having exactly the same problem when using CSP 1.75 preview and Sol 2.0.2. Game runs fine on the monitor but crashes the game, the computer and the Oculus Quest 2 when I try to run it in VR. When I remove Sol 2.0.2 and roll back to CSP 1.60 everything runs fine in VR.
 
Last edited:
I’m having exactly the same problem when using CSP 1.75 preview and Sol 2.0.2. Game runs fine on the monitor but crashes the game, the computer and the Oculus Quest 2 when I try to run it in VR. When I remove Sol 2.0.2 and roll back to CSP 1.60 everything runs fine in VR.
THIS WORKED! 1.60 runs like normal. The only problem is the sky is missing, just a black void. any idae if other CSP's work without the crash?
 
Thank you both SO MUCH. I dumped about a day trying to get Assetto Corsa running and had the exact same symptoms described as the OP. (Sleep mode too)

I was running CSP 1.73 (Custom shaders patch), and SOL. (Guessing approx ver 1.5 - don't know how to check)
Switching to CSP 1.60 = success! I could leave SOL enabled.

Frame rates over beta V29 Air Link aren't amazing, and seem to drop really bad when drifting tight corners. (Feels like 15fps and becomes temporarily undrivable). Otherwise it's fine and I was able to turn out a few laps.

I'm just dumping all my information here for the next person.

Oculus Quest 2 headset
- Using V29 software, Air Link beta. Worked w 72hz, tried 90hz to try and get a smoother feel and I think it got worse unless sitting still. Will try wired later when cable arrives via amazon in 3hrs.
- Air link setup = PC -> CAT5E -> TP-Link AX11000 router (Verified 1000mbps ethernet connection) -> Dedicated 5ghz 4800Mbps Wifi 6 SSID for the headset.
Turns out that is super overkill and likely in the future, no more than 500Mbps would be used for the Quest 2. (AMD is also currently hard-limited to 100Mbps, Nvidia 200Mbps as of 6/2 for Air Link)

RX 580 GPU on 21.5.1 drivers. On my main 2D monitor, the game looks like it is running smoothly. I dumped many of the settings low to start. I think my framerate issues are just because of Air Link's current limitations.
 
Thank you, rolling back to CSP 1.60 made it work with an Oculus Rift S but no sky

I wonder if any other settings of newer CSP versions is causing these crashes, I tried disabling all "VR Tweaks" but still nothing

Is anyone else able to run their game in VR with latest CSP versions ? Doing so either crashes my whole PC or AMD drivers timeout, I have a RX580 4GB graphics card with i7-10700k CPU and 32GB RAM
 
I’m having exactly the same problem when using CSP 1.75 preview and Sol 2.0.2. Game runs fine on the monitor but crashes the game, the computer and the Oculus Quest 2 when I try to run it in VR. When I remove Sol 2.0.2 and roll back to CSP 1.60 everything runs fine in VR.
Thanks for this, I spent 2 hours trying to find a way to fix it to no solution. I still have no sky but at least the vr works now, I guess I have to wait for new updates.
 
Top