Unable to turn AI headlights on.

Oct 17, 2018
3
1
31
Hello!

I remember making a setting change where in it stated " turn on headlights when the AI does". I probably changed that value and now in night races, i have manually turn my headlights ON, while the AI do not have any headlights.

Now i'm confused as to where i did that change. Please help me how to rectify this
 

Alan Jones

10RPM
Premium
Feb 25, 2017
19
6
66
Only place I've seen that is in the custom shaders patch.
In content manager, go to 'settings' then select 'custom shaders patch', then in the Extensions list, choose 'general patch settings' and make sure the 'active' box is checked.

Now scroll down to 'Weather FX' and under 'Miscellaneous' is the option you need to make sure is checked.

I hope that clears things up and doesn't add to the confusion!

1.jpg
2.jpg
 
Apr 6, 2018
488
71
30
It is in the weather file, look at the last line.

[CLOUDS]
COVER=1 ; regulates clouds transparency: 0-1
CUTOFF=0.107 ; regulates other colors influencies on the cloud: 0-1; if 1, just the color of the cloud is considered; if 0, just the color effects on the clouds are considered; if 0.5, 50% of cloud color and 50% of effects
COLOR=1 ; base color, the sunlight, light color and ambient will be added to this: 0-1
WIDTH=3 ; width of the quad
HEIGHT=1 ; height of the quad
RADIUS=3 ; distance from the center of the skybox to the quad
NUMBER=75 ; number of clouds
BASE_SPEED_MULT=0

[FOG]
COLOR=0.012,0.012,0.012
BLEND=0.8
DISTANCE=12000

[LAUNCHER]
NAME=Night; name of the weather as it will appear in the launcher menus
TEMPERATURE_COEFF=0.8 ; creates a variation of the asphalt temperature relative to the weather, ambient temperature and time: −1-1; see the readme_weather.txt for explanation

[CAR_LIGHTS]
FORCE_ON=1
 
  • Like
Reactions: Sagar Hiremath

Paul Murphy

25RPM
Mar 1, 2011
45
12
Only place I've seen that is in the custom shaders patch.
In content manager, go to 'settings' then select 'custom shaders patch', then in the Extensions list, choose 'general patch settings' and make sure the 'active' box is checked.

Now scroll down to 'Weather FX' and under 'Miscellaneous' is the option you need to make sure is checked.

I hope that clears things up and doesn't add to the confusion!

View attachment 297448 View attachment 297449
How might I do the opposite, meaning have the AI turn lights on when I do? Or at least adjust their threshold for turning on?
 

Jim Layee

100RPM
Jun 11, 2016
233
234
55
I have a similar but different problem AI lights are on all the time , whatever the time or weather

Any ideas ?
 
  • Like
Reactions: SaXXXon