• Guest, RaceDepartment is now on Discord!  Join Here

Thrustmaster T300 help

Jun 1, 2020
6
0
43
Hi, this is my first post here. After much reading on this and another forum, I took a gamble and purchased a broken T300 to try to repair as a cheap upgrade from my current G27. Well I think I have lost this gamble lol.

I received the wheel and found it would power on and the fan would run but that was it. It would set there for a few mins with the wheel tight and after a few mins would go into overheat mode and shut down. After much reading I ordered a replacement motor and installed it over the weekend.

Now when it powers up the motor kind hums and vibrates for a few seconds at a time like its trying to calibrate itself but then stops and does nothing but the fan runs. At that point I just unplugged it to avoid overheating the motor.

I think I'm in over my head at this point, unless anyone has any ideas of what else it could be.

Also, the plastic piece that holds the hall sensor is in good shape.

Thanks in advance for any help.

John
 

TShrimp

50RPM
May 7, 2020
50
14
50
Hi, this is my first post here. After much reading on this and another forum, I took a gamble and purchased a broken T300 to try to repair as a cheap upgrade from my current G27. Well I think I have lost this gamble lol.

I received the wheel and found it would power on and the fan would run but that was it. It would set there for a few mins with the wheel tight and after a few mins would go into overheat mode and shut down. After much reading I ordered a replacement motor and installed it over the weekend.

Now when it powers up the motor kind hums and vibrates for a few seconds at a time like its trying to calibrate itself but then stops and does nothing but the fan runs. At that point I just unplugged it to avoid overheating the motor.

I think I'm in over my head at this point, unless anyone has any ideas of what else it could be.

Also, the plastic piece that holds the hall sensor is in good shape.

Thanks in advance for any help.

John
Here is a good teardown. Not sure if it will help, but I figured it can't hurt.


The T300RS GT (3 pedals) does go on sale from time to time for a good price. I got mine from Microcenter for $202 USD. However, with the pandemic it is harder to find things at regular price much less on sale :(.
 
Jun 1, 2020
6
0
43
Thanks, I had already seen that vid somewhere. I guess I picked the wrong time to try to upgrade lol. If I can't figure it out I'll probably end up trying to sell it to recoup some of my money and just save up for a direct drive wheel.
 

asteroulis

250RPM
Oct 8, 2012
428
167
It seems that the motor is stalling. First of all do a firmware upgrade (even if you have the latest) to clear it's memory. Now motor stalling can be because of the motor (it's not in your case) or because of the main board , which seems to be the case here. It's not an easy (if possible at all) fix unfortunately . So yes , sell it for parts. There are many people searching for psu's , replacement motors , hall sensor mounts etc.
 
  • Like
Reactions: TShrimp
Jun 1, 2020
6
0
43
It seems that the motor is stalling. First of all do a firmware upgrade (even if you have the latest) to clear it's memory. Now motor stalling can be because of the motor (it's not in your case) or because of the main board , which seems to be the case here. It's not an easy (if possible at all) fix unfortunately . So yes , sell it for parts. There are many people searching for psu's , replacement motors , hall sensor mounts etc.
Thanks for the response! It was your posts helping others on this and another forum that caused me to take the gamble on this.

Is it ok to unplug the motor in order to do the firmware upgrade? I tried to that once before installing the new motor, but the unit overheated and shut down before I could do it.

I hadn't even thought of parting it out but will either sell whole or the individual parts if the firmware upgrade doesn't fix it.
 

Follow RaceDepartment