The big problem with exporting to RBR. HELP!

Hi, I have a problem with the export route to RBR.
After another export it turned out that the loading path in the game crashes me to desktop. Other export routes to work, which is the longest I worked off my game.
I have Windows XP, 4GB RAM and a 1GB graphics card.

Please help, below shows the route loading screen until you dig me to the desktop.



I don't know really... Try to memorize what you did before you got this. Maybe some objects or new textures. What is shadowvolume... Maybe you checked "receive shadows" with objects - I don't use this feature. Save the project somewhere else under different name, close BTB, open the project, export... Reinstall RX plugin, even maybe RBR... Besides the screenshot everybody has no information what happened. I never had such error...
hello. This shadow file I got from a friend and it resolved the issues emerging notoriously message that you see in the image. Bay1956 what is meant by "tried Replacing 'shadowvolume.fx' with a fresh copy?"
unfortunately failed to find conflicting object which caused a crash when loading a route to the desktop, but continued to work i. .. are again the same problems. Crashes me to desktop after the addition of even a simple, contained in the default xpacku objects. Perhaps the fault of the directx? or other drivers?


So, start with just a straight road and export. If this works, add some terrain.. You can even add a single diffuse map as a terrain (Edit Materials and select the texture to diffuse only)... and so... Hard work, but maybe you find where's the conflict. Make a different tracks (open, circuit etc).
Does it all happen even with Default xpack?


I remember you have shared one of your tracks quite long time ago - is it the same hardware as then? If yes, try to memorize what changes you had in the sofware (new programs, system settings - sounds hard, I know....)
Maybe still look for most updated gfx drivers and newest possible DirectX 9.0c... and .NET Framework...
The point is that the equipment itself - graphics and music with the latest drivers. Continuous updates of the system. I have a strange feeling about the Framework ... I always had some problems with that. But strange that such a simple route, made fast in the BTB, is operating normally in the RBR: /


:) Don't ask me what is the Framework - I just have installed it... So, maybe uninstall it, dowload te latest version (3.5 I guess - I have this one here)...
So, you say you are pretty sure it's about objects? Did you ever change default xpack?



before reinstalling anything you should upload some short test track for other people to test it so we at least be sure there is nothing wrong with the track itself.

about "ShadowVolume.fx": both vertex and pixel shaders for this effect are version 2 so unless you have a very old gfx card it should be no problem loading it. (LoadEffect() : error would also occur if the file is missing or damaged but having other people test one of your tracks should clarify that);

about .NET Framework: RBR and the rx plug are NOT using it at all so version should not matter (BTB however is using .NET but thats irrelevant to your problem);

about xpack: they are used by BTB ONLY, RBR and rx are not influenced by what xpacks you may use so they are also irrelevant to your situation.

about DirectX: you should always have the latest runtime installed, you can find it here: Latest DirectX Redist. a wrong directx version can cause problems but if thats the case you'll get a "missing dll" error and the game would not work at all so i guess thats not the case.

other causes for that crash may be: conflict with other plugins and mods, altered game executable, wrong plugin<>track version.


Here's my route in the early beta version, please just download and check if it works - for me, unfortunately for pupitu crashes when booting.
you should change the windows language and keyboard settings to english before exporting the track because the punctuation in some of your ini files is wrong(ie.: SpecularColor=0,8627451,0,8627451,0,8627451 should be SpecularColor=0.8627451,0.8627451,0.8627451).

i've tried to correct some by hand but the thing its a mess, even without objects at all the track seems very fragmented.
make a backup somewhere, remove ALL the objects except ground meshes, set your system to english and try again.
in the configuration of regional settings, keyboard and now I have English. I am doing export and continues to be an error. The changes specifically what you're saying?
Top Bottom