PC Shimmering, wavy road surface - gfx setting problem

Billy Pilgrim

1000RPM
Premium
Mar 25, 2014
1,492
390
Hi
I've got pCARS running reasonably well (60 to 100 fps depending on conditions) and looking quite good, with high and medium settings, on my system (triples with 780 sli).

But the road surface can sometimes have a weird, wavy, shimmering aspect that's off putting. It's not always there: It's worse when it's sunny/clear and will be better or worse depending on the angle of the road to my (virtual) eyes. On some tracks I don't see it at all, on others it's so bad I'll stop using it.

Any tips? I can't afford to turn up AA that much. Currently, I've got my AA settings at (I think) MSAA and one of the others (can't remember, not at my PC now).
 

Thomas Wilen

25RPM
Sep 7, 2014
42
6
55
Maybe try higher Anisotropic Filtering, if it is the actual road surface texture that is shimmering?
 

Billy Pilgrim

1000RPM
Premium
Mar 25, 2014
1,492
390
As a test, do you see the same effect without any AA enabled?
I just tested with no aa. The problem disappears without aa (but the rest looks a bit rubbish obviously).
Funnily enough, with no aa my framerate goes down too (by 15-20%)
 

neuer31

500RPM
Oct 4, 2011
726
246
Could you post a pic here plz :D

And i recommend posting this issue in the offical PCARS Forum
 

Ace King

500RPM
Oct 4, 2009
920
415
My friend had this issue until he used my suggested settings: DS2X with SMAA (low), now it's fine!
 

Kyle Pearson

500RPM
Oct 26, 2008
875
271
I'm using MSAA and SMAA (low)
Edit: I've started using SMAA (medium). Doesn't seem to improve the wavy road texture problem

SMAA will have some pixelation (as will MSAA). The two combined will create more of it. Originally, the plan was to remove MSAA modes since they are problematic, but they were kept to help with some systems which may not be able to handle other modes. Try using FXAA instead of SMAA. It should reduce the pixel crawling.

FWIW, I can't remember if you have to enable that in the NVidia control panel or not for the in-game setting to work. I use DS2X and FXAA (low).
 

Billy Pilgrim

1000RPM
Premium
Mar 25, 2014
1,492
390
SMAA will have some pixelation (as will MSAA). The two combined will create more of it. Originally, the plan was to remove MSAA modes since they are problematic, but they were kept to help with some systems which may not be able to handle other modes. Try using FXAA instead of SMAA. It should reduce the pixel crawling.

FWIW, I can't remember if you have to enable that in the NVidia control panel or not for the in-game setting to work. I use DS2X and FXAA (low).
Thanks for your help. Tried FXAA though, didn't work.
This is weird.
Maybe nvidia inspector would help

What a hassle it is having to restart the game for every gfx setting change!
 
Last edited:

Ace King

500RPM
Oct 4, 2009
920
415
Another glitch to add to SMS growing fix list since i believe "off means it should be off.
 
Last edited: