• 23000+ Members! Dear Guest, join the community on the official RD Discord server today.   learn more

PC Saving Graphics Options Issue

Dave R

500RPM
Premium
Mar 17, 2015
629
208
46
I posted this in the Steam forums but didn't get much help. I hook my computer up to a 32in TV with 23hz refresh rate. I change the refresh rate to 23hz and turn the motion blur to "off". The game then says to restart for changes. I restart and both are back on again. It's basically a never-ending loop. I've tried restarting the computer, steam, etc to no avail. The game will not save any of my graphics preferences. Has anyone else experienced this? Is this a bug and is there a workaround? Thanks!!
 

William Wester

1000RPM
May 28, 2013
1,270
505
I have never had it where my graphics settings didn't stick... and this is over that past couple of years (during development and since release). So what does pCARS show as the refresh rate "before" you change it to 23hz? My first guess is it can't sync or doesn't see 23hz as a viable refresh rate.
 

Dave R

500RPM
Premium
Mar 17, 2015
629
208
46
It shows the default refresh rate as 59. GSCE, Dirt Rally, Grid AS, R3E, rFactor, and the rest of my sims all show 23hz as the refresh rate but I change PC down to that and each time it comes back with 59. It also puts the motion blur back on as well as changing other visual settings as well. I can scroll down to 23hz and then click the back button and it will say "restart to see load changes" but each time it puts all those same settings back,
 

William Wester

1000RPM
May 28, 2013
1,270
505
It shows the default refresh rate as 59. GSCE, Dirt Rally, Grid AS, R3E, rFactor, and the rest of my sims all show 23hz as the refresh rate but I change PC down to that and each time it comes back with 59. It also puts the motion blur back on as well as changing other visual settings as well. I can scroll down to 23hz and then click the back button and it will say "restart to see load changes" but each time it puts all those same settings back,
...and why don't to run pCARS at 59Hz refresh?
 

Dave R

500RPM
Premium
Mar 17, 2015
629
208
46
When I try to run it at 59hz, it's laggy and doesn't refresh correctly. I am on build #619842. Thank you all for the help!!
 

Frank

RaceDepartment Administrator
Staff member
Premium
Oct 9, 2010
3,569
1,052
When I try to run it at 59hz, it's laggy and doesn't refresh correctly. I am on build #619842. Thank you all for the help!!
The issue you are describing was also an issue on some of the earlier builds, however in this case it seems to be different.

Do you have any spare monitor that runs on a different refresh rate than 23? I have the feeling the issues lay there.
 

Dave R

500RPM
Premium
Mar 17, 2015
629
208
46
I have a MacBook Retina 15 inch that's dual booted with Windows 7. The lid on the MacBook is always closed when I'm booted into the PC Side (have it hooked into a 32in TV with a Windows Keyboard and Mouse).