RD Series on Simracing.GP

Daily WTCR races on Simracing.GP Weekly GT3 Endurance races on Simracing.GP Weekly GT3 Sprint Races on Simracing.GP Weekly GT4 Sprint Races on Simracing.GP

Reverb G2 VR noob struggling for a smooth experience

Hi everyone,

Another 'help a VR noob with my new setup' thread.

I thought that I would make the leap from an ageing triple-screen setup to a new VR rig. I have moved from a elderly Xeon X5660 and a 980Ti which ran triples at well at 60Hz on medium settings with no post processing, to a 5950X and 3080 for my new G2. I ran the G2 on the 980Ti for a few weeks while I was trying to get hold of a new graphics card, and it seemed to do OK at medium-ish settings and 60Hz (this is the max refresh rate I could set for the G2 as the 980Ti only has DP 1.2), so I had high hopes for a 3080 to be able to run with everything cranked reasonably high, some post processing added, and still be able to achieve a buttery smooth 90FPS.

I started off with Andrew_WOT's suggested 'ultra' settings using CSP and SOL_Extra. This looks great but I get 50-60FPS, the main CPU thread sits around 60%, and the FPS dips often so is all a stuttery mess. The only way that I can achieve a solid 90FPS with the main CPU thread up at ~99% is to either turn off post processing all together (turning everything else down in game just never gets you the 30-40FPS you need), or go into Steam VR and turn down the per eye resolution from 100% (3168 x 3096 on the G2) to something much lower and nowhere near as clear. I know that the 3080 needs to push out 50% more frames at 90Hz than the 980Ti did at 60Hz, but it should be ~3x faster than it!

This is all pretty disappointing. It's probably also worth noting that initially I struggled to get the G2 to work without crashing on the X570 motherboard (seems that this is a known issue). After several BIOS updates and lots of USB swapping I have found a rear port that is stable, although I can't currently get sound on the G2 which I know has worked in other less reliable USB ports. I have also run some non-VR benchmarks, and the CPU and 3080 seem to perform as expected.

Have I underestimated how much grunt you need to run a G2 in VR at 90FPS, could there still be a G2 & X570 USB issue, or is something else amiss?
 
Yeah, this has been bugging me also. I feel like there is something coded funky with this game that can't be gotten around.

With post processing On I get 55fps, with it Off 160fps. (2D) It looks nicer but not 3x nicer.

Even if I set the ppfilter.ini sections to Enabled=0, it still drops the frame rate 2/3rds.

Exactly what in post processing is causing such a huge drop in frame rate I'd like to know also.

Something is taxing the graphics and frame rate more than it seems it should.
 
Last edited:
I am running CSP 0.1.68 (with the settings as suggested by Andrew_WOT for VR, so it's not like I have everything turned up to max) and SOL 2.0.2. As soon as I turn PP (post processing) on it tanks my frame rate.

The thing that I find confusing is that loads of people seem to be running VR with PP turned on just fine on seemingly less powerful systems, so I thought that I would be fine. I could live without PP and take the higher frame rates if it weren't for brake lights and dashboard rev lights being almost impossible to see with PP turned off.
 
I'm one of those people, albeit your G2 has higher res than my vive pro (2160x2160 vs 1440x1600). I'm running a 2080 with i7-9700k and maintain 90fps with pp on.
 
CSP 1.60 and SoL 1.62 are still the best performing me. Visually, I like natural mod post processing filter much more than the SoL options.

I run 100% SteamVR and 110% AC on a 3090 and that's locked at 90fps. Visually it looks great and smooth. I'm not a fan of lower frames or reprojections so locked 90fps is my primary goal.
 
Hi there, I´m running the G2 on a 3900x and a RTX 3090 with PP off and Steam VR at 100 and AC at 129 %. Most of the tracks work with around 15 cars AI and look quite sharp. And I got the 3D printed FOV Mod wich I can absolutely recommend.
 
I’m running G2 on a I7 7700K@5ghz, Rtx3080 and had the same problem.
After i uninstalled Sol and using Natural Base PP-filter the game still looks very good and i’m reaching 90fps with 25 opponents in high-settings and 70SS in Steam-settings.
 
Last edited:
I’m running G2 on a I7 7700K@5ghz, Rtx3080 and had the same problem.
After i uninstalled Sol and using Natural Base PP-filter the game still looks very good and i’m reaching 90fps with 25 opponents in high-settings and 70SS in Steam-settings.
I thought natural mod filter required Sol to be installed....am I missing something? lol
*edit* I now see Natural Mod can be used without Sol...maybe I'll try that, as I'm currently only getting 76fps with 100%steamvr/AC resolution +CSP +Sol +Natural mod on my 5800x w/ RTX 3070, and i would like 90fps.
 
Last edited:
My recent post may be helpful to those with G2 and low FPS in AC:

 
Last edited:
There are still problems with Nvidia drivers so anyone with a 3000 series card will not be getting the expected performance from it , I had better VR performance with my RTX2070 compared to my very expensive RTX3080 , very very frustrating , Nvidia need to pull there finger out and optimize VR for the 3000 series.
 

Mauser118

Premium
There are still problems with Nvidia drivers so anyone with a 3000 series card will not be getting the expected performance from it , I had better VR performance with my RTX2070 compared to my very expensive RTX3080 , very very frustrating , Nvidia need to pull there finger out and optimize VR for the 3000 series.
I'm still on 457.30 drivers, I found the latest driver releases seem to impact performance in VR on my 2070super so rolled back to the one driver that seems to have the best performance for VR and that's 457.30. I can't speak to performance hits on 30XX cards but I was losing at least 10% in frames with the newer drivers.
 
I'm running my G2 on a 6800XT which is a touch less powerful than your 3080 and fortunately my old eyes are OK with 60FPS. I run the latest Sol 2.1 alpha and CSP preview33
I have a video showing my G2 settings in AC here for you to compare


My CPU (5600X) is never limiting unless I have around 40 AI cars so maybe that's your trouble
 
Hey Chris, did you ever get to the bottom of your performance issues in AC with the Reverb G2?

I was having the same problems with VR in AC using the G2 and 3080, but low and behold managed to get 90fps quite consistently after I turned off all post processing in the Video section of AC settings in Content Manager.
Only problem is that now all the custom tracks I've amassed don't seem to work anymore until I reenable PP, but can't for the life of me find a PP setting that gives anywhere close to the performance with PP completely off.
 
Hi @libor.masek,

I have done exactly the same thing and turned off all post processing. It doesn't look as pretty, but I prefer having a solid 90fps than having PP turned on. I'll just have to wait until the next generation of graphics cards allow me to turn all of the nice stuff on (and run ACC at anything better than a slide show at full res!).
 
@Chris, yeah, experiencing anything less than 90fps just isn't an option after you've done a few laps of your fav track at 90fps.

There must be something in the implementation of AC/CSP that just doesn't scale well to the high res of the Reverb G2, as I can get 90fps in Automobilista 2 while looking pretty decent.

Hopefully the hardware/software catches up with sim racing in VR, but technology has sure come a long way since the days of playing games like Test Drive/Turbo Out Run on the C64. At least we don't have to wait half a day for games to load from tape!
 
Hi @Chris Dawson,
I had a win with getting AC to run smoothly at 90fps with PP on.

First of all, I used the settings exactly in this video, which are shown at around 10:38

I think I had some of the shadow and mirror resolutions quite high, so set them down to what is shown in the video. I also turned back PP, and used the _Sol_Extra filter as shown.

This then allowed me to play the existing tracks I frequent (Imola etc that come with the game) with a solid 90fps. Because PP was now on, I could now also play my custom downloaded tracks (Shotuko, LA Canyons, Lake Louise), which previously didn't work without PP on. However, I was still getting frame rate drops down to 60fps for these.

I then changed the SteamVR super sampling from 100% down to 80%, and now I'm getting pretty consistent 90fps on these custom tracks, and the gameplay is now instantly more enjoyable with solid 90fps! I can't detect any difference between 100% and 80% except that the gameplay is infinitely better without the frame rate drops, so will leave it at 80%!

NOTE: I had previously changed the SS from 150% to 100% and also turned off Advanced Super Sampling, which helped, but still couldn't get 90fps with PP on.

So give that a whirl, and see if it helps. Only difference is I'm on an 10th gen i9, but believe your AMD should have enough CPU grunt.

I'm off to hoon around LA Canyons at 90fps :)

PS: I also have Automobilista 2, which I though would have much better graphics than AC, but I"m now preffering AC with these mods, especially since there's not too much car selection in AMS2, and I only drive cars with a H pattern transmission.
 
Top