Offical Studio 397 Le Mans undriveable! (SOLVED)

Tarmac Terrorist

Paul McCaffrey
Mar 22, 2017
183
58
40
So i just bought the Le Mans track, was v much looking forward to this, but its undriveable, do to extremely low FPS and stutters.
Now I know this is a big track to render but even with one car on track and driveable FPS it stutters and hangs every 5 or 10 seconds. If i put 7 AI and me on track the FPS is so low (18 - 35 FPS) its unraceable. Can't even enjoy a lap on my own due to the stutters.
Now, big track yes, so how come the Vitua LM version runs like a dream with 16 cars on track? Lowering track detail doesnt even help much.
Is it just me experiencing this? Can't believe its not been optimized enough to drive even with one car.
 

Tarmac Terrorist

Paul McCaffrey
Mar 22, 2017
183
58
40
Im just wondering if this is due to the last update, as I did'nt have the track before it was updated, just bought yesterday. Just wondering if folks who had it before the update also experienced this
 

Tarmac Terrorist

Paul McCaffrey
Mar 22, 2017
183
58
40
Main reason I was looking forward to this track is the modern layout, laserscanned and the Virtua LM version is great but, the GTE's (probably GT3's aswell but not tested) AI can't handle the curbs before the starting straight and spin out, so I was thinnking the official version would have AI sorted for this track with all official cars. So gutted I can't run it well enough to find out
 

lukester1975

10RPM
May 9, 2011
19
7
FWIW I found the same on my previous gfx card (1050) but current (rx5700) comfortably get 100fps (even after the v2 update). Pretty much maxed out settings @ 3840x1200.
 

Emery

2000RPM
Jun 6, 2009
2,212
836
If i put 7 AI and me on track the FPS is so low (18 - 35 FPS) its unraceable. Can't even enjoy a lap on my own due to the stutters.
Which video card and which cars are you using for AI? When someone has this low of fps and they're usually able to run other tracks, it's often because they are running out of VRAM.
 
  • Like
Reactions: M D Gourley

Tarmac Terrorist

Paul McCaffrey
Mar 22, 2017
183
58
40
Well yes my system is an issue here, I can run other official tracks just fine with 14 to 16 cars but that is with a lot of graphics options on low or medium, and I have been thinking the stutters (even when FPS is stable might be me running out of ram). I’m running:

Core i5 2400 at about 3.10ghz processor
MSI H61M-E33 (B3) motherboard
4 G Crosshair RAM
GTX 750 ti Nvidia graphics card
Intel 250g SSD & Kingston 500g SSD drives

Heck my wheel is only a humble old Logitech GT. I know, I know, it’s stretching it. If I had money I’d happily set aside £10,000 to run this sim, for all of its faults I’d prefer 1 car type and 1 track to race in Rfactor than hundreds in any other sim, and I’ve tried a lot! Been at it since TOCA, Papyrus, LFS, RBR (still best rally sim!), GTR, GTR2, RF1, AC, PC2 etc, only ones I’ve never tried are iracing & Netcar.
 

Ace King

500RPM
Oct 4, 2009
850
352
As Emery stated you may be running out of VRAM since your GTX 750 Ti has only "2048 MB". I recommend using a minimum 8 GB System RAM. Your track , car mod and the number of AI will directly affect your results.
 
Last edited:

Gringo

500RPM
Feb 13, 2015
990
613
52
Your hardware combo is not really that bad, I wonder if you would benefit from more RAM, 4GB is a bit low. rF2 puts a big load on your CPU, and I found that even when using low graphics settings if our CPU cant keep up then you will get FPS problems. Have a look at your CPU load (record/monitor with afterburner) while you are running rF2 if you see the CPU cores are hitting 100% then you will get render/physics thread sync problems, and a poor FPS.

Use afterburner to monitor the video card loads too, maybe it is your video card that is the limit as it has quite a low amount of VRAM.

One thing to try if you havent done so... Delete contents of the folders CBash and shaders located in \Steam\steamapps\common\rFactor 2\UserData\Log

One important detail missing from your system specs is what video resolution you are running. I could be possible to reduce your resolution to improve performance, but this would be a desperate measure.
 

Denis Betty

The older I get, the better I was.
Staff
Premium
Jun 18, 2013
6,334
2,745
Maybe check that you're using a separate thread for FFB commands? It's in controller .jason
 

M D Gourley

1000RPM
Premium
Sep 17, 2015
1,139
1,667
56
So i just bought the Le Mans track, was v much looking forward to this, but its undriveable, do to extremely low FPS and stutters.
Now I know this is a big track to render but even with one car on track and driveable FPS it stutters and hangs every 5 or 10 seconds. If i put 7 AI and me on track the FPS is so low (18 - 35 FPS) its unraceable. Can't even enjoy a lap on my own due to the stutters.
Now, big track yes, so how come the Vitua LM version runs like a dream with 16 cars on track? Lowering track detail doesnt even help much.
Is it just me experiencing this? Can't believe its not been optimized enough to drive even with one car.
I to had this problem with an older Graphics card GTX690 and all I did was update it to the RTX2070 with no other PC upgrades and got playable frame rates with everything maxed out using the new'ish GT3 and GTE cars with 10 + myself on the grid...getting around 45 - 75 fps, which I am happy with.
If you are interested, here is a link to my Thread on my new RTX 2070
 
Jan 31, 2010
1,704
1,010
Now, big track yes, so how come the Vitua LM version runs like a dream with 16 cars on track? Lowering track detail doesnt even help much.
Because the Virtua LM version is a conversion from an rF1 track that was built around 2010 and has probably something like 10 times less objects in it, plus it isn't laser scanned, so the geometry is much less detailed as well.
 

Emery

2000RPM
Jun 6, 2009
2,212
836
GTX 750 ti Nvidia graphics card
You definitely need a video card upgrade as 2 GB of VRAM is not enough for Le Mans once you put some opponents on track. You're not the first one to run into this problem with Le Mans.

If you want to still try with your current video card, turn down track detail and opponent detail. I don't know for certain it will help, but it's the only thing I can suggest.
 

Tarmac Terrorist

Paul McCaffrey
Mar 22, 2017
183
58
40
So if Le Mans is this bad on FPS cause its a big tracl (8. something miles), what the hell is Nürburgring like?
 

Shovas

500RPM
Premium
Apr 18, 2014
984
588
So if Le Mans is this bad on FPS cause its a big tracl (8. something miles), what the hell is Nürburgring like?
Even worse. I have 16GB RAM and 6GB VRAM and it can use ALL of that memory and when it does your FPS tanks to like less than 10, I'm not exaggerating.
 

davehenrie

250RPM
Jun 4, 2017
359
177
62
FWIW, I would not buy any card now, unless it had at least 8megs video ram. Things will only become more graphically demanding as we move forward. Yes, folks will say 4megs is fine, 6megs too, but if you want to avoid your current situation again in a year or two, go for 8megs minimum.
 
  • Like
Reactions: Emery

Shovas

500RPM
Premium
Apr 18, 2014
984
588
FWIW, I would not buy any card now, unless it had at least 8megs video ram. Things will only become more graphically demanding as we move forward. Yes, folks will say 4megs is fine, 6megs too, but if you want to avoid your current situation again in a year or two, go for 8megs minimum.
Megs?

Back in my day we had 640KB and we were happy
 
  • Like
Reactions: Fat-Alfie

Durge Driven

1000RPM
Jun 17, 2017
1,794
846
62
Yeah prices back then $60 per mb. to run NFS SE in SVGA you needed 16mb

Work out 16GB at that :barefoot:

I only could afford 8mb at most so I used QEMM memory manager to run NFS SE worked just as good as 16mb
 
  • Haha
Reactions: Shovas

Tarmac Terrorist

Paul McCaffrey
Mar 22, 2017
183
58
40
So is anyone else with a similar spec to me able to run this track reasonably? I can accept that it’s tuff to run FPS wise with several cars but I can’t accept that I can’t run it with even one and decent FPS but these stutters ruining it
 

Christian.ca

75RPM
Premium
Jul 5, 2012
83
70
@Tarmac Terrorist what is your setting for textures? With your GPU it could be one of the setting that might affect the performance on the latest S397 tracks. I know with my 6gb card I had to lower textures for the first time with Nords (all these graffitis comes to a cost). So with only 2gb of VRAM, textures resolution should be a problem on many of the latest track that use many high res textures.