NLRv3 users - a quick heads up if you have just updated to 2.81

Discussion in 'Sim Racing Hardware' started by Steve D, Dec 6, 2018.

  1. Steve D

    Steve D
    Premium

    Messages:
    345
    Ratings:
    +238
    Have just updated my NLRv3 to the latest 2.81 driver and firmware. This resulted in none of my existing custom profiles being registered in game, i.e there was no motion. I have no idea if this is simply an issue on my side but I thought I'd give a quick 'heads up' in case other users are experiencing the same and wondering 'what the chuff' is going on.:)

    It is recommended in the update release notes (Changes) that "due to changes in profiles internal structure," custom profiles are re-created but there was no choice in my case and I had to clone all of them again from the default game profile. (Don't use a previous clone). For info, if you do have to do this, make sure Shallow Copy is ticked, which it should be by default.

    Also, when I tried to then 'clone from the new clone,' to reduce set up time when creating multiple new profiles per sim, I appeared to have an issue where the values would reset to default after use. I'm not sure if I was doing something wrong but to overcome this I had to create each clone I required from the default profile only each time.

    Bit of a ball ache and hopefully other users won't be affected and the problem is local to me but I thought I would share anyway. :thumbsup:
     
    Last edited: Dec 7, 2018
    • Beer Beer x 1
  2. TroyC2

    TroyC2

    Messages:
    13
    Ratings:
    +3
    Thanks for the heads up Steve. You´re not the only one, I´m having Problems too.
    Since the 2.81 update yesterday my iracing profile isn´t working. Tried PC2 and DCS and they both work ok. In the iracing profile the Shallow Copy option is greyed out and can´t be ticked :(
    Any one got a workaround apart from re-installing the old driver and firmware maybe (haven´t tried it yet)?
     
  3. Steve D

    Steve D
    Premium

    Messages:
    345
    Ratings:
    +238
    If 'Shallow Copy' is greyed out it's probably because you're looking at a cloned profile and trying to clone from that. I made that mistake first time around. So create a new clone from the default iRacing profile and you should be good.

    Good luck.
     
    Last edited: Dec 7, 2018
  4. sdubbin

    sdubbin
    Premium

    Messages:
    84
    Ratings:
    +30
    does tactile not work in assetto corsa since this update. i never noticed it before so not sure if it ever did but i dont have the tab in ac , all other games have.
     
  5. Steve D

    Steve D
    Premium

    Messages:
    345
    Ratings:
    +238
    I'm not at my PC but is there anything in the new SFX tab? (Within the profile)
     
  6. sdubbin

    sdubbin
    Premium

    Messages:
    84
    Ratings:
    +30
    rfactor2 and RRE have the sfx tab , PC2 has tactile but no sfx. so i suppose ac doesnt have either.
     
  7. TroyC2

    TroyC2

    Messages:
    13
    Ratings:
    +3
    Awesome, that makes sense. I did make a clone a while back so, as you say, I was probably trying to use that. Thing is, I think I may have deleted my default iracing profile or maybe I didn´t favourite it and that´s why I didn´t see it yesterday. If I did delete it, is there a way to get the default profile back (I´m at work so I can´t check)?
     
  8. sdubbin

    sdubbin
    Premium

    Messages:
    84
    Ratings:
    +30
    change the profiles view to ALL, you will then see the default profiles you cant delete the default profile as far as i know
     
  9. RobertR1

    RobertR1
    Premium

    Messages:
    270
    Ratings:
    +131
    This update has the rev limiter intensity slider now that i've had for some time as a beta update. Keep it around 30% and it's nice when you're jumping between cars to get that physical nudge to shift.
     
  10. TroyC2

    TroyC2

    Messages:
    13
    Ratings:
    +3
    The idea crossed my mind a few minutes ago too. Makes perfect sense, cheers for the tip... looks like my weekend has been saved :thumbsup:
     
  11. sdubbin

    sdubbin
    Premium

    Messages:
    84
    Ratings:
    +30
    my problem with no tactile was to do with my cloned profile, i looked at the default and it had tactile and sfx tabs. just in case anyone is missing theirs
     
  12. Fauves

    Fauves

    Messages:
    4
    Ratings:
    +7
    Anyone use the VR compensation software ? It now causes me to have small jitters when looking around when using in Iracing. As soon as I turn off the compensation software it goes back to being smooth.
     
    • Agree Agree x 1
  13. BrainsBush

    BrainsBush

    Messages:
    219
    Ratings:
    +108
    I will do some more testing but since updating to 2.81 I experienced micro stuttering when turning my head in VR. Have not tested without VR headway yet.
     
  14. Fauves

    Fauves

    Messages:
    4
    Ratings:
    +7
    Well if you turn the actual l platform off mid race it shuts off the motion software and you can feel the difference immediately.
    There is also a hotkey which just shuts off the software only.
     
  15. anton_Chez

    anton_Chez
    Premium

    Messages:
    891
    Ratings:
    +291
    So I have been super busy and used the weekend to just relax and not be in the rig at all. What do I need to do now that I've seen this before seeing the update? Do I need to manually input all the settings for my custom profiles after the update? I have screenshots of everything in case something goes balls up but if there's a better way I'd rather use it.
     
  16. anton_Chez

    anton_Chez
    Premium

    Messages:
    891
    Ratings:
    +291
    Well I've just updated it and the Shallow Copy is greyed for me as well. Yet to test them in sim but I gather it will be the same as everyone else here with it not working. Bit of a pain since we have so many customised profiles but anyway. Hopefully there is a benefit to doing it.
     
  17. Mascot

    Mascot
    Card-carrying mod whore Premium

    Messages:
    1,281
    Ratings:
    +425
    Thanks for the heads up @Steve D. I'd updated in the middle of last week so just missed 2.81.
    I'll be avoiding it like the plague.
    No word about a fix yet?
     
  18. Steve D

    Steve D
    Premium

    Messages:
    345
    Ratings:
    +238
    Not sure if there will be mate. In the patch notes it does mention that it's 'recommended' to re-create any custom profiles, which would indicate that Next Level were aware that those created pre- 2.81 were going to cause issue, due to the new 'shallow copy' functionality.

    However, in my mind it was essential and creating replica custom profiles from the Default profile, (and not an existing clone), resolved things immediately.
     
    • Like Like x 1
  19. anton_Chez

    anton_Chez
    Premium

    Messages:
    891
    Ratings:
    +291
    I spent half hour at least fixing them all up again manually. Like I said if there is a good reason for it and we can expect an improvement then yeah I can understand. But what a waste of time if it was just for a little housekeeping. Hopefully that won't happen again. Easily the worst update from them since I've owned the platform.

    I also now have all my profiles everywhere and not as organised as they were before. Hopefully the fix for that comes sooner rather than later. OCD person here, too.
     
  20. Steve D

    Steve D
    Premium

    Messages:
    345
    Ratings:
    +238
    @anton_Chez drop Pawel an email and ask him for the beta he created for me on Friday to alphabetically group and order the profiles. Works a charm! :thumbsup:

    [​IMG]
     
    • Love Love x 1
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.