• Guest, RaceDepartment is now on Discord!  Join Here

NEW + 9.12 Hotfix!!! Final ATI Catalyst™ 9.12 Suite for Windows

Marcel Hulsbergen

#111 | Roaring Pipes Maniacs
Dec 29, 2006
2,329
22
Ati released the final 9.12 drivers.

http://support.amd.com/us/gpudownload/Pages/index.aspx

For release notes check the Ati website.

ATI has released a Catalyst 9.12 Hotfix graphics driver.

This hotfix is essentially a beta which is newer than the recent Official 9.12 Catalysts.

Specifically it resolves the mouse being enlarged under Windows 7, improves the performance of OpenGL games, provides support for CrossFireX on Eyefinity setups, OpenCL and DisplayPort Audio support, and has several other fixes.
 

Marcel Hulsbergen

#111 | Roaring Pipes Maniacs
Dec 29, 2006
2,329
22
I notice a big performance increase in Vantage, arround 1000 points more. So + 8% for me.

These drivers are highly recommended for Dirt2, as there is a fix included.
 

Piotrek Blaszczak

1000RPM
Premium
Race Ban
May 21, 2008
1,290
867
39
Is he fix the Anty Aliasing problem??I have a 4850
When i install the 9.11 drivers i have a problem with AA playnig Sim Bin games and i back to 9.9.
Maybe somebody know is the AA problem was sloved by ATI
 

Marcel Hulsbergen

#111 | Roaring Pipes Maniacs
Dec 29, 2006
2,329
22
AA is ok here if i play on highest setting and also quality on max, but if i lower the quality then it gets worse, its a simbin feature lol.
 

Ben Tusting

5000RPM
Mar 5, 2008
5,764
133
Just updated to the new drivers and the control center doesn't work :(
Why bother with updating drivers as they fail all the time
(Windows 7 Ati 4850 here)
 

Jayblue

250RPM
Sep 14, 2009
436
138
I updated to these drivers from catalyst 9.11 and my AF in Simbin games is fixed! On 9.11 it was broken. I use a HD4870 1gb on Windows 7 64bit. Dirt 2 runs more smoothly with these drivers too so thumbs up from me.
 

Nigel Atkins

3000RPM
Jan 3, 2007
3,019
64
Just updated to the new drivers and the control center doesn't work :(
Why bother with updating drivers as they fail all the time
(Windows 7 Ati 4850 here)
CCC works fine here with the new drivers, you`ve obviously done something wrong :mad-tongue:
 

Ben Tusting

5000RPM
Mar 5, 2008
5,764
133
I find the issue, Driver sweeper wasn't finding the Ati folder in my x86 program files

Yeah i did use it in safe mode
 
Jun 10, 2007
924
17
I first use Revo Uninstaller Pro to remove the drivers before going into safe mode. After that I go into safe mode and use driver sweeper. Then remove extra ATI directories while still in SM. Then after rebooting to normal desktop, run driver sweeper again to make sure, then run Registry Mechanic. Then install new drivers. Works every time with no problems. This is on Windows 7, 64-bit.
 

Follow RaceDepartment