Upcoming Events

Weekly BMW races on Simracing.GP Other regular AC events on Simracing.GP Weekly GT3 Sprint Races on Simracing.GP Rookie friendly WTCR sereis Weekly rFactor 2 events

Micro freezes

Messages
1,488
Points
3,111
Hi Guys

Today I started getting these micro freezes, noticed these before but they were hardly ever. Now it's every lap and sometimes they last long enough to destroy your race if you are in a corner.

There's also been a drop in fps and loading time's take much longer now.

All my other games are perfect, drivers and everything else is up to date, using SOL and Custom Shader Patch with Content Manager.

Tried everything, different settings, no difference. Tried Google but there was no real solution.

Hopefully someone can steer me in the right direction, thank you!

Page edit:

I deleted the Assetto Corsa folder in documents, this solved the fps and graphics issue. Loading times were still very long. Deleted Sol and shader patch, nothing.

Deleted Content manager and loading times were back to normal.

Deleted the Assetto Corsa folder in documents again, then reinstalled shader patch with sol.

Something in the Content Manager and AC file that caused this, no clue what but now everything looks and works perfectly again.

ASUS ROG Strix G17 Ryzen 9 5900HX | RTX | 32GB RAM | 2GB SSD | Dell Monitor
 
Last edited:
Messages
1,488
Points
3,111
Hi Guys

I've read a lot about people having the same or similar issues on the the net with little to no real solution to solve the problem.

I'm not saying what I did will work for everyone but it made a huge difference for me.

Still don't know how overnight with out changing anything I had a massive change in fps, loading times and overall quality. Is this from the constant changes with Sol, Customer Shader Patch with Content Manager I don't know but doing what I did made my game run like new even with all the track and car mods.

Back up all folders mentioned below before you follow this process.

You will lose all your settings and saves if you don't back up these folders.

- Back up Assetto Corsa folder in documents
- Back up AcTools Content Manager file in users\...\appdata\local\AcTools Content Manager
- Delete Assetto Corsa folder in documents
- Delete AcTools Content Manager file in users\...\appdata\local\AcTools Content Manager
- Delete/Uninstall Custom Shader Patch
- Delete/Uninstall Sol
- Restart PC
- Launch Assetto Corsa vanilla and exit when done (creates new AC file in documents)
- Reinstall Content Manager
- Reinstall Custom Shader Patch
- Reinstall Sol
- Launch game with Content Manager

This worked for me and hopefully will help others. I still recommend doing this because my game feels and looks much better now.

N.B. Remember that you can copy back all yours saves, wheel settings, controller settings, custom previews from Content Manger or anything else that you need from the files that you backed up before.

ASUS ROG Strix G17 Ryzen 9 5900HX | RTX | 32GB RAM | 2GB SSD | Dell Monitor
 
Last edited:
Messages
1
Points
11
I had very similar looking issue couple of weeks back, it turned out to be a windows "fault tolerant heap" thing. Can be fixed by accesing windows registry editor ( windows +r , run , regedit) look for Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\FTH , if theres an entry adding acs.exe in \state subfolder, delete it; also add acs.exe to ExclusionList entry. After rebooting issue should be solved. btw. backup your registry before editing it in case you mess things up
 
Messages
20
Points
26
Hi ClimaxF1. Can you please explain it a little bit more precise? How can I delete Custom Shader Patch if I've deleted AcTools Content Manager first because then it won't start anymore. And which files do I have to copy back? The whole folders? Tried your solution but still have micro freezes. Thanks
 

Panthera

Premium
Messages
13
Points
17
Hi ClimaxF1. Can you please explain it a little bit more precise? How can I delete Custom Shader Patch if I've deleted AcTools Content Manager first because then it won't start anymore. And which files do I have to copy back? The whole folders? Tried your solution but still have micro freezes. Thanks
Just to mention: kb5005033 (august patchday) can cause freezes and frame drops.
 

Similar threads

Top