Upcoming Events

Weekly BMW races on Simracing.GP Weekly BMW races on Simracing.GP Other regular AC events on Simracing.GP Weekly GT3 Sprint Races on Simracing.GP Weekly GT4 Sprint Races on Simracing.GP

Massive stuttering issues in VR

Messages
122
Points
0
Hi all,
I am having problems in the past 2 days with severe stuttering and cannot seem to find the source. The stuttering occurs when in Steam home and in all vr games, including DCS which is stand alone. I mainly use Elite Dangerous, DCS, AC1, AC2, Raceroom, PC2
I would appreciate any advise on where to go from here. Below are my system specs and the what I have done so far with no luck:
System: i9900k water cooled, 32mb ram, 2080ti, Windows pro 2004, OP on m.2 , games on separate m.2, also two other ssd drives for games, HP reverb G1. The system is used only for gaming. I keep all my drivers up to date and my bios is up to date.

I am lucky to own the Reverb, Index, and Rift S. During my testing, I have tried all three and the same problem exists. I believe this rules out a hmd issue.

I have tracked my temps and no issues there.

In FPSVR app I am getting on average of 7 to 15 FPS with the GPU being the one maxed out. CPU is fine.

When observing task manager my GPU shows 3d tracking about 35% even with me just looking straight ahead in steam home no moving my head. I have no idea what to make of this and it may not be unusual, just thought I would mention it.

Steps I have taken:
1. Used DDU and reinstalled nvidia drivers to latest....no change
2. Used DDU and reinstalled nvidia drivers to earlier version....no change
3. uninstalled and reinstalled WMR in windows....no change
4. uninstalled and reinstalled Steam WMR....... no change
5. uninstalled and reinstalled Steam VR......no change
6. rolled back the latest windows updates......no change
7. made sure all unnesessary background apps were not running.....no change
8. Ran my games in flat screen with no problems
9. Made sure no virus protection was running
10. Made sure windows firewall protection was not running
11. Checked to make sure Windows game bar was not running.
12. Checked Device Manager to make sure no issues showed up there.



At this point, I do not believe it is hardware related but software. The thing is, I cannot for the life of me figure out if it is a windows, or steam issue. I have a lot of hardware and programs installed in really would like to not have to to a clean reinstall of windows if I can help it.

Please let me know any ideas to try before I spend the next week wiping my computer and starting over.....
thanks
P.S I am posting this in several forums...I hope it not against the rules....lol
 
Messages
1,229
Points
801
Run a non Vr bench like 3D Mark TimeSpy and post your scores. That should show us if the system is working as it should. That will help narrow it down quickly.
 
Messages
122
Points
0
Run a non Vr bench like 3D Mark TimeSpy and post your scores. That should show us if the system is working as it should. That will help narrow it down quickly.

Thanks for your help!
Screenshot 2020-10-04 093312.png
 
Messages
1,229
Points
801
Ok. Good news is that your system is running normally. So it's down to your VR. A couple of things I'd try.

Turn on HWinfo64 of gpu'z in the background. Load up VR and run the AC built in benchmark in VR but watch you monitor. See the GPU load% and clock speeds. Check the power draw.

Make sure nvidia control panel is set to "maximum performance" for now.
 
Messages
122
Points
0
Ok I ran the tests like you said and I did not notice anything out of the ordinary. below is a screenshot of the sensor monitoring screen that I took. I hope you can read it and maybe find something useful.....
Screenshot 2020-10-04 102414.png
 
Messages
122
Points
0
I am going to be out of pocket for about an hour...so forgive me if I do not answer you quickly. thanks for your help
 
Messages
1,229
Points
801
A few things:
- make sure you're in High Performance mode and USB suspend is set to to disable and hard disks set to 0

1601823873802.png


- Move the HMD to a different ports on the back of the motherboard

See what that does. Disable any projection.
 
Messages
122
Points
0
Ok,
I checked:
I am in high performance mode. Usb selective suspend was enabled....
I disabled then went to device manager and made sure each device, under power management tab, allow the computer to turn off this device box was unchecked.
I rebooted....no change.
I then moved both the dp connector and the usb connector to different ports on the computer. THen rebooted.....no change.
Man, this is frustrating....lol

I am not sure how to disable any projection......
 
Last edited:

Andrew_WOT

Premium
Messages
5,539
Points
742
It's a bit bit weird.
- Do you have Free/GSync monitor. Try to set monitor refresh technology to Fixed in NVidia and VSync to Off.
- Reset your WMR home and redo boundaries
- This guy may cause issues esp. on multimonitor setups, disable it (it may show up only when WMR is active, you also should enable Show Hidden Devices)
1601833930587.png

- Double check cables, all connections, Reverb had some intermittent disconnect issues, try different USB port.
- I assume the lighting conditions didn't change since it ran fine.

Do you have any issues in WMR home, when launching WMR without Steam?

I wouldn't completely discard hardware issue, check with HP support, testing on different computer before that would be ideal.
 
Messages
122
Points
0
Well I am back up and running smoothly again! I REALLY appreciate all you guys jumping in and spending time trying to help me.

It was a windows problems (I think..lol)
I went back to windows up date and found a couple of optional updates. Two were driver updates for my monitor and usb something or other( I don't remember the whole name.
I installed those and an additional optional update appeared that was published 2 days ago. It was a cumlative update for windows 2004.

I installed that and shut down. In addition I unplugged all my peripherals except for the hmd.
I rebooted and launched wmr....no stutters. I launched AC1 in vr....no stutters.
I kept adding back my peripherals one by one and rebooting each time......no stutters.....

So, I still believe it was a windows issue and not anything to do with hardware/driver conflicts.
 

Andrew_WOT

Premium
Messages
5,539
Points
742
Glad you solved it. :thumbsup:
As you mentioned it, I had experienced something similar with pending restart updates, but as you updated your drivers few times, which requires restart, thought it's not your case.
 
Top