Issues/bugs since using SRM Fana Adapter

Spinelli

1000RPM
Jan 22, 2014
1,195
411
Ever since I installed the SRM Fanatec base-side Adapter, Automobilista has done a few strange things leaving the game literally unplayable. The following issues occur:

Issue #1
As soon as I go into the car, the car will instantly be put into first gear and I cannot put the car in neutral nor change gear at all. If I then alt-tab out of the game and go into my Fanatec shifter's control panel, I'll see that the shifter is constantly holding down the first gear button no matter what I physically do with the shifter. If I escape back to the AMS menu, my shifter responds again but the first-gear mapping is gone and both the physical first & reverse gears are mapped to the reverse button. If I go back in-game and try to drive, it again gets stuck holding down the first-gear button.

The only way to fix the physical first gear being mapped to the reverse button is to go into the Fanatec Windows control panel and re-calibrate the shifter but the problem comes back as soon as I go out on track again.

Issue #2
There is a 3 or so second delay when I do the following: start AMS, hit the drive button to go out on track, escape from the track back to the pits, escape from the track or pits back to the main AMS menu.

Notes for Issue #s 1 & 2:
  • These issues do not happen out-of-game nor in-game before I go on track nor in Raceroom. Raceroom also natively supports the LCD display and has no issues whatsover.
  • I downloaded Fanaleds and tested it on my Winodws desktop and that does not cause any issues either.
  • If I unplug the SRM adapter, the issues don't exist
  • I tried disabling AMS' auto-detection of Fana LCDs by removing ReizaSLIMaxMgrBridge.dll but the LCD still worked. How can I disable AMS' in-built Fana LCD implementation?
  • I'm guessing that if I remove AMS' built-in detection of Fana LCDs and instead rely on Fanaleds or SLIMax Manager, the issues will go away as it seems to be some sort of issue with AMS detecting and using the LCD.

Issue #3
Ever since I re-setup my Nvidia Surround settings and used the SRM adapter for the first time, I need to move my mouse to the right of all the options in AMS in order to click them when running with a bezel-compensation resolution. If I start AMS without a bezel-compensation resolution then I do not get the same issue.

Notes for Issue #3:
  • RFactor 2 with the same bezel-corrected resolution does not experience this issue.
  • This issue may have nothing to do with the SRM adapter and may just be a coincidence because the issue occurs even when I disconnect the adapter. Having said that, I don't recall the issue happening before I got the adapter.
 

Spinelli

1000RPM
Jan 22, 2014
1,195
411
In case anyone is wondering, this issue has been resolved by going into the controller file and setting either "Start Hardware Event Monitor" or "Use Additional Hardware Features" to 0. Either setting, doesn't have to be both.

This will make the LCD on the Fanatec rim not work anymore unless you use use Fanaleds (or probably also Slimax manager). That's a great solution anyways because Fanaleds and Slimax mgr offer a ton of options and control.

You may miss out on AMS' auto steering rotation working when setting either of those above settings to 0. I'm not sure as I can't test it because I don't think the Accuforce (my wheel) works with AMS' auto-rotation in the first place.

Reiza were extremely quick in responding in their official forums. Fantastic customer support :thumbsup:
 
Last edited:
  • Like
Reactions: EsxPaul