Help, very weird fps drops in races.

44
15
Can somebody help me with this?

When driving races in AC framerates drop from my normal (locked) 90 FPS to under 30.

I am not running vsync or freesync.

As you can see in the image my GPU is only running around 35% here while when driving solo or running benchmark it runs at 99% with unlocked framerate.

Nor is my CPU bottlenecking, all cores run at max 60%.

I do not have this in other sims.

PS: It might still have to do with AI, No difference between 6 or 30 opponents...Games runs smooth with 97% GPU usage....IF I am in pole position or starting last. When in the middle of the pack GPU usage drops a lot, as does the FPS. But the CPU does not get above 60% so thats not a bottleneck. Weird...weird....weird...
AC framerate issue.jpg
 

Jens Roos

Premium
900
1,305
Sweden
check this using the in-game fps app as well, if internal (game) cpu usage above 95-96% there be a drop in fps. this is not the same as you cpu usage as ac only uses 2 cores (or was it one?)
 
Just a guess, had this myself, i think it was the processor having such an easy time it would down clock.
I think it was also the same with my gpu. I just changed the settings rather than proving it, Also went for max performance both for the CPU, GPU and power setting to be always at max, no energy saving mode etc,
Or it could be over temp somewhere. NVMI, ram. or even had this with SSD being full, causing a
memory blockage, check how much free memory you have.
i am sure someone will reply with something that has more sense attached than the above, should
do for a starters.
 
44
15
Some extra info down below. I still have not been able to find the problem or a solution/workaround.

MB Gigabyte B360M AORUS GAMING 3
Intel Core i5 8600 PC1151 9MB Cache 3,1GHz
CORSAIR 650W TX650M ATX Semi-Modular (80+Gold)
16GB DDR4 (2x8)
Gigabyte GTX1070TI
SSD 500GB Samsung 2,5" (6.3cm) SATAIII 860 EVO

Monitor Samsung CHG90 3840x1080

When running AC I mostly have Crewchief running in the background.

Apps I run on screen.

Sidekick 1.11.1
FFBClip app 5.3
Car Radar 1.52
Kunos lap delta app.

I run AC through content manager, with custom shaders patch and sol.
 

Jempy

Premium
1,993
626
Belgium near Spa
So .... no need then to try what I suggested at the AC Forum ... as the issue is not AC or CM but rather in your PC.... as I may now understand.
Your problem seemed very strange ... to get only 30fps with a better PC config than mine.
 
44
15
So .... no need then to try what I suggested at the AC Forum ... as the issue is not AC or CM but rather in your PC.... as I may now understand.
Your problem seemed very strange ... to get only 30fps with a better PC config than mine.

I am going to try every suggestion till something fixes it!
 
44
15
01.jpg
Disable all apps and check again. Might be one of them going bonkers when in a pack of cars.
Quit crew chief too and report back :)

So...this must be what happens. MSI afterburner shows that my CPU is only at around 50%....but the AC app shows the CPU at 97.7% and so limiting framerate and using only 54% GPU power.

So AC does not use my multicore i5 8600 very well. Anybody know of a fix/workaround?

Edit: CPU behaves this way more with mod cars then kunos cars.
 
Last edited:
View attachment 321846
MSI afterburner shows that my CPU is only at around 50%....but the AC app shows the CPU at 97.7%
Edit: CPU behaves this way more with mod cars then kunos cars.
MSI afterburner shows overall cpu usage
AC app shows usage of its most active thread on one cpu-core

dont use bad mods, they decrease performance, when using mods here from RD your mostly fine

Maybe this helps a bit:
https://www.assettocorsa.net/forum/...to-corsa-only-use-one-cpu.53631/#post-1012571

i am not recommending anything for next values, as they differ from system to system:
"assettocorsa\system\cfg\assetto_corsa.ini"

[PHYSICS_THREADING]
; -1 = automatic
; 0 = disabled
; 1...N number of threads dedicated to physics
THREADS=4

[THREADING]
; -1=Automatic - no timer process for CPU with more than 2 cores, timer process for dual cores.
; 0=Always off.
; 1=Always on.
USE_TIMER_PROCESS=0
; 0=Windows scheduler will decide where to run the threads.
; 1=Main thread assigned to Core0, physics thread assigned to Core1
SET_THREAD_AFFINITY_MASK=0
 
44
15
MSI afterburner shows overall cpu usage
AC app shows usage of its most active thread on one cpu-core

dont use bad mods, they decrease performance, when using mods here from RD your mostly fine

Maybe this helps a bit:
https://www.assettocorsa.net/forum/...to-corsa-only-use-one-cpu.53631/#post-1012571

i am not recommending anything for next values, as they differ from system to system:
"assettocorsa\system\cfg\assetto_corsa.ini"

[PHYSICS_THREADING]
; -1 = automatic
; 0 = disabled
; 1...N number of threads dedicated to physics
THREADS=4

[THREADING]
; -1=Automatic - no timer process for CPU with more than 2 cores, timer process for dual cores.
; 0=Always off.
; 1=Always on.
USE_TIMER_PROCESS=0
; 0=Windows scheduler will decide where to run the threads.
; 1=Main thread assigned to Core0, physics thread assigned to Core1
SET_THREAD_AFFINITY_MASK=0

Thanks for your reply. Is a bit technical for me. So what are you saying? Do I need to change something in assetto_corsa.ini?
My CPU had 6 cores, 6 threads. Thats all I know, lol
 
44
15
make a copy of your original ini and try the values above

So I pasted:

[PHYSICS_THREADING]
; -1 = automatic
; 0 = disabled
; 1...N number of threads dedicated to physics
THREADS=4

[THREADING]
; -1=Automatic - no timer process for CPU with more than 2 cores, timer process for dual cores.
; 0=Always off.
; 1=Always on.
USE_TIMER_PROCESS=0
; 0=Windows scheduler will decide where to run the threads.
; 1=Main thread assigned to Core0, physics thread assigned to Core1
SET_THREAD_AFFINITY_MASK=0

Unfortunenatly no difference. Or did I do it wrong?
 
not paste, search orig values in the file and change, else you end up with double values.
and use kunos cars for testing
for clearity: removed comments:

[PHYSICS_THREADING]
THREADS=4

[THREADING]
USE_TIMER_PROCESS=0
SET_THREAD_AFFINITY_MASK=0
 
44
15
not paste, search orig values in the file and change, else you end up with double values.
and use kunos cars for testing

Ok. changed the orig:
[THREADING]
USE_TIMER_PROCESS=-1
SET_THREAD_AFFINITY_MASK=0
to:
[THREADING]
USE_TIMER_PROCESS=0
SET_THREAD_AFFINITY_MASK=0
and the orig:
[PHYSICS_THREADING]
THREADS=-1
to:
[PHYSICS_THREADING]
THREADS=4

but no difference again...

Does Content Manager use this .ini?
 
Top