Fanatec handbrake doesn't work at start

Discussion in 'DiRT Rally' started by Tomas Reinicke, Jan 11, 2017.

  1. Tomas Reinicke

    Tomas Reinicke
    Premium

    Messages:
    264
    Ratings:
    +45
    I have added a Fanatec handbrake to my rig and it works fine on stage but it doesn't work at the start of the stage.
    I get the instruction to use the handbrake but nothing happens when i pull the brake, so I can'ät start the stage, if i remap the handbrake to a button I can start the stage and if I then remap it back to the Fanatec Handbrake the handbrake works in game.

    Anyone that have had something similar?
     
  2. Evilsmurf

    Evilsmurf

    Messages:
    44
    Ratings:
    +37
    I had a problem that the handbrake needed recalibrated nearly every time I loaded dirt rally. Would normally only register half the travel of the handbrake.
    I would have to open the Fanatec app and re calibrate the handbrake.
     
  3. Ross Garland

    Ross Garland
    R3E & AMS Club Manager Staff Premium

    Messages:
    7,482
    Ratings:
    +3,255
    I don't have a handbrake so I'm only guessing. Perhaps the game is looking for a digital button press before it'll start the rally, rather than an axis? This would also explain why those that use their h-box as a stand-in handbrake don't have issues.
     
  4. RaceWasGood

    RaceWasGood
    Premium

    Messages:
    299
    Ratings:
    +107
    It should work with just the handbrake. Has worked for me even though i've once experienced something a bit similar. It might just be what @Evilsmurf pointed out; the handbrake calibration. I noticed the handbrake "calibration bar" didn't go up all the way when this happened. I didn't recalibrate it though. Guess i just rebooted the CSW wheelbase and restarted the game. After that it was OK and i forgot all about it until i saw this post. Note to self: Check handbrake calibration :)
     
    • Like Like x 1
  5. Evilsmurf

    Evilsmurf

    Messages:
    44
    Ratings:
    +37
    The calibration bar didn't go all the way up for me either, I would either unplug it and plug it back in, or re calibrate it. Usually worked for me when this happened.

    Ironically, since I moved my pc to another room for the family to enjoy, and set up my sim rig with my PS4 and Fanatec handbrake I have had no issue with dirt rally and the handbrake lol
     
  6. *CF*

    *CF*

    Messages:
    10
    Ratings:
    +6
    I have also added a Fanatec handbrake (with usb adaptor) to my rig this Monday.....I had to install the 64 bit driver 4 times to work properly ....after this, it works as x-axis in the game
     
  7. Tomas Reinicke

    Tomas Reinicke
    Premium

    Messages:
    264
    Ratings:
    +45
    Yes it works as an axis but I can't start the stage, can you use the handbrake (X-axis) at the start of a stage?
     
  8. *CF*

    *CF*

    Messages:
    10
    Ratings:
    +6
    yes it works at start as handbrake (X-axis) ...
    check adain the game controllers and try to reinstall the fanatec driver ..... hope to work and for you
     
  9. Tomas Reinicke

    Tomas Reinicke
    Premium

    Messages:
    264
    Ratings:
    +45
    It was a calibration issue, after some fiddling with getting it rigth, I used DIView to get 100% signal at full pull of the lever.
    Problem solved :)
     
    • Like Like x 3