• 27500+ Members! Dear Guest, click this link to join the community on the official RaceDepartment Discord server

CSR Elite Pedals Brake Problem

Mach

#47 G.R.Webb Sidecar Racer 1962-1972
Jan 14, 2015
159
49
45
I've had the pedals less than a week and used them for less than an hour....and they are great, but.....big fat butt!!! The brake is sticking electronically....physically fine, the pedal is fully released but the brake registers anything from 5-25%..this is the amount I have to increase the deadzone to fix it...obviously not an ideal fix...The problem lessens if I reduce the sensitivity on the pedal itself...if I disconnect the pedals and reconnect it also fixes the problem (temporarily) it comes back within 5-10 mins!..I have sent 5 tickets to Fanatec, and I'm getting very little back!

Any one experienced the same thing?? I have a video, but they have asked for it not to go on you tube....but it's going on if they can't respond tomorrow. I can't upload it here either for some reason...Any help appreciated. :thumbsup:
 
Last edited:

Blkout

2000RPM
Aug 2, 2010
2,751
593
45
I'd say try a different USB port and reinstall the drivers again. Try setting the load cell at 10 to begin with and make sure you can get 100% brake pedal travel in the Fanatec control panel. If that didn't fix it, you may have a bad load cell from the factory.
 

Mach

#47 G.R.Webb Sidecar Racer 1962-1972
Jan 14, 2015
159
49
45
Cheers Blkout.. Appreciate the response. I can get 100% no problem. In all the ports it works fine.. I have tried the driver a few times and even gone back one version but still the same. I've a feel feeling they are heading back...
 

Blkout

2000RPM
Aug 2, 2010
2,751
593
45
Maybe I misunderstood, are you saying that you can register 100% but the brake sticks sometimes at 5-25%? Does this happen in the Fanatec control panel or in a particular game? Very unusual problem, have you looked to see if something is physically binding or getting caught when the pedal is returning to start position?
 

Mach

#47 G.R.Webb Sidecar Racer 1962-1972
Jan 14, 2015
159
49
45
That's right mate, exactly that... I will have a look at the pedal more closely but I'm pretty sure that without taking it apart it seems fine. Thanks again man.
 

Mach

#47 G.R.Webb Sidecar Racer 1962-1972
Jan 14, 2015
159
49
45
Sorry for the double post....

Fanatec are sending me a new pcb and load cell.
 
Last edited:

Mach

#47 G.R.Webb Sidecar Racer 1962-1972
Jan 14, 2015
159
49
45
Will do dude.... Thanks fella.
 

James Cook

Marcas fan
Oct 18, 2013
1,143
413
39
Sorry to hear you've had problems, Matt, but at the same time welcome to Fanatec ownership!
 
  • Like
Reactions: Mach

Mach

#47 G.R.Webb Sidecar Racer 1962-1972
Jan 14, 2015
159
49
45
I've just taken delivery of a new Load cell and Pcb...free from Fanatec.

Now where's my hammer..?