• Welcome to the largest (sim) racing website in the world!
    Blurring the line between real and virtual motorsports.

CSL Elite - cant update firmware

Discussion in 'Sim Racing Hardware' started by Ariton, Jun 2, 2019.

  1. Ariton

    Ariton

    Messages:
    1
    Ratings:
    +0
    So recently i finally got my CSL Elite racing wheel. I tried to update it`s firmware but it`s always giving me an error "Default hex file load failed". I tried everything, but nothing works.

    I tried:
    - disabling antivirus and firewall
    - reinstalling drivers
    - Different USB port
    - Different computer

    but it still giving me that error. I contacted Fanatec support and they told me that its probably antivirus or something blocking it, and that i should try on a different computer. But that cant be since i tried turning antivirus off and also tried on a laptop but it didnt work. Im now completely lost, I dont know what to do. Fortunately the wheel works and I can play with it, but i would really like it to be updated to the latest version.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.