Can't access password protected server online

Abdoulaye Diop

Toyotasupra612
Hi :),
I can’t access any password protected server... I can type the password but when i press enter the field goes blank. Then when I try to type something again, it says Server Connection Failed. This is on build 860 and i'm am using the default UI, i have tried reinstall the game but i'm still having the problem..

@Gijs van Elderen, looks like it is not possible to take screenshot of the password field, i think the game doesn't allow that, the only screenshot i could take was the last one when it says "server connection failed"
 

Attachments

  • GRAB_026.JPG
    GRAB_026.JPG
    235.2 KB · Views: 320
If you try to join one of the club race or league server have you tried to install the vmod manually? Maybe you have a missing component. So it think a car or track is missing,
 

Abdoulaye Diop

Toyotasupra612
I did install the mod manually, i have the 3.5 car since it is out and i took the track and the mod the day i subscribe for the race, i have started the mod offline without any problem, if there was no password on the server, i would be able to join, this is why it is a weird problem..
 
When you type in the wrong password you'll get: "server connection failed"

But the field going blank :O_o:, is a new one.
- What you could try is remove the player.json and multiplayer.json file. (Make a copy to the desktop first)
- start rFactor 2 again. (it will create a new player.json and multiplayer file)
- You'll have to set your in game graphic settings again.

BTW: You have no problem with non passworded servers?
 

Abdoulaye Diop

Toyotasupra612
yep i have no problem with non passworded servers, i just tried to remove player.json and multiplayer.json but still no change... i also sent a mail to rfactor2 support, i m starting to get really lost with this..
 

Abdoulaye Diop

Toyotasupra612
i made a video from my phone and uploaded it on mediafire as you guys can take a look :)

(mod edit: video with server password removed)
 
Last edited by a moderator:
Got it mate, ;)

I had to remove the link. :whistling: Sorry about that.
I'm still puzzled with the problem... I've no problem if you send the video to ISI support.
But not in public... ;)

But what you can try, Make an other lite install in an other folder: ex: rFactor3. (I've 3 installs on my PC)
install the track, car, Vmod on that install.
(you can install content from 1 common package folder to an other rF2 installs in the mod-manager)
 
Last edited:

Abdoulaye Diop

Toyotasupra612
Well, the lite install actually, its been a little while that i've not done a big fresh install, and i've stopped playing rf2 last june as my online suscription was over, and i took a year suscription like 1 week before spa race, and i did update to the build 860 at that moment with the automatic update, in my opinion that's is when the problem started, maybe some files from the old build were mixed with files from the new build so something was going wrong... but now i have the fresh install and i was able to move all my mods on it and everything works, thanks to you guys again ;)
 
Aha,

You missed an update. ;) An importent one: The player.ini file is no more...
It has become the player.json file. Same file but different structure. More info: click here

It was recommend to do a new fresh install. So you missed nothing. :p
 
I had this problem yesterday too, with the RD FR35 Bahrain server. I seemed to solve it this way -

I run command prompt 'as administrator' then run these 3 commands and reboot.

netsh winsock reset catalog
netsh int ipv4 reset reset.log
netsh int ipv6 reset reset.log

Then I could get in server.
 
Top