Assetto Corsa Launcher not starting ( Solved )

Discussion in 'Assetto Corsa' started by =-B-R-A-K-E-=, Jul 18, 2016.

  1. =-B-R-A-K-E-=


    Dear all,
    i have a serious issues i cannot deal alone with:
    I just made a clean install of Windows 10 (pro). Made all updates. Installed all drivers. Installed Steam. Installed Assetto Corsa (with every packs). But when I start Assetto Corsa, the Launcher isn't even showing up.

    My new rig:
    i7 6700K, ASUS Hero VIII, EVGA GTX1080 SC Gaming, 32GB Corsair DDR4, 1TB SSD Samsung 850 Evo, Oculus Rift CV1, Logitech G27, Corsair K70 RGB RapidFire,....

    On my old PC i had Windows 8.1 running. Assetto Corsa was fine.
    Then I made the update to Windows 10. Assetto Corsa was fine.
    Then I set up my new rig with my old SSD drive. Assetto Corsa with Oculus was still fine.
    Then I made my clean install with Windows 10. Now Assetto Corsa is not launching at all.

    When i launch Assetto Corsa, 2 instances of "Assetto Corsa Launcher 32-bit" show up in Windows task manager. Then I get 2 "beep-beep" sounds from Windows and that's it. Nothing happens.

    In windows event monitor i get the following Errors:
    1. Anwendung: AssettoCorsa.exe Frameworkversion: v4.0.30319 Beschreibung: Der Prozess wurde aufgrund einer unbehandelten Ausnahme beendet. Ausnahmeinformationen: System.NullReferenceException bei AC.Launcher.Startup.Main(System.String[])
    2. - <System>
      <Provider Name="Application Error" />
      <EventID Qualifiers="0">1000</EventID>
      <TimeCreated SystemTime="2016-07-18T18:18:54.307563900Z" />
      <Security />
      - <EventData>
      <Data>C:\Program Files (x86)\Steam\steamapps\common\assettocorsa\AssettoCorsa.exe</Data>
    3. Application: AssettoCorsa.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.InvalidOperationException at System.Windows.Threading.Dispatcher.WndProcHook(IntPtr, Int32, IntPtr, IntPtr, Boolean ByRef) at MS.Win32.HwndWrapper.WndProc(IntPtr, Int32, IntPtr, IntPtr, Boolean ByRef) at MS.Win32.HwndSubclass.DispatcherCallbackOperation(System.Object) at System.Windows.Threading.ExceptionWrapper.InternalRealCall(System.Delegate, System.Object, Int32) at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(System.Object, System.Delegate, System.Object, Int32, System.Delegate) at System.Windows.Threading.Dispatcher.LegacyInvokeImpl(System.Windows.Threading.DispatcherPriority, System.TimeSpan, System.Delegate, System.Object, Int32) at MS.Win32.HwndSubclass.SubclassWndProc(IntPtr, Int32, IntPtr, IntPtr)

    Things i have already tried:
    • Make a local check of Assetto Corsa files.
    • Uninstalled some additional programs (ASUS AI Suite, etc...)
    • Turned every overclocking off
    • Installed DirectX and vcredist from folder "_CommonRedist"
      DOTNET4.0 couldnt be installed since it is already part of Windows10.
    • I even installed Visual Studio in order to get all C++-Runtimes I can possibly think of.
    • I also created a new windows user with admin rights and tried everything all over
    • There was a certain Windows Update to be found in other forums, that needed to be installed. I do not have this update.
    • I also uninstalled Assetto Corsa and Steam. Deleted everything and Only installed Assetto Corsa Basic (without the add-on packs).
    Has anyone an idea? Anything?
    Please help. I have been so frustrated that I bought ProjectCars - just to play "something".... :)

    Thank you for any help!

    Attached Files:

    Last edited: Jul 18, 2016
  2. Andrew

    Out of my mind ! Back in five minutes. Staff Premium

    Maybe Assetto Corsa does not feature 64-bit systems ?
  3. Bokonon


    Assetto Corsa does support 64 bit systems, and it even has a 'froce 32 bit option for those that need it. @BRAKE if you haven't already I would submit a thread with all this info over at the official AC support forum. Logically though this game has worked with all your previous set-ups so it is likely to be to do with your latest windows install. Maybe try sfc/ scannow in the windows command line to check all windows files are present and correct.
    • Like Like x 1
  4. =-B-R-A-K-E-=


    It ran all fine before the clean install of Win10. Before it was 64-bit, too.
    Must have something to do with the "clean" install. Maybe some old .NET-things aer missing now....
  5. =-B-R-A-K-E-=


    I already did "sfc /scannow", everything was correct...
    I did post the issue on - Hoping for Kunos to fix it..
    I also found one other thread there where someone has the same issue after a clean installation.
  6. Rami

    #20 FinnTeam Premium

    @=-B-R-A-K-E-= I remember reading somewhere that some contollers (xbox mostly) can cause this. Have you tried with all sim equipment disconnected? I had trouble with that same mobo than yours with usb devices not been recognized properly. Also was having trouble if any of ASUS programs were installed. Hope you get your AC running again...
    • Like Like x 2
  7. =-B-R-A-K-E-=


    YES!!!! Rami, you are THE man!! Thank you for the hint.
    After uninstalling absolutely EVERYTHING and step-by-step re-installing one after another, I can say that it IS related to ASUS software package.
    It seems that the SONIC STUDIO (Audio enhancement) is the one to blame.
    If I kill all of its processes, Assetto Corsa is starting, again.

    I will contact ASUS and also inform Kunos.
    This issue seems to be solved for now. Thank you sooo much. I tried almost everything, but forgot to do the most obvious :)
    • Like Like x 2
  8. Rami

    #20 FinnTeam Premium

    Glad I could help :)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.