Appcrash d3d9.dll with GID Plugin

Hello everyone,

GID was using plugin 1.2 smoothly when stopped working.
When loading the track I get a message like this:
Problem signature:
Problem Event Name: APPCRASH
Application Name: rFactor.exe
Application Version:
Application Timestamp: 4e860117
Fault Module Name: d3d9.dll
Fault Module Version:

I've tried reinstalling the game without MODS, TRACKS or other Plugins, use version 1.2 to 1.5 of the plugin and still showing the same error.

I do not need MiniMap, but to delete the d3d9.dll the plugin does not work.
Have googled for similar problems and all unsolved. Does anyone have any ideas or tips that might help?

Thanks for reply,
Yes, I have also tried this, as well as many different d3d9.dll files and reinstall Dx9. Weird because I use the same plugin in "Game Stock Car" without problem.
IIRC, rF does not have a d3d9.dll itself. Only add-ons add that. But, if you only delete that from a GID install, rF still tries to start the GIDPlugin.dll in the plugin folder. To remove it you would have to delete both .dlls. That should allow rF to run without the GID.

Not sure why you had the original problem though. I've used GID for years without problems. I'd suggest installing a fresh rFlite, confirm it works, then copy or reinstall the mods, plugins, player folder from the corrupted install. You shouldn't have to deal with Trymedia or the latest license stuff, because you aren't doing a new install, only another rF copy.