AI Track Learning not working

TJam-11

10RPM
Original poster
Mar 1, 2016
11
1
31
Hi,
Does anybody know how to get the AI learning to work?
I've followed the instructions exactly as laid out in MarcG's guide here:
https://forum.studio-397.com/index.php?threads/ai-learning-step-by-step-guide.47657/

But the AI does not proceed to enter learning mode when I click add AI.
It just sits there for a bit and then goes out like normal in a session. I don't get any messages telling me the AI has entered learning mode or that he's getting closer to '0.00' with each lap.
He just laps as normal.

I found a thread that said to try it by unchecking practice, quali and race to enter test day mode, but no luck, it still does the same.

Anybody know how to get this working?

Many Thanks,
J
 

MarcG

1000RPM
Premium
Jun 17, 2011
1,842
2,370
What track are you trying with? Rarely some tracks just don't work in my experience.
 

TJam-11

10RPM
Original poster
Mar 1, 2016
11
1
31
Ha, a reply from the man himself!
I tried two different tracks by "RaceRFactor" - Spa and Red Bull Ring. Neither worked.
Let me try with a stock ISI track...
 

MarcG

1000RPM
Premium
Jun 17, 2011
1,842
2,370
Ok, it's been awhile since I did it myself so let me check tomorrow and I'll get back to you :)
 

MarcG

1000RPM
Premium
Jun 17, 2011
1,842
2,370
Ok @TJam-11 with default ISI/Studio397 content it's working for me.

I have just altered the process slightly in that post to reflect the change to have 0 AI first then Unselect all 3 sessions, please try again Step-By-Step with default content (not 3rd party) and see if it works for you :)
 

MapoUK

100RPM
Jan 28, 2013
208
145
48
I can confirm it's working for me as well, setting to 1 in the json file then unselecting all 3 sessions (test day) and then adding one AI once in the test day has started. I remained in the pits as the AI go out and start running laps.

When the AI leaves the pits I got a message saying 'stay out of my way human...' which indicated they had started the learning process.
 

TJam-11

10RPM
Original poster
Mar 1, 2016
11
1
31
Still can't get it to work, no matter what I try.
I must have a broken game.
Nevermind!
 

TJam-11

10RPM
Original poster
Mar 1, 2016
11
1
31
Nope, just Single Player.
Update: Okay, I CAN get this to work in Dev Mode. But only Dev Mode.

I found another Player.JSON in the "ModDev" folder and changed 'AutoCalibrate AI' option to 1.
So I had both Player.JSON files found in UserData and ModDev folders respectively set to 1.

Tried Single Player again. No luck. So out of curiosity I booted up DevMode and tried it with the stock Joesville track and Skip Barber vehicles found within. Worked instantly.
Went back to single player mode and tried to replicate the settings exactly but nothing.

So my next question is simple - If I load the tracks and cars so they can be used in DevMode and simply do the AI learning there, would I be able to achieve the same result which can then be put to effect in Single Player?
 

MarcG

1000RPM
Premium
Jun 17, 2011
1,842
2,370
Backup your player.json file in the normal install (not moddev), when you next run RF2 it'll create a fresh default one, then edit and edit the calibrate setting then try again. My theory is your regular player.json has perhaps got corrupted or not updated properly at some point, I've never had the need to do learning in dev move so can't answer your question.
 

TJam-11

10RPM
Original poster
Mar 1, 2016
11
1
31
Nope, just Single Player.
Backup your player.json file in the normal install (not moddev), when you next run RF2 it'll create a fresh default one, then edit and edit the calibrate setting then try again. My theory is your regular player.json has perhaps got corrupted or not updated properly at some point, I've never had the need to do learning in dev move so can't answer your question.
Yep, that fixed it!!!!

Must have been a dodgy Player file.

Thanks Marc, we got there in the end :D
 
  • Like
Reactions: MarcG

Boby Kim

1000RPM
Aug 28, 2010
1,757
703
Hello, sorry to re open this thread.
Problem: in Json i set autocalibration at 1.
I set all parameters correctly, i also uncheck all sessions. Once i hit start the game loads and i end up at the full practice start with all AI's, while i set the amount to zero:O_o:
When going back to the main menu, all sessions have been selected, every setting has gone back as it was before (my default race settings).
I want to autocalibrate on Reiza's VIR with the Metalmoro MR18.