• Welcome to the largest (sim) racing website in the world!
    Blurring the line between real and virtual motorsports.

Aggggh My Track Suddenly has an Error

Discussion in 'Bob's Track Builder' started by Gee Truelove, Sep 9, 2009.

  1. Gee Truelove

    Gee Truelove

    Hello Blokes,

    Ok heres the scenario,i have been making a track,and each time i do something new i usually load it up into rF to see what it looks like.

    Well everything was going great,until i got this error out of the blue when loading up in rF,

    1. gMOTOR 2 Error
    Error loading texture 003 for material roada45.
    2. gMOTOR 2 Error
    Error loading global material roada45.

    For my road textures im using Road_Mid xpack, ive tried changing the textures to something different but still get the message.

    I really need your help on this one,so Thanks in advance.

    MrGeeman (MrMenMods)
  2. banger


    check any background picture/blending materials, i had a random problem like this before.try changing the file format to targa,(that what i used).jpg seems to cause issues.? it the only thing i can think off atm.
  3. Gee Truelove

    Gee Truelove

    Cheers Banger,that helped, what i did was go in to the folder in rF,found the 003 tex,opened it,saw what it was,then wentinto Bob's and changed it,all sorted.

    Thanks again. :woot2:
  4. mianiak


    I'm getting these same loading errors. I'm using a custom texture and initially it was 2048x2048 DXT5 12 levels, I have resized it down to 256x256 DXT5 10 levels, then when I start rfactor I get this error ^^.

    I went to the game directory and opened all textures then re-saved them and the track loaded but all the textures were off centre, all the tree trunks were on the outside of the tree model. The road texture was massive, the yellow lines were almost as wide as the car and on the side of the road instead of the centre. Unfortunately I didn't get a screenshot because I just thought it was probably the mapping. So I turned the game off and went through every texture that I am having problems with and using the materials editor, replacing them with a random tex then back to the texture I edited thinking it might be a mapping issue from the difference in sizes and hoping that replacing > replacing might reset something. But no luck, I'm still getting this error.

    It could be the levels of mipmaps, but right now, I need to step away and take a break from it, so I thought I'd post and see if anyone knows exactly what's going on before I spend more time doing trial and error. :)

    [ED] Forgot to mention that I don't have any background images in the project.

    [EDD] I think I found the problem, the mip maps weren't filling up the whole aera and had left a blank pixel where 1x1 should have been, By changing the mip map setting to 'ALL' it saved that extra pixel and it works fine. I don't know if this is what exactly happened that caused it or not and I don't know why or how this works, but it works now :D .
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.