1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

GTL Registration Fix

Discussion in 'GT Legends' started by Ramon van Rijn, Jul 29, 2009.

  1. Ramon van Rijn

    Ramon van Rijn
    Premium Member

    I made a fix for registration of new online drivers also.
    Warren pointed to me this was still not working.

    I also found where in the code the referral to the old domains are, so might be able to work together with SB on a fix.

    The fix is basicly the same as the normal fix but it uses domain www.gtl-server2.net as domain name with the same ip address. This domain is used for registration of new drivers.

    Manually adding " www.gtl-server2.net" to the hosts file does the trick or use the attached cmd file.

    I have informed SimBin about a GTL fix i can create if they decide on a new domain. It will be a proper fix without hosts file tricks :)

    Attached Files:

  2. Bram

    Roaring Pipes Maniacs | #27 Staff Premium Member

    Nice, so you will send your second invoice to simbin soon?
  3. Ramon van Rijn

    Ramon van Rijn
    Premium Member

    First post updated with the fix.
    Have fun new drivers!
  4. Warren Dawes

    Warren Dawes
    Premium Member

    We cannot thank you enough for your time and skill to keep GTL alive for us lovers of GTL. :handshake:
  5. Ahhh I know what's going on here...
    Ramon is keeping GTL alive now the 1310 mini mod has arrived cos he wants to kick our asses a bit more :party2:

    Thanks mate, much appreciated!
  6. Perhaps Simbin might like to make a donation to RD :wink2:
  7. Stuart Thomson

    Stuart Thomson
    The Stoat Without Fear ™ Premium Member

    That Ramon feller - he's different class on and off the track :good:
  8. Ramon van Rijn

    Ramon van Rijn
    Premium Member

    You should have seen me in the PCC at Mid Ohio yesterday. Normally I mis-shift about 2-6 times in a race (h-shifting that is). But now it was about 6 times a lap.
    So my result was going off track, then spun the car and stalled it (auto-clutch off), then accelerated too much on the curbs ending myself kissing the wall. At least I finished the race.

    But indeed the Mini's are sweet :), I think I am back on earth now. The trip to Mars was nice tho :)
  9. Unable to Register - Cannot Connect to Server

    Based on the comments above, it sounds like the servers may be offline and that is why I cannot register for online play. I am a new member and I have never registered. I tried your fix. No luck so far. I get the failed server connection message.
  10. Ramon - you are an absolute top bloke :good:
  11. I am unable to register/connect either being a new user. any ideas?
  12. Stuart Thomson

    Stuart Thomson
    The Stoat Without Fear ™ Premium Member

    well it depends on where you are trying to connect.

    If it's to the lobby, you cannot, no-one can as it is totally down.

    If it's to a LAN / Direct ip game, I'm not sure if you need a registration.
  13. As i reinstalled the game, it seems i need to register again...

    So with a fresh install, i first install the cmd from Ramon back in July called "gtlfix", and then i install this one here "gtlregister". That all?
    Because i did that and it's impossible to connect to the server according to GTL...
  14. Stuart Thomson

    Stuart Thomson
    The Stoat Without Fear ™ Premium Member

    Bert - those fixes from Ramon are no longer valid - the new problems mean they no longer work.

    We are using the Anti-Deco patch to connect now, via the LAN / Direct IP method, NOT Internet, as has been detailed in many posts.

    go here and see how you get on: http://forum.racedepartment.com/356061-post7.html
  15. Ok tx Stuart.

    So think with me. The two "broken" fixes from Ramon, i installed them. What do they do and do they go in GTL itself? those little cmd's.

    I am asking this because if i want to install the anti-deco, what do i need to do now, uninstall the whole gtl first, or can i find the patches, cmds somewhere on my pc and delete them from there?
    Because in some of those thread i also could read the two don't work together. So if i would install the anti-deco now, it won't work. At least, that's what i got from reading all of it...

    EDIT: oh yeah, in step 3 of the link it says you need to give in yr normal username and password. But if you can't register, there's no password. :s
  16. Stuart Thomson

    Stuart Thomson
    The Stoat Without Fear ™ Premium Member

    Ramon's fixes affect the "hosts" file, but the anti-deco will overwrite them anyway, but if you want to manually fix it, go to the hosts file and remove all references to GTL.

    Install the anti deco, run GTL from the Anti deco icon (that bit is important), anti-deco will overwrite the hosts file.

    As for usernames and passwords you can just add them into your player file manually.

    in the [ Multiplayer Options ] section, at the bottom just add the lines

    Online UserName="[type your username here]"
    Online Password="[type your password here]"
  17. Stuart Thomson

    Stuart Thomson
    The Stoat Without Fear ™ Premium Member

    Yes - that works - I just manually added a totally made up user name and password to my plr file, and as long as I had the right ip and server password, I connected fine. :good:

    I logged in as Jackie Bollocks, if you must know :D
  18. Please oh please tell me you done some laps :)
  19. Stuart Thomson

    Stuart Thomson
    The Stoat Without Fear ™ Premium Member

    even if I did, it doesn't matter - the user name and password aren't what show in the game, it's the username of the plr file. Even though I logged in as J. Bollocks, I was showing as S. Thomson in game.

    The username and password are just for validation on the SimBin (or whatever) lobby, you don't need validation for LAN or Direct ip games, but you do need something in there to progress to the server password screen.
  20. No games available... And i tested everything the link says i should test. Is the Ip adress you pm'd me yesterday still the same?

    I see nothing in the lobby. Only black text "no games available"

    Am i the only one inhere with this problem of the old league racers?