• "Auto racing began 5 minutes after the second car was built." - Henry Ford
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

Euro Truck Simulator 2 Bug Reports

Discussion in 'Euro Truck Simulator 2' started by Marcel vd Aa, Oct 20, 2012.

  1. Marcel vd Aa

    Marcel vd Aa
    AC Paint Guru

    Messages:
    1,771
    Ratings:
    +426
    Post your bug report here for game version 1.1.1

    Bugs found sofar:
    • The world/ engine needs some optimization..especially in city areas the fps drop is significant.
    • Sometimes when coming to a hard stop and having neutral gear on the truck moves backwards after coming to a stop.
     
    • Like Like x 2
  2. Kai Lohmann

    Kai Lohmann

    Messages:
    626
    Ratings:
    +362
    Agreed to the above atmost to the fps drops and also:

    - AA needs to be applied anywhere..fences and so on its not working properly
    -Vsync doesnt work properly

    Running a i52500K and gtx570phantom
     
  3. Scott Webber

    Scott Webber

    Messages:
    7,392
    Ratings:
    +2,397
    my FPS drops dramatically, no matter what settings i have / resolution or Refresh Rate the FPS lag, sometimes it's like the game goes in slow motion for 3 seconds then carrys on normal, it's quite frequent for me.

    Running a i5 2500K 4.0Ghz , 8GB DDR3 , ATI 7870 2GB
     
    • Like Like x 1
  4. Vangelis Parginos

    Vangelis Parginos
    Greek SimRacing Community Premium

    Messages:
    1,338
    Ratings:
    +1,947
    I got a sound problem, inside the cabin is like im driving a sound proof car, the engine sound is so low i dont know if the engine running. Anyone else with the same problem?
     
  5. Senad Subasic

    Senad Subasic

    Messages:
    8,711
    Ratings:
    +1,901
    Yes, noticed that as well, have to look at the rev counter to know when to change gear. Perhaps that's the normal sound level in cabins?
     
  6. Vangelis Parginos

    Vangelis Parginos
    Greek SimRacing Community Premium

    Messages:
    1,338
    Ratings:
    +1,947
    I watch many gameplay video's at youtube and the sound is much more higher than mine, i have try everything in audio setup. I even change my set up to 2.1 because i dont think it ets2 has surround support, but no go!!!
     
  7. J van E

    J van E

    Messages:
    133
    Ratings:
    +26
    The only bug I have is bas FSAA. Seems very lowres, specially in the distance.

    I have great fps and no real drops btw with everything completely maxed out (i5 2500K @ 3.3, GTX580).
     
  8. thrumastyre

    thrumastyre

    Messages:
    14
    Ratings:
    +2
    when i click in race and then in world it sads: "invalid login:please register"
     
  9. J van E

    J van E

    Messages:
    133
    Ratings:
    +26
    Before I call this a bug... I noticed a temperature reading in my cockpit: it said something like 85 C. I wonder if that's the engine temperature (in which case it probably could be right) or the outside temperature (in which case it's a bug...). ;)

    BTW Just bought the game and started a new profile. Payed extra attention to performance. I do get a hickup every now and then (random) but it's always one skip of frames, never a constant drop in fps... It doesn't happen enough to annoy me or to even notice it (I mainly noticed it because I payed attention because of all the bad performance reports here).
     
  10. thrumastyre

    thrumastyre

    Messages:
    14
    Ratings:
    +2
    invalid login: please register
     
  11. J van E

    J van E

    Messages:
    133
    Ratings:
    +26
    What I would also call a bug: getting a ticket for driving through red when the light goes red after the front of the truck has already passed the traffic light. Just now another stupid AI stopped in the middle of a corner and the light turned red while I already passed the light: red ticket.
     
  12. Márcio Oliveira

    Márcio Oliveira

    Messages:
    12
    Ratings:
    +4
    hi, does anyone have problem to look left or right inside cockpit? I can't look. its like the camera is stuck :S it moves like bug in a fraction of second. even if I move the mouse quickly cant get it to move. outside camera works fine. what could it be? I use wheel g27 although I tried with a controller too (even set the look left / right axle to see if works)
     
  13. Dave Stephenson

    Dave Stephenson
    Technical Administrator Staff Premium

    Messages:
    8,972
    Ratings:
    +1,008
    Just a minor one.

    In the UK, the satnav still shows the route around roundabouts the European way.
     
  14. Adrian Britton

    Adrian Britton
    Banned

    Messages:
    405
    Ratings:
    +143
    I use my trackball to look about in the cockpit (would of thought the mouse does the same)

    I would like to know if some of the AI's have a bug, as it appears they are bit too easy on letting others out, even when its on a straight.
    I was sat in a queue for ages, as three down, there was a truck sat there letting traffic through.
    Also they can stop in the middle of the road and not move as your waiting to pull out, which results in me clipping them. :whistling:
     
    • Like Like x 1
  15. Senad Subasic

    Senad Subasic

    Messages:
    8,711
    Ratings:
    +1,901
    Clockwise/counterclockwise? I think mine showed correctly.
    Then again, I did a couple of Anglo-French routes, so could be mistaken. Haven't killed anyone in a roundabout yet :D

    Bah, had that as well, two trucks and three cars ahead, letting everyone through for 5 minutes at least.
    Had to reverse in that small space, and change lanes. But of course, as soon as I did that, I stopped the traffic coming from behind, so the idiots in front finally moved :D
     
    • Like Like x 1
  16. Dave Stephenson

    Dave Stephenson
    Technical Administrator Staff Premium

    Messages:
    8,972
    Ratings:
    +1,008
     
  17. CFG9000

    CFG9000

    Messages:
    6
    Ratings:
    +1
    - Running an HD 7970: great fps on high, but screen flickering and artifacting is common

    - UK speed traps are all screwed up. Constantly getting fined for doing 45mph in a 50mph.

    - Random damage happening that I'm not being informed of. Sometimes I go to check up on my damage and find that I've received 8% cargo damage from apparently nowhere.

    This whole game is a bug, frankly.
     
  18. Márcio Oliveira

    Márcio Oliveira

    Messages:
    12
    Ratings:
    +4
    I tried in my laptop with the computer euro truck profile (in docs folder) and works good. and then went back to my computer did a new profile and still cant use look inside cockpit. tried without the wheel, only keyboard, and still nothing. any ideia?? i'm stuck.
     
  19. rachmat_f

    rachmat_f

    Messages:
    2
    Ratings:
    +0
    I had a similar case, when I play using a 5.1 speaker system (Logitech z5500), the sound in the cabin can be said to be very silent or sound-proofed, I can not hear the engine sound, turbocharger whistling, etc.. but when I try to use 2.1 speaker system (Logitech z623), the sound in the cabin is very clear. according to my opinion this game not too support to use 5.1 speaker system. btw, i use sound blaster X-Fi titanium fatal1ty champion series.
     
  20. sfy

    sfy

    Messages:
    18
    Ratings:
    +6
    i noticed in the dash of the valiant f16h, it said the temperature at 4:30 in the morning was 88 Celsius. didnt notice it on other trucks, but wasn't looking either.


    EDIT: noticed when i started the truck again, it was the thermostat showing that temperature.