Thrustmaster tx ffb

Discussion in 'Euro Truck Simulator 2' started by Kurupt CDN, Feb 21, 2016.

  1. Kurupt CDN

    Kurupt CDN
    DirtT Tuned Motorsports

    Messages:
    2,222
    Ratings:
    +1,501
    I can feel vibrations, bumps, curbs and all other ffb effects but the wheel is completely light and has no resistance when turning....the only way I can fix this is by turning spring to 100% in the thrustmaster profile.
    Is this normal or anyone have a possible fix for this?
    I downloaded the ATS demo and it's the same.

    Cheers
     
  2. jimortality

    jimortality
    Premium

    Messages:
    3,746
    Ratings:
    +1,022
    Yeah spring and everything in tm control panel turned up. There was a plug in done for logitech wheels but never anything for us TM owners.
     
    • Like Like x 1
  3. Kurupt CDN

    Kurupt CDN
    DirtT Tuned Motorsports

    Messages:
    2,222
    Ratings:
    +1,501
    Thanks jim,
    I did some research on there forums and found that there isn't any tire model ffb in the game, just canned effects to to imitate engine and bump vibrations and to compensate for the light wheel wheen turning was to enable spring and dampening within your wheel profile.

    Cheers
     
    • Like Like x 2
    • Beer Beer x 1
  4. Metalogic

    Metalogic
    Premium

    Messages:
    555
    Ratings:
    +134
    So do Logitech owners get tyre FFB in ETS 2 or are they in the same boat as Thrustmaster owners? Just wondering as am pondering buying a wheel, mostly for RaceRoom Racing Experience, but I also play a lot of ETS 2 and was think of getting the Thrustmaster TX package with the leather rim and T3PA pedals, or else a Logitech G920 or even G27...
     
  5. acrox999

    acrox999

    Messages:
    40
    Ratings:
    +10
    According to the author of the FFB plugin, he said there are only real vibrations from actual tire and road collisions, thanks to the telemetry SDK. I don't know if that means he got tire FFB working but I can't tried it out since I don't know why, my G29 suddenly refuses to work with the plugin after a few months of not using it (since I got the T300RS). I wasn't the only one though, can't do anything about it since the author can't seem to bother with an issue only reported by 2 people or it could just be me that's not satisfied by how terrible the G29's FFB is.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.