Thrustmaster T100 malfunctioning. Advice needed.

May 26, 2014

I've recently acquired a Thrustmaster T100 wheel for the PS4. I bought it as spares and repairs, the seller advised that it powered on and the wheel worked but there was a problem with the pedals. He hadn't opened the unit up or anything though so I figured I'd take a chance.

Anyway, I've been using Project Cars to test it. The steering and FFB works fine and initially the accel and brake worked fine, RESULT I thought! But then the 2nd time I went to use it, they didn't work. The brake worked fine but the accel didn't.

I went into settings to calibrate the pedals and no response from the accelerator so I opened the unit up. I tested the pedals with the cover off and this is the strange thing, they work absolutely fine. I fiddled with the potentiometers and they both work fine too. It looked like perhaps the case was pushing the contacts on the potentiometers when closed so I cut some of the case off (on the inside).

Now this is where I'm stumped. Whenever I put the case back on, as soon as I depress the pedals slightly (which you have to do to get the case back on) they engage the L2 and R2 buttons (on project cars in the calibration screen the "calibrate ffb" and "calibrate pedals" buttons both become highlighted). When the case is then screwed back on, the accelerator doesn't work anymore and I'm back to where I started.

I really don't know what to do, obviously I know the warranty is void but it just feels like it's something that can be fixed, I just don't know how.

Any ideas or advice would be much appreciated.