1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[solved] Run-time error Windows 7 racer.exe

Discussion in 'Racer Problems & Fixes' started by modfox, Sep 14, 2013.

  1. modfox


    I just downloaded 0.9 RC7, RC6, and an older 0.6 version all of which will not run on my machine running Windows 7 64-bit. Below is a snapshot of the error as it comes up for 0.9.0 RC6. The error that pops up matches the content of the logged messages in QLOG. I cannot even get to the main screen. All I get is a black window where the splash screen has yet to even begin loading when the error occurs. Browsing forum for other troubleshooting posts I checked and indeed my graphics card driver is up-to-date for my NVIDIA Quadro FX 1800M so no issues there. Any thoughts on why racer isn't loading properly?

    0x609A317D [nvoglv32]: (filename not available): DrvPresentBuffers
    0x609A32A6 [nvoglv32]: (filename not available): DrvPresentBuffers
    0x60207A56 [nvoglv32]: (filename not available): (function-name not available)
    0x6092424E [nvoglv32]: (filename not available): DrvPresentBuffers
    0x601F04BB [nvoglv32]: (filename not available): (function-name not available)
    0x601F06F5 [nvoglv32]: (filename not available): (function-name not available)
    0x601F139F [nvoglv32]: (filename not available): (function-name not available)
    0x60213A15 [nvoglv32]: (filename not available): (function-name not available)
    0x602139A8 [nvoglv32]: (filename not available): (function-name not available)
    0x6082190B [nvoglv32]: (filename not available): (function-name not available)
    0x6021387D [nvoglv32]: (filename not available): (function-name not available)
    0x60825677 [nvoglv32]: (filename not available): (function-name not available)
    0x608261D9 [nvoglv32]: (filename not available): (function-name not available)
    0x60826880 [nvoglv32]: (filename not available): (function-name not available)
    0x602BC747 [nvoglv32]: (filename not available): (function-name not available)
    0x00452276 d:\source\trunk\dev\src\libs\d3\dtexture.cpp (line 855): DBitMapTexture::FromBitMap()
    0x004524E3 d:\source\trunk\dev\src\libs\d3\dtexture.cpp (line 749): DBitMapTexture::DBitMapTexture()
    0x0046AC61 d:\source\trunk\dev_racer\src\lib\rmanager.cpp (line 1807): RManager::Create()
    0x00403706 d:\source\trunk\dev_racer\src\mrun.cpp (line 1785): Setup()
    0x00403EF1 d:\source\trunk\dev_racer\src\mrun.cpp (line 2182): Run()
    0x00401675 d:\source\trunk\dev_racer\src\main.cpp (line 274): main()
    0x004016F3 d:\source\trunk\dev_racer\src\main.cpp (line 281): WinMain()
    0x0059D1BB f:\dd\vctools\crt_bld\self_x86\crt\src\crt0.c (line 263): __tmainCRTStartup()
    0x75BD33AA [kernel32]: (filename not available): BaseThreadInitThunk
    0x77D79F72 [ntdll]: (filename not available): RtlInitializeExceptionChain
    0x77D79F45 [ntdll]: (filename not available): RtlInitializeExceptionChain [%s]
    Fri Sep 13 21:40:57 (INFO ): [racer] Going to crash, reason: qfatal [qdebug.cpp:432 / QCrash]

    Attached Files:

  2. Alexander Knoll

    Alexander Knoll

    hmm...sounds like your grafikcard is to weak...
    1800M ->M=Mobile? ->Notebook?
    ..do you tried the nocg version of racer? the exe is at the main folder...
  3. modfox


    Hey, thanks for the reply. The graphics card is on a laptop as you guessed. Though not top end for a laptop its comfortably in the middle of the road and I suspected it should be able to run "nocg" or an older version of the game which actually was not happening. Googling the apparent cause of problems with the nvoglv32.dll file (in the QLOG file) I found that this is an NVIDIA code library and so I searched NVIDIA's website and found an alternate driver here which actually solved the issue: http://www.nvidia.com/object/quadro-notebook-win8-win7-64bit-320.86-whql-driver.html
    I can now run all versions including the standard (not the "nocg") with 40+ fps. :)
    • Like Like x 1