rFactor 2 Build 906 now available

Ryan Ogurek

2000RPM
Premium
Apr 13, 2014
2,211
1,379
30
launcher1.png

Image Space Incorporated has released a new update for rFactor 2. The update includes the first step of implementing the new UI menu, which will include "simplified activation, updating, mod downloading, installation and verification features."

launcher2.png


Here's the full changelog as stated by ISI:

"Update 28 (Build 906) Changelog Dec 11, 2014):


FEATURES:
————-
Added code to allow non-linear analog gauges.
Added some feedback to 3 AI parameters to dev mode AIW editor (corner caution:, understeer throttle cut:, understeer lat) so that you can watch in realtime as they have an effect.
New Launcher UI.
New remote content package manager integrated with Launcher UI.
Simplified activation process.
Sync Manager now restarts Launcher after update installation with original permissions.


BUG FIXES / OPTIMIZATIONS:
————-
Fixed intermittent crash on vehicle load.
Fixed rain volume which became too loud for some reason.
FXAA fix for monitor.
Fix for extraneous window in ded server mode.
Possible fix to 1st time failure downing vmod install failure on game connect in cases where vmod and components already downloaded but not installed.
Set lower default spotter volume.
Changed the small rfm, veh, and track main page display buttons to not load an image if their image size is set to 0 in either dimension. This is to prevent crash if a UI should have them on the same page as one of another gizmo that uses those assets (and destroys them).
Fixed bug with options not always remembering rfm/vehicle/track list/menu preference.
Fix for replays not loading some *.mas skins. (skins shared over multiplayer may still not load)
Potentially fixed names running over the HUD menus with a new HUD parameter & a fixed algorithm.
Fixed 64 bit Dev Mode inablity to save AIW files.
Fixed a potential crash upon starting AIW editor.
Fixed pit menu selected box from being too small in some cases.
Fixed HUD message center messages from extending beyond the box in some cases.
Fixed bug where virtual vehicles created with a *.mas loose skin file instead of a *.dds skin file wouldn’t show the correct skin in the spinner or on track.
Fixed a rare buffer overrun error in track name text display.
Changed replay letterbox to extend the entire width of the screen instead of just inside the options extent.
Attempted fix for occasional vehicle load/unload loop that appeared to cause network lag.
Fixed some multiplayer “Get Mod” issues with downloading/installing components and cleaned up the UI to be more readable.


UI / HUD / OPTIONS:
————-
Added APP_TextValue_GarageTireLoad_FrontLeft, APP_TextValue_GarageTireLoad_FrontRight, APP_TextValue_GarageTireLoad_RearLeft, APP_TextValue_GarageTireLoad_RearRight Gizmos back. (not yet used in default options)
Created gizmos for replay mode, length and current position. (not yet used in default options)
Renamed “binkanimations” to “genericanimations” since they not longer use bink
Added HUD parameter for pit menu maximum length.
Added an “instant update” parameter to vehicle and track lists for options that forgo the “accept”/”cancel” mechanism.


MULTIPLAYER:
————-
Broke up installing of downloaded components on multiplayer join so that the options have a chance to update and get a little bit of ui feedback to the user about what the game is doing


GRAPHICS
————-
Modified scene post-gamma value to improve color balance.
Ambient boost removed, no longer needed with improved scene gamma.
Improved some HDR automation parameters.
HDP files now deprecated and are disabled by default. HDP files can still be enabled via the plr file option ‘Enable Legacy HDR Profiles’.
Removed specular floor value, which was causing incorrect highlights at night.


CONTROLLERS / FFB:
————-
Added a Controller.JSON value “Steering Torque Capability” in order to specify the strength of strong FFB wheels (like direct drive). If this is set properly, and it exceeds the NominalMaxSteeringTorque for a given vehicle, it allows a 1:1 correlation between the calculated torque and the actual FFB torque. (However, note that we still don’t model power steering, so the calculated torque is stronger than it should be for some vehicles.)
Increased the number of buttons per controller supported.


MODDING / PUBLIC DEV:
————-
Updated the component mas file loading (for tracks only) to remove irrelevant layout mas files.
Dev Mode: When editing AI driver parameters we now change the driver to match selected car in the editor window automatically when bouncing between cars


PLUGINS:
————-
Set the mLastImpact* variables in the telemetry plugin interface.
Made plugin interface to add chat messages work on dedicated servers.
Fixed a few things with the Internals Plugin weather interface, and added a new option to apply cloudiness instantly.
"

Join the discussion in our dedicated rFactor 2 forum, check out awesome screenshots and videos in our rF2 gallery, get racing in our rF2 Racing Club and Leagues and make your game even more awesome with some rFactor 2 mods!
 
Jul 31, 2011
168
59
uh, i was planning on not playing sim racing tonight and to do some CS:GO playing... guess what?! CS:GO keeps crashing and there's a new rF2 build :)
 
Oct 20, 2010
299
269
I have a question about that: Some weeks ago, I've made a dual rF2 installation (the first with the current build and the 2nd with the brand new), and after have decided to uninstall the useless one (the first), the 2nd was also uninstalled ! And I didn't wanted to !
How to avoid that please ?
The first was in C:\ Programs Files\rFactor2 and the 2nd in C:\Programs Files\rFactor2bis
 

Juergen

250RPM
Jan 11, 2011
371
80
I have a question about that: Some weeks ago, I've made a dual rF2 installation (the first with the current build and the 2nd with the brand new), and after have decided to uninstall the useless one (the first), the 2nd was also uninstalled ! And I didn't wanted to !
How to avoid that please ?
The first was in C:\ Programs Files\rFactor2 and the 2nd in C:\Programs Files\rFactor2bis
It`s not your fault. Afaik the rF2 Installer overwrites the windows registry entries for each new installation.
 

Blkout

2000RPM
Aug 2, 2010
2,750
592
44
Looking for help here from anyone that might have encountered this issue but after installing the 906 update yesterday, every time I try to start a race, my FOV is screwed up. I can't see any of the interior of the car except the windshield and it looks like I'm slightly looking up at the sky instead of straight ahead. I've tried changing the camera, moving the seating position and even deleting my user files and nothing has fixed it yet. I'm at work now but if someone needs me to post a screenshot I'll do it later when I get home. I was just hoping someone has seen this before and knows the fix off-hand.

I just want to add that I also just switched the Fanatec CSW v2 wheel and I installed the update at the same time that I added the wheel so I know my control cfg has to be redone. The thought had crossed my mind that maybe a button was mapped incorrectly causing the FOV to be screwed up. I have tried removing all button mapping in the camera menu but that didn't fix the issue. The only thing I haven't tried yet is to launch the game with the wheel off so that it doesn't recognize it. I don't even know if the wheel is the issue but I just wanted to mention it.
 

Juergen

250RPM
Jan 11, 2011
371
80
Looking for help here from anyone that might have encountered this issue but after installing the 906 update yesterday...
Try to rename your UserData/player folder e.g. _player and start rF2 again. rF2 should make the files new.
 
Sep 8, 2013
595
242
Looking for help here from anyone that might have encountered this issue but after installing the 906 update yesterday, every time I try to start a race, my FOV is screwed up. I can't see any of the interior of the car except the windshield and it looks like I'm slightly looking up at the sky instead of straight ahead. I've tried changing the camera, moving the seating position and even deleting my user files and nothing has fixed it yet. I'm at work now but if someone needs me to post a screenshot I'll do it later when I get home. I was just hoping someone has seen this before and knows the fix off-hand.

I just want to add that I also just switched the Fanatec CSW v2 wheel and I installed the update at the same time that I added the wheel so I know my control cfg has to be redone. The thought had crossed my mind that maybe a button was mapped incorrectly causing the FOV to be screwed up. I have tried removing all button mapping in the camera menu but that didn't fix the issue. The only thing I haven't tried yet is to launch the game with the wheel off so that it doesn't recognize it. I don't even know if the wheel is the issue but I just wanted to mention it.
I did the same updates (core + csw base) yesterday and have no problems. So it seems to be a problem at your end.
I would try what @Juergen Herrmann has suggested.
 

Juergen

250RPM
Jan 11, 2011
371
80
Sometimes it could be messing, if you have selected a gear with the shifter, while trying to map buttons.
 

Tr3voRR

500RPM
May 10, 2013
683
167
How to activate HDR ? what is the plr file please ? Never mind I found how, it's not even a .plr file... it's a different extansion !
 
Last edited:

Blkout

2000RPM
Aug 2, 2010
2,750
592
44
Try to rename your UserData/player folder e.g. _player and start rF2 again. rF2 should make the files new.
Good call. I'm back in action. Strangely though, I deleted all of the files in my player folder last night and it didn't seem to help. The only thing I did differently today was rename the player folder per your suggestion and I didn't let the game detect my wheel, I just mapped the buttons from the keyboard setting instead of choosing the Clubsport preset. I deleted my old _player folder after the new one started working correctly.