Problems creating skin for Cobra 427 (Kunos)

CobraCat

500RPM
Original poster
Jun 7, 2016
862
509
I'm using the supplied CobraBody.psd file and when I apply paint to the Layer1 layer, the car appears black (when viewed in game) regardless of what color I use. I've painted other cars with no issue. Any suggestions ?
 

Kweel

100RPM
Jul 23, 2016
185
214
40
yeah first think dont use layer 1, paint is always before ao
2nd dont use black alpha layer lol
(black alpha means in this case zero transparency)
edit my mistake the skin use metaldetail.dds so if you want to use it too set a semi transparent alpha
 
Last edited:

CobraCat

500RPM
Original poster
Jun 7, 2016
862
509
Ok cool. Although its strange as every Cobra skin contains a CobraBody.dds file and not a one metaldetail.dds file.
 

Kweel

100RPM
Jul 23, 2016
185
214
40
euh nothing weird because metaldetail is already on the car, like all other texture
 

Hoksu

500RPM
Premium
Aug 15, 2017
651
885
euh nothing weird because metaldetail is already on the car, like all other texture
Most Kunos cars use metal_detail.dds for main body color of the car, with the skin file does decals, stripes, different colors. Kunos do that even with cars that don't have metallic paint or carbon fiber on the main body so the exact same result could be achieved with txDiffuse and all-white alpha. Cobra is originally a mod that was made into official content, maybe that has something to do with it.

OP, did you check alpha channel? Also AO layer needs to be in multiply mode, otherwise layers below will not appear
 

CobraCat

500RPM
Original poster
Jun 7, 2016
862
509
Deleting the alpha channel resolved the issue. All I wanted was a variety of solid colors, no decals, etc. Thanx!