Oculus DK2 Help

Shaun Clarke

1000RPM
Original poster
Premium
Nov 20, 2014
1,911
3,322
45
Hi All,

I am really hoping somebody can help me here. For no reason, my DK2 has stopped working. It will not pick up the HDMI or USB3 for the headset, but the sensor is ok (in either USB3 or 2 ports)

I have updated Video drivers, there is no updated USB3 drivers, I have uninstalled Oculus software, re-installed Oculus software, tried different HDMI sockets (I only have 1 x single screen) tried different USB3 sockets.

I have unplugged the cables in the DK2 headset and plugged them back in, but there is no light on the headset.

In Device Manager there is a Oculus VR Devices and shows Rift DK2 Sensor.

I don't know what else to try, so any suggestions would be very gratefully received

Regards

Shaun
 

Jordan Dion

Bluestar Racing
Jan 11, 2017
621
269
34
1 - did you tryed an other hdmi port on your pc?

2 - did you try installing beta or non beta Oculus driver.

3- try reinstalling Nvidia drivers

4 - look at the HDMI cable on the side of the headset. Disconnect and connect it. You should also check the cable condition.