• 26500+ Members! Dear Guest, click this link to join the community on the official RaceDepartment Discord server

My MR18 badly bogs down!

Msportdan

@Simberia
Mar 17, 2014
2,962
564
42
i cant keep up with the AI off the line, i get good revs but as soon as the torque kicks in my metalmoro bogs down and the AI pull away.

Anyone have this?
 

Fernando Zart

250RPM
Aug 20, 2008
475
132
If you're talking about the race start, it takes time/practice to start without loosing too much rpm (i.e., modulate the clutch to avoid spinning and keep rpm in the right zone). If you don't use clutch, try to use launch control button (dunno if the Metalmoro has one).
If on the other hand you're not talking about the race start, then the only thing I can think of is to check if you don't have pit limiter engaged by mistake or maybe try to reduce the AI strength a little.
 

Jan Mikuž

1000RPM
Nov 21, 2013
1,057
174
40
Yeah, it's either a bug or it's just the way this car is made. I use autoclutch and the rpm drops heavily at the start, eventhough i have the throttle pedal pressed to max.
No other car behaves like this and i'm able to maintain high revs at the start and get off the line in a normal manner.
 

Renato Simioni

Reiza Studios
Jan 6, 2010
1,649
5,246
This has been updated in v1.27 but apparently not enough. The engine does not have a lot of torque in the low range so you would want to keep the revs up for a strong start, but it is indeed bogging down too much. It will be looked into for the next update.
 

Msportdan

@Simberia
Mar 17, 2014
2,962
564
42
Thanks Reiza. dont get me wrong the MR18 is a quality car to drive once its away... its just getting it away hehe :)

cheers
 

What is your favorite social network?

  • Twitter

    Votes: 109 31.0%
  • Instagram

    Votes: 140 39.8%
  • Facebook

    Votes: 62 17.6%
  • Other (specify in thread)

    Votes: 75 21.3%