Skins Kunos Preview Builder

Ryno917

1000RPM
Original poster
Dec 5, 2013
1,570
1,172
33
I'm working on a set of skins for a car that uses a custom shader, so I can't generate previews with CM unfortunately. I've run the kspreviewbuilder, but the previews are quite dark. It doesn't seem like the exposure settings in any of the .ini files have any effect at all.

Anyone have any idea how I can brighten the previews up without processing in Photoshop?
 

Ryno917

1000RPM
Original poster
Dec 5, 2013
1,570
1,172
33
First I would contact the CM developer. He can be very helpful.
I did a couple days ago, and he said he does plan to add support for custom vehicle shaders but is working on the shaders/lights patch first :)
 

AlleyViper

500RPM
Oct 29, 2015
984
726
I'm working on a set of skins for a car that uses a custom shader, so I can't generate previews with CM unfortunately. I've run the kspreviewbuilder, but the previews are quite dark. It doesn't seem like the exposure settings in any of the .ini files have any effect at all.

Anyone have any idea how I can brighten the previews up without processing in Photoshop?
Have you added FILTER=S1-Showroom (assuming the default kunos filter for previews/or your intended one is correctly installed at Program Files (x86)\Steam\steamapps\common\assettocorsa\system\cfg\ppfilters) at the end of Documents\Assetto Corsa\cfg\preview_video.ini?

It's not very clear on the instructions (they are actually wrong, by pointing to showroom_start.ini to call filters), but you must call the filter you'll use on previews from preview_video.ini. That file acts like a "video.ini" exclusively for kspreviewbuilder. Using a regular filter such as "default" (which comes selected by default on the vanilla file) will produce very dark previews. That file should also have reflections set in high detail.

Ex of a preview_video.ini that generates 4K images (can be used with a lower resolution monitor, because it's set to windowed mode) with S1-Showroom filter and highest detail to be later downsampled to 1024x574 by checking it under kspreviewbuilder:
Code:
[VIDEO]
FULLSCREEN=0
ANISOTROPIC=16
AASAMPLES=8
VSYNC=1
AAQUALITY=0
SHADOW_MAP_SIZE=4096
DISABLE_LEGACY_HDR=1
FPS_CAP_MS=16.666667
WIDTH=3840
HEIGHT=2160
REFRESH=60

[CAMERA]
MODE=DEFAULT       ; DEFAULT | TRIPLE

[EFFECTS]
MOTION_BLUR=0
FXAA=0               ; doesn't work with OCULUS
SMOKE=3
RENDER_SMOKE_IN_MIRROR=1

[CUBEMAP]
SIZE=2048
FACES_PER_FRAME=6
FARPLANE=500

[MIRROR]
SIZE=1024
HQ=1

[ASSETTOCORSA]
HIDE_ARMS=0
LOCK_STEER=0
WORLD_DETAIL=5       ; 0 to 5
HIDE_STEER=0

[SATURATION]
LEVEL=100

[POST_PROCESS]
ENABLED=1; on (1) or off (0)
HEAT_SHIMMER=1 ; on (1) or off (0)
RAYS_OF_GOD=1 ; on (1) or off (0)
FXAA=1 ; on (1) or off (0)
QUALITY=5
GLARE=5
DOF=5
FILTER=S1-Showroom
 
Last edited:

Ryno917

1000RPM
Original poster
Dec 5, 2013
1,570
1,172
33
Thank you @AlleyViper ! My .ini files didn't have the line calling out the PP filter to be used in them. I was tearing my hair out trying to find it. I'll give that a go this evening and see if I can get some nice results.

Thanks again!
 
  • Like
Reactions: AlleyViper