Frame hitching every few seconds. Can't figure out what's causing this only in ACC.

Hey guys, question about this annoying thing that only seems to happen in ACC for me. I've seen other people mention this "frame hitch" or "stuttering" while driving and it seems I am having this very annoying problem too.

I have solid FPS around 120 with a 5600x, 16gigs of 3600, and a 3080rtx. Even with the framerate rock solid I get these "hitches" which throws immersion right out the window.

I've tried all Vsync on/off etc. limit frames etc. but can't seem figure out what is causing it. ACC is the only sim/game that causes this. Anyone else experience this that has found a fix?

Thanks for any help!
Derek
 
186
175
Paris
Hey guys, question about this annoying thing that only seems to happen in ACC for me. I've seen other people mention this "frame hitch" or "stuttering" while driving and it seems I am having this very annoying problem too.

I have solid FPS around 120 with a 5600x, 16gigs of 3600, and a 3080rtx. Even with the framerate rock solid I get these "hitches" which throws immersion right out the window.

I've tried all Vsync on/off etc. limit frames etc. but can't seem figure out what is causing it. ACC is the only sim/game that causes this. Anyone else experience this that has found a fix?

Thanks for any help!
Derek

i Just had the same problem with the exact same configuration .
Game was unplayable .
I thinked it was linked to windowed mode... but never understand what was the problem.
I also changed every settings in nvidia panel, in game, on my screen.
And then suddenly everything was good, no more stutters Just plain smooth it works flawessly now.
 
The obvious first step is to check GPU temperatures. I have a horrible problem with ACC right now where it seems to be triggering an x570 chipset bug that momentarily halts my USB subsystem & that really screws up my external soundbox, so these things can get a bit esoteric.

Can try disabling full-screen optimisation ( right-click AC2.exe, it's under Compatibility ).
 
Last edited:
i Just had the same problem with the exact same configuration .
Game was unplayable .
I thinked it was linked to windowed mode... but never understand what was the problem.
I also changed every settings in nvidia panel, in game, on my screen.
And then suddenly everything was good, no more stutters Just plain smooth it works flawessly now.
Strange isn't it? It was weird because a few days ago when I was racing it seemed perfectly smooth too. Nothing changed on my pc so not sure what the deal is but maybe mine will smooth itself out again on it's on hopefully haha.
 
The obvious first step is to check GPU temperatures. I have a horrible problem with ACC right now where it seems to be triggering an x570 chipset bug that momentarily halts my USB subsystem & that really screws up my external soundbox, so these things can get a bit esoteric.

Can try disabling full-screen optimisation ( right-click AC2.exe, it's under Compatibility ).
Thanks for the reply Richard.
My temps are CPU 53 and GPU 63 so temps are real good. I did disable full-screen opt and that didn't seem to do anything. Nicoboks mentioned his was doing this stutter thing then suddenly became smooth.

He wasn't sure what suddenly fixed it so I'm not sure what's going on but hopefully mine sorts itself out on it's own too.
 
Other things:

* Clean install of the video drivers
* Update chipset drivers
* Unplug any peripherals you're not using & replug them one by one if removing them all helped. If you can reproduce the issue via a replay I'd probably unplug everything other than the keyboard ( including the mouse ).
* Check to see if you're running unnecessary windows services ( I believe siltes like tenforums have lists of all of them & which ones you really need )
* Check what's enabled in Task Scheduler & remove anything you don't need there too. Quite a few annoyances seem to sneak in there these days.
* Get hold of Latencymon ( it's free ) & run it in the background while you're playing, it might give you some clues.
* Check to see if there's a usable newer motherboard BIOS.
 
Last edited:
Other things:

* Clean install of the video drivers
* Update chipset drivers
* Unplug any peripherals you're not using & replug them one by one if removing them all helped. If you can reproduce the issue via a replay I'd probably unplug everything other than the keyboard ( including the mouse ).
* Check to see if you're running unnecessary windows services ( I believe siltes like tenforums have lists of all of them & which ones you really need )
* Check what's enabled in Task Scheduler & remove anything you don't need there too. Quite a few annoyances seem to sneak in there these days.
* Get hold of Latencymon ( it's free ) & run it in the background while you're playing, it might give you some clues.
* Check to see if there's a usable newer motherboard BIOS.
Thanks so much for taking the time to write this Richard , I will try these!!
 
Just a follow up for anyone interested. I tried the things Richard suggested and this happens only with AI. I can run laps all day with rock solid fps for hotlaps.

AI is definitely causing the problem in my case. As I said earlier I can max just about every sim and game on my pc and get high frames so it's definitely something with ACC and AI for me just not sure how to fix it.

I understand with a field of AI the cpu/gpu is doing a lot more work but it will run high fps with sim maxed out with 21 cars but will hitch every few seconds and I noticed when it does the "hitch" I dropped like 10 fps or so just randomly then back to rock solid smooth. No other sim does this no matter how many AI. For some reason I'm just randomly dropping 10ish frames which causes stutter.

This happens no matter what settings I use. Lowest or maxed doesn't matter.

I realize most people seem to have no issue so it's frustrating. If my pc had any other issue with any other of the simulators or games that would be one thing, but it is ACC only.
 
1,019
866
Germany
With intel cpus I could only do 25 AIs on an i5 with 4 cores and 8 threads. Now with an i7 and 8 cores and 16 threads I can run a full grid and 49 AIs. The recommended setup from Kunos is 6 cores.

Differently to other sims ACC has full physics on all AIs, hence the CPU load.
 
With intel cpus I could only do 25 AIs on an i5 with 4 cores and 8 threads. Now with an i7 and 8 cores and 16 threads I can run a full grid and 49 AIs. The recommended setup from Kunos is 6 cores.

Differently to other sims ACC has full physics on all AIs, hence the CPU load.
Thanks for the info guys!!!
Disabling HPET is what ultimately solved it on my end.
 
Last edited:
Top