Fanatec McLaren GT3 wheel buttons randomly stop working

Discussion in 'Sim Racing Hardware' started by Warfalcon, Aug 26, 2018.

  1. Warfalcon

    Warfalcon

    Messages:
    15
    Ratings:
    +1
    Just curious if anyone else has this issue? I know some do that I ran into on other forums. I RMA'ed mine and the new one sent is doing it as well. I have tried 310, 311 and 312 beta and still have the problem.

    If you have yours on a wheel base that is not a Fanatec base do you ever have this problem?

    I have a CSW v2.5 base. I have two other wheels from Fanatec that I have zero issues with. This is something with the firmware I believe. It will eventually start working again just randomly. I do not have to exit the sim or restart hardware.

    Someone else I spoke w/ also RMA'ed and got a replacement that was also doing it so that is why I think this is a firmware issue.
     
  2. johndough247

    johndough247
    Premium

    Messages:
    218
    Ratings:
    +108
    I'm on my 2nd McLaren GT3 Rim. The first one right out of the box had an issue: rotating the FunkySwitch didn't work properly. If I rotate clockwise only, it would go LEFT RIGHT LEFT RIGHT. Same thing if I rotate anti-clockwise.

    Contacted Fanatec and they wanted to RMA...I said no, because I had previously owned the BMW GT2 rim and that had a screen issue and I was getting tired of sending wheels back to them. They offered to send me a replacement FunkySwitch instead so I agreed. FunkySwitch arrives, I install it and...same issue.

    Contact Fanatec again and they say it's probably a Main board issue, so they could either send me the replacement board or I could RMA the wheel for a replacement. Decided to replace the whole wheel. Received wheel #2 yesterday and all was working well...until a few minutes ago. This time the shifter is missing downshifts. At first I thought it was me, but I parked the car and checked it out...it started with one missed shift, but later on it was missing 4 to 8 shifts in a row! I exited the game and checked the Fanatec control panel (In Windows)...the shifter is indeed malfunctioning as the dots that indicate a button was clicked would randomly not light up (it eventually started working better but now I'm worried It'll do it again).

    Both rims are/were on v311 and I'm using a CSW v2.5 as well. I also have a Porsche 918 rim that works perfectly.

    I really love the feel of this wheel but man...these quality control issues are getting to me (not to mention I had to wait 6 months on my pre-order to get it). I almost wish I had kept the first rim as that one didn't have the shifting issue :cry:
     
  3. White Hawk

    White Hawk

    Messages:
    76
    Ratings:
    +16
    This doesn’t look good, I had my rim for a couple of weeks and while time trailing in F1 2018 it wasn’t upshifting all the time, went into driver and it was doing it there, so currently it’s on its way back to them, got a feeling I’ll be getting a refund eventually as I don’t think this rim has the best quality control, my universal hub has been fine for years. I got the metal quick release for this too, hope there’s no issue with getting a refund or exchange for a different rim, might have to wait it out till the podium F1 rim comes out. :(
     
  4. racingenthusiast

    racingenthusiast
    Premium

    Messages:
    631
    Ratings:
    +118
    You guys using the fanatec hubs or osw?
     
  5. White Hawk

    White Hawk

    Messages:
    76
    Ratings:
    +16
    Fanatec CSW 2.0 here, in my case it was a hardware fault, the way it was behaving and no other buttons were doing it including the down shift it was obvious, but I think this rim is having both driver/firmware and hardware issues.
     
  6. DomB_Fanatec

    DomB_Fanatec
    Fanatec Community Manager Premium

    Messages:
    16
    Ratings:
    +16
    Hi guys, I'm just popping in here to say your feedback has been noted and we'd like to assure you that we're actively working on an investigation into these issues.
     
  7. johndough247

    johndough247
    Premium

    Messages:
    218
    Ratings:
    +108
    I’m really glad to see you’re also patrolling forums for customer grievances other than the Fanatec blog. Looking forward to getting this resolved soon, but all signs point to hardware failure.
     
  8. anton_Chez

    anton_Chez
    Premium

    Messages:
    604
    Ratings:
    +226
    Anyone with a McLaren rim that is using another wheel base will need to have it updated to the latest firmware via Fanatec customer service or another user that has a Fanatec wheel base. I use mine on my OSW conversion hub and I had problems with it. After I've received it back from Fanatec, I've never once thought about it. It works perfectly. Clutch paddles used to drop out and never come back, shifting was a little unreliable also. Now, perfect. I guess even if you are using a Fanatec wheel base and you haven't updated the firmware on the rim, I would recommend to do so. It may exhibit the same problems mine had.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.